WiFi not work - Volumio v2 Cubox-I

WiFi does not work with volumio-2.032-2016-11-27-cuboxi.img and volumio-2.029-2016-11-18-cuboxi.img
I tried volumio-for-cubox-coming-t4580-40.html
and wlan-device-with-volumio-029-2016-cuboxi-img-t5212-10.html
threads suggestions and it didn’t help
Could I kindly ask to fix it?

Please stop opening new threads for the same issue. Cubox and WiFi is WIP at the moment, 20 more threads won’t change that.

I find a work around, and it works on my Cubox-i4pro. Do the following steps on your Cubox as root.

  1. Download brcmfmac4330-sdio.txt file from the following link and put it to /lib/firmware/brmc
    wget -O brcmfmac4330-sdio.txt “http://forum.solid-run.com/download/file.php?id=52&sid=ae54e543af0e8a819b444575b0efb548

  2. Restart cubox, in order to reload the driver.

  3. After restart, do the following command, you should see wlan0
    iw dev

  4. Check connection status, should show not connected.
    iw wlan0 link

  5. Create a WiFi password file,
    wpa_passphrase [SSID] [WiFi_Password] > /etc/wpa_supplicant/wpa_supplicant.conf

  6. Connect to WiFi
    /sbin/wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

  7. To confirm it connected to your wif, you should see the SSID you provided
    iw wlan0 link

  8. Obtain IP address
    dhcpdc5 wlan0

  9. To confirm wlan0 has IP.
    ifconfig wlan0

In order to make it work during bootup:
systemctl enable rc.local
add the following before exit 0 in /etc/rc.local
sleep 5
/sbin/wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
/sbin/dhcpdc5 wlan0

You can reference this page:
linuxcommando.blogspot.ca/2013/1 … twork.html

Hope this help.