Wifi keeps going down on Zero w

Hi all,

I hope someone can advise me, I’m going crazy over the following…

Setup :

Netgear R7000 router 2.4/5Ghz (RPi on 2.4Ghz)
RPi 4 4G Volumio 3.233 & Hifiberry Dac + / 2A 5v phone charger
RPi 4 4G Volumio 3.233 & Hifiberry Dac + / 3A 5v original charger
RPi 4 4G Volumio 3.233 & Hifiberry Amp2 / 20v laptop charger
RPi Zero W Volumio 3.233 & Hifiberry DAC / 3A 5v external battery (30000mah, good for a few days)
RPi Zero W Volumio 3.233 & Hifiberry Amp / 2A 5v phone charger

All on scandisk ultra SD cards.

The Rpi’s 4 are running with no problems.

After installing a fresh volumio OS on the Zero’s the wifi keeps falling out, I am able to connect to the zeros but after 30sec it works very laggy, and the Zeros reboots automatic, there is the start up sound playing every ten minutes or so…(I hate that sound now :roll_eyes:)

Things I’ve done for now :
I have installed the OS on 3 different brands of SD cards.
Scandisk 128gb ,Kioxia 32gb and Transcend 8gb A1class 10 (They all work on the RPi 4) multiple times.
Installation made on the RPi4 and then when everything was setup put the card in the Zeros, multiple times.
Changed my wifi network name. No underscores.
Changed my rooter/modem. Rebooted my router.
Changed the powersuplys of the Zeros.
Installation made next to the router itself (no chance of bad signal)

No chance on getting the logs out because after the wifi signal is lost ( at least that’s what I think is happening ) I can’t get back in to the Zeros. (I still don’t have adapters to connect HDMI screen or keyboard)

Strange thing is the OS installed on the RPi 4 all work on all 3 SD cards on the RPi 4 but when putting them in the Zero W they both have the same problem. Wifi keeps falling out. So it must be I’m missing something here ???

Note : I’m a complete noob on ssh. So I use the app on Android to control the Rpi’s.

Edit :
Forgot to mention. The first time that I used the Zero I used an already configured SD card (on RPi 4) on the Zero and it worked untill I shut it down. After running one week. Soft shutdown and pulled the plug.

After I plugged it back in I never got it working again…

Please help :woozy_face:
Thanks in advance.


Depending on your locale you may need to set the country code for WIFI. Try:
sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

Check to see if following line exists:
CC is your two letter Country Code. If the line is missing or CC is wrong, edit with nano:
sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Some forums also recommend editing the the default crda file:
sudo nano /etc/default/crda

Hi thanks for your answer.
I live in Belgium so country code is ‘be’

I tried this but no succes :
*added the file to boot partician - *wpa_supplicant/wpa_supplicant.conf

I havent tried the crda file. Will try this evening.

It might be case sensitive. Try BE.

Done :
Fresh install, added the file to boot, country=BE*
Fresh install, ssh with the RPi 4, 2th option u mentioned.

Same frustrating result :confounded:
Other suggestions ?

Ok this happend :

Fresh install OS
sudo nano /etc/default/crda

It workt for like 2minutes, was able to install Mixcloud plugin (IP adres is 169.1.xx.x)
After that i tried to play something from Mixcloud → reboots automaticly (configuration updated, player succesfully restarted message)
IP adres changes to a complete different number 169.254.xxx.xx - after reboot .result connection lost.

Hard reset, In my Netgear settings i dissabled internet acces for the Zero Pi.
Added the Zero Pi to my multiroom and it works :exploding_head:

so conclusion when the Zero is had acces to the internet it crashes/reboots ?

Any suggestions ?

Thanks in advance

Did the same with the other Zero that i got.
As long as i keep the Pi’s off the internet they work fine, Sadly I cant add them to my multiroom without internet acces. As soon as i give them acces they start to reboot or dont respond anymore…

After i logged out on my premium account on the Zeros.
Put internet acces back on on my router for the Zeros.
They work just fine as they should.

So logging in to my account on the Zeros cause them to crash/reboot.
Some help would be very welcome now :woozy_face:


No one ?
Funny thing is i made a new (free) account, logged in and it works :upside_down_face:
Im being punished for having a Premium account ? :face_with_raised_eyebrow:


I bought another Rasberry Pi Zero 2 (Should have bought a RPi 4 that saved me alot of trouble but where is the fun in that :upside_down_face:)

RPi Zero 2W with Hifiberry Miniamp

  • Volumio-3.251-2022-03-31-pi fresh installed on sd card.

Disabled all my router firewalls, no luck.
Wel for 20seconds i could connect the multiroom and then it went out…

Logs :
http://logs.volumio.org/volumio/djq9eD6.html - with firewall - troubles start after activating MyVolumio on this device.
http://logs.volumio.org/volumio/mUEqeEw.html - without firewall

Suggestions ?
The Volumio support suggested i should try a DMZ or a Hotspot from my phone.
I tried to connect it to a hotspot but this gives me even more troubles and how to setup a DMZ is still a complete mystery for me now.

Kind regards.

For anyone who has the same problems,
Turns out this was a DNS problem

=> Enable custom DNS
fill in values

Zero works, even in multiroom

Grts !