Wifi connection drops after 20 minutes

Hi guys!

First of all thanks to the team for making Volumio. It is a great music player, but unfortunately I am having some problems with it.
I hope somebody can help me with this or, if there is an existing thread that can help me with my problem, point me in the right direction.

My setup: Raspberry Pi modell B Rev. 2, 2A power supply for the pi, a powered USB hub for a LaCie 160gb external harddrive, Edimax 7811un wlan dongle plugged in the pi, Hifiberry DAC.
I am currently using Volumio beta1.11, but i have previously tried Raspyfi and the Volumio beta 1 and 1.1.

The problem: When I start the pi most of the time everthing works fine, but when I for example start a radio station and let it play it will most of the time stop playing after 20 minutes, sometimes earlier. When it has stopped I cannot ping the pi or SSH into it, but the Edimax dongle is still visible on Fing. Sometimes it reconnects after a few minutes and some attempts to ping it, sometime it does not come up at all and I have to restart the pi.
When I leave the pi in idle the connection seams to be more stable. When I play a playlist with music from the harddrive the music will keep playing after the connection drops, but I cannot control Volumio anymore.

What I have tried so far: I tried Raspyfi and all the beta versions of Volumio. I tried the fixes for the Edimax power saving function, including the cronjob pinping the router. I tried using a static IP. I checked the dhcp leasing time (it is set to10080 minutes).

I searched the web for similar problems but did not come up with much,so I hope you guys can help me. Let me know if you need more information.

Greetings from Germany

Update : Still no reliable connection. After the beta 1.2 refused to connect to Wifi and had problems with the WebUI I switched back to my other SD card with beta1.1.

I noticed that the date/time on my Volumio was way off. After I reset my locale and getting the ntp server to connect I had an connection for more than two hours that was stable. The next day the problems were back again. Now the connections lasts longer than 20 minutes but only up to 35 minutes (not all the time). Sometimes the connection drops completely and sometimes the SSH session remains and I can restart MPD an the music starts playing again. All in all is it not possible for me to listen to a webradio station for more than half an hour.

I have been searching for similar problems on the net but didnt quite find a solution.
I looked through the option of my router but didnt find any restrictions for the Pi. Other wireless gadgets dont have problems with the wifi.

I hope someone might have a solution or a hint in the right direction.

on another note: How can I access the logfiles/errror messages? I tried several commands but all came up empty or did nothing at all.

Please help me. I like Volumio but with these problems I cant use it.

And another update: I am pleased to report that Volumio beta1.1 is up and running. My router has been the problem. I tried to update the router’s firmware before over it’s settings page but there where non available. Then I found a manual update on the manufacturer’s homepage and after the update the connection did not drop again. Now I have a rock-solid connection and play webradio for hours without a problem. I have no clue why just the Raspberry had problems with the connection and non of my other devices, but so be it.

I guess I will wait for the next version to upgrade and skip beta1.2 altogether. Beta 1.1 is running nicely so that is okay.

For the people who have a similiar problem and tried all the common fixes and tricks and still can not figure it out : Try and update your router’s firmware.


PS: Thank you achmed four your PM. I am still searching for the reply button.

im having a similar issue as well… wifi drops out after about 20minutes or so (in or around there). I can say with assurance it’s not my router as i’m using the pi as an access point.

heres the details:
Wifi: Bus 001 Device 005: ID 050d:705a Belkin Components F5D7050 Wireless G Adapter v3000 [Ralink RT2571W]
WPA2 if it matters.
pi is powered by a 1A usb hub.

What happens is I can be using airplay off my phone connected to the rpi’s ap and everything works. eventually the audio drops. turning wifi off then back on on the ios device shows the AP but it fails to connect. After it fails, it dissappears and reappears occassionally but I can never connect to it again.

checking dmesg i see this:
[ 2400.656608] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x30a0 with error -71

I was thinking perhaps it’s a hardware fault but the odd thing is as soon as the connection drops, while watching top, kworker (sometimes more then one) becomes the highest cpu usage. prior to this, shairport is using around 6 or 8% of the cpu and it’s the highest. as soon as the connection drops there is usually 2 kworker pid’s running totalling around 50% cpu… prior to the connection drop kworker is only a couple %.

rebooting the pi fixes the issue again for another 20 minutes or so.

while the wifi connection is dead, i can still access the device over lan and use airplay over my own LAN.

perhaps there is something else i can try?

Wait, are you using the Pi where Volumio is running as an access point? So, did you configured HostAPD on it?

yes. using hostapd i’ve setup a wireless ap. i setup nat so if i plug in at home i can still access it to copy music over/etc easily while being able to still get internet on a wifi device connected to it. i also made sure to not specify dns servers so i can still use pandora/etc over 3g on my iphones (specifying a dns server seems to kill the internet on the 3g since its trying to resolve hosts using the wifi ap that has no internet.

regardless, the dropouts seem to only occur if i use airplay. i’ve let my ipad sit idle connected to it for some time now and it hasn’t lost its connection but when i use airplay to stream something the audio drops out and the wifi turns dead.

Ok. Please make sure you disable power saving on your Wireless Adapter. BTW, the problem is likely to reside on your Hostapd configuration.