WiFi adapter on RPi 2 not ok with Volumio, but ok with Kodi

I bought a wifi adapter that according to the seller should work on Raspberry Pi, and indeed it worked with Kodi.
Now when I installed Volumio it does not work anymore, I posted this in the thread for compatibility of adapters:

Adapter Name: unbranded
Chipset: unknown
Driver/Firmware: unknown
Working with Volumio: NO
Tested Versions and Platforms: Volumio 1.5
Comments: works on Raspberry Pi 2, with OpenElec / Kodi, but not with Volumio.
Buying Link: aforyou.nl/wifi-adapter-usb-802.11-n

Is there anything that I can tweak in settings or something like that ?
Or is the only solution to buy a new adapter… :frowning:

If it works on other Linux distro, it will work with Volumio! But it could be due to missing driver firmware. Could please send more info about the chipset used ? What returns the command “iwconfig” ? and “lsmod” ?

All the info that I know about this wifi dongle, is in the link of the seller. No chipset is mentioned.
I don’t know yet how to perform the commands “iwconfig” ? and “lsmod” as you describe, but I will search this forum first to find out how that works. And then post the result.

Things are getting worse… Today I tried to connect via LAN cable, as I wanted to connect to the RPi with Putty (SSH).
I installed advanced IP scanner a couple of days ago, and then I could get the Voumio GUI via the internet browser on the found IP address.
But now Advanced IP scanner cannot find the RPi anymore.
I tried to ping the last known address, but no connection. Of course I don’t know if that was still the right IP adddress, because of DHCP,
but Advanced IP scanner could not find the RPi at all.
The 2 LEDs on the RPi are both red.

This evening I will try to re-install Volumio on the SD card, and see what happens.

Two red LED’s doesn’t sound too good? Have you tried pulling the power?

Yes, I tried to reboot several times, but always ended up with the same result: red LEDs and no LAN connection found by Advanced IP Scanner.

Can you add auto eth0 in /etc/network/interface (if you have a keyboard or putting the SD card on your pc

I removed the WiFi dongle, left the LAN cable connected and rebooted the RPi:
Now I can see the web GUI at the IP address as found by Advanced IP Scanner.
Then I inserted the Wifi dongle again, but did not reboot.
Next I tried to login to the RPi with putty, and entered the 2 commends as mentioned earlier. This is the result:

pi@volumio:~$ iwconfig
-bash: iwconfig: command not found
pi@volumio:~$ lsmod
Module                  Size  Used by
r8188eu               470025  0
nfsd                  276617  2
ipv6                  351566  34
snd_bcm2835            21342  2
snd_pcm                93100  2 snd_bcm2835
snd_seq                61097  0
snd_seq_device          7209  1 snd_seq
snd_timer              23007  2 snd_pcm,snd_seq
snd                    67211  8 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
uio_pdrv_genirq         3666  0
uio                     9897  1 uio_pdrv_genirq

Edit: I looked in another post, I see there the command sudo iwconfig was used, so I tried:

pi@volumio:~$ sudo iwconfig
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

Any ideas how to proceed ?

This auto eth0 is already in the file:

pi@volumio:/etc/network$ nano interfaces
  GNU nano 2.2.6              File: interfaces

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wireless-power off
wpa-ssid linksys1
wpa-psk ****hidden****

auto eth0
iface eth0 inet dhcp

Shouldn’t the wpa-ssid and wpa-psk be enclosed in quotes? ie. wpa-ssid “linksys1”

There probably will be clues in your log files too. Reboot and then ssh in and run:

sudo journalctl -b

Thanks for the suggestion, but this file was never changed by me, generated by the Volumio software I guess.

In the meantime I spent many hours in getting my Synology NAS connected, to stream the mp3 files from there.
But again I ran into all kinds of troubles (that other peolpe also reported before), like:

  • cannot mount the NAS
  • NAS disappeared from the Browse menu
  • When I select library, the roating arrow with the text connecting keeps running forever.
  • etc

I am now at the point that I am fed up with tweaking, testing and trying. It simply cost me too much time (days !) for just getting music streamed from my NAS to a couple of RPi’s.
Thank you all for the support, unfortunately it did not result in a working system,

I am done with Volumio, and will look for an alternative app for the RPi.

Have you tried Volumio 2? There is little support for 1.55 now, and it is certainly not being changed at all.

Thanks for the tip, I did a quick round of google, and I see that it is still under development.
I am a electronics and domotica fanatic, and I spend a lot of time on all kinds of DIY projects,
but for simply streaming music from my NAS, I don’t want to spend much time in setting it up.
So I am looking for an app that works more or less out of the box.