Why Volumio cannot handle reboot even after all these years?

I have used Volumio for years on Raspberry 1, 2, 2B and now 3. From the very beginning into newest Volumio version, Volumio cannot handle simple task of reboot/power outage.

I install Volumio to my raspberry precisely like in tutorial (write image with win32diskimager), and volumio even works for few restarts. After those, its upon higher deitys whether it restarts or no. Only thing that works after that is formatting microsd-card and fresh install. So basically fresh install of volumio has to be done every month.

-I have tried many different sdcard brands and problem persists regardless of sdcard brand/speed/whatever.
-my 5v USB supply is of excellent quality (3A)

  • I stream music from my NAS via ethernet

What am I missing here? I have also had XBMC/OSMC in other raspberry for years and years and i have never ever had a single problem with restart even after numerous power outages and cold restarts + numerous updates, it just keeps working. How can it be that Volumio cant handle this?

Please help as this is so damn frustrating. I love Volumio so much, but this problem is driving me nuts.

This would drive me nuts too, believe me :open_mouth:

If this would be a common issue, we would have heard about this issue before from many sides, honestly we haven’t.
Actually, we have gone to great lengths to avoid SD card corruption, the boot partition and rootfs are never written to!
Even logs are being kept in memory, so why your SD card can become unbootable after a power outage is a complete mystery to me :confused:
lt will be very tricky to locate this, so start with the obvious.

  • Which was the last Volumio version have you been running?
  • Do you install anything else on top of Volumio after flashing, other than plugins?
  • Have you ever tested your SD card with a tool like “H2testw”? Here’s a nice HowTo
  • Are any other devices directly connected to your PI other than perhaps a WiFi or BT dongle? USB disks?
  • What kind of power supply are you using, make/model? 5V and min. 2.5 A?

this is just off the cuff. Could it be the tool you are using to flash the sd-cards that is the culprit? I am using Linux Mint and I use the default USB Image Writer that is preinstalled, and even though I have no used Volumio for a long time I have upwards 30 reboots and 5 flashes on 2 cards and never had a hiccup.

Perhaps you could try firing up a Linux liveCD and use that the flash the SD-card?

Good luck!

Good point, nothing to be excluded yet, card writers (especially the ones that don’t verify by default) have been source of issues.

This part is “odd” and we have no way of verifying this claim.

It just does not make sense. Why would Volumio, not writing to any vital parts of he SD card, stop working and other images do not.
All same PI kernel, same Raspbian.
We need more information…

Thank you all for replies. Here is requested info:

  • Powersource is 2.4A. I have measured power input (from GPIO pins with fluke multimeter) of 4.95V, it does not drop from that value
  • I write images in windows 7 with Win32DiskImager. Nothing else is written to SD card nor tweaked.
  • I use Volumio with Hifiberry Digi
  • This behaviour has percisted with 2 different raspy 2 and 2 different raspy 3 boards.
  • I always write newest image of Volumio to SDcard

Last time I had this behaviour, I swapped sdcards: corrupted sd card of Volumio to raspy that had originally OSMC card in it -> Volumio card does not work. and OSMC sdcard to raspy that had Volumio -> OSMC card works perfectly. So the actual raspy board is not the cause.

Does Volumio keep any full log which could be retrieved (from windows/linuc PC-machine) even is sdcard wont boot to raspy? would it be possible to hunt problem from those logs?

Ok so I had to reboot my Volumio and tadaaa, its DEAD again. Ethernet lights are live and blinking but no IP to router (Asus RT-68A with merlin), nothing on HDMI, no way to connect to Volumio.

So I did some further digging and we might be dealing with Windows 10 anomaly (READ: “Feature” of windows 10) instead of problem with Volumio. When writing to sdcard with Win32DiskImager with windows 10, and further verifying it, immediately throws verify error. This is issue that apparently does not have solution in windows 10. See this post.

I wrote Volumio image with Win32DiskImager in windows 7 and verifying was flawless! Perhaps this issue needs to be adressed in “install volumio” tutorial?

Perhaps google for win32diskimager and odroid.
You should/could be pointed to a version that Hardkernel adapted and has a built-in verify function.
Your problem is new, so I don’t know what adding it to the tutorial would bring

I think this may have been the root cause of what I was experiencing.
Until yesterday I was having a similar issue… constantly having to re image my SD. Using the GUI, changing a setting would cause it to hang, then the only resolution was to re-image. After pretty much giving up I tried Runeaudio and it was stable —odd. Anyways Rune doesn’t have it, so I found myself searching for a resolution yesterday and saw this.
I have been using Windows 10 on a MS Surface Pro with W32DiskImager to write to my SD. Previously I had been using a Win7 laptop (not sure why I had re-imaged, but I am thinking that is when the problem arose). After reading this thread, and nolonger having access to a Win 7 OS I tried imaging the SD with Etcher. That was last night and it has been stable for the past 12 hours - yes not a long time but I know if I had made any changes via the GUI (configure wireless, add a plugin/activate a plugin etc) it would have hung and would have needed a reimage.
I am using Rpi3b/Piano1.1/Kali with buyapi.ca’s audio power supply.
Thank you

I am experiencing the following issue, I have imaged he SD with etcher on my Microsoft Surface Book. I have a raspberry Pi 3 B+, with a Geekworm Raspberry Pi 3 B+ DAC Amplifier HIFI AMP TAS5713 Expansion Board Audio Module. Symptoms are as follows with a 5 inch touch screen , When it boots it works fantastic, but whenever I shut it down there is less than a 50/50 chance it will reboot. If I select restart from the menu it has about a 30/70 chance of working. I am modifying a boombox for my son for his birthday and I know he will frequently shut this down and restart it. I am happy to provide logs and more details. Things I have tried.

  1. Removing the touch screen. Not seeing really any change from this.
  2. I have some music on a USB, I removed that to see… not much difference (it’s hard to tell since it is so intermittent)
  3. Tried just using the power on the Raspberry pi board… no go.
  4. replaced the SD card.
  5. replaced the Pi
  6. Removed the DAC (just using the speaker jack) … no dice.

I reviewed the logs for Volumio.log and boot.log… I can’t really see anything here but then I am not used to lookig at them. Any help would be greatly appreciated. Been working on this for several days now. BTW I do love this software, I am excited to get it working.

Do you have some network mount? Like a NAS folder mounted?

Hello and thank you for the prompt reply. There are no NAS mounts, I feel like the USB is a mount in terms of a /dev/sda or /dev/sdb device. but there are no NAS or other mounts than that.

Here is the boot.log

here is the volumio.log


Coming from a software project manager background I know any thread of information might provide a clue.

This is my experience:

RPi 3B+ with official power supply 2.5 A.
A comment I read somewhere suggested power issue, so I tested: a few other power supplies with claimed 3 and 4 W and I saw the lightning bolt to indicate power issue. So the official power supply for the RPi 3B+ it will be!

I am using Win7 with latest Etcher version.

I experienced that my Volumio will boot a few times post first config and then without warning refuse to boot. Power suply in / out /in /ou and after a few attempts it boots fine.
I then left the Pi to run over night to dodge the pain, and just turn off power to the powered speakers, but in the morning : a dead Volumio - Pi running happily not making any sound coming from the speakers.

Power supply unplug, count to 10 hold thumbs and it will start up 6/10 times.

So I read the thread: volumio-doesn-always-boot-t10485.html#p52090
especially the comment: by michel8166 » Mon Aug 13 2018 14:32 (I flashed a new image and then went through the entire set-up and then, as a volumio asks for a reboot, I did not reboot.
instead, I activated the dev version (test mode) and updated it to the dev version)

Armed and fired-up with this info I downloaded 2.452 and did as michael8166 suggested: Only issue, that was such a resent release, that no dev version was available.

So far; probably 15 restarts I only had one “no-reboot” …probably the 3rd one.

This version seems much more stable as far as reboot issue.

I will leave it running like before and check in on Monday to report back.

even the album pics are updating for the first time, so huge shout-out for the Volumio Team!! Thanks for a real nice product.

BTW: I have copied a load of mp3s to the Micro SD CARD and play the songs of that.

Thanks for the report.
The thing that changed is the kernel version, so I think the PI foundation’s kernels have some issues lately…
We will follow this closely

yes thanks for following.

Looks like my report of this is a dup (volumio-doesn-always-boot-t10485.html.

I tried Volumio on my RPi 3B + and thought it might hav been the SD card so off I went to get the board and tools to run my Volumio from SSD and then have loads of spave to copy files onto the SSD.

Issue was as previously mentioned. 30/70 chance of starting.

So I thought let me stick the card in my 3B.

NO Issues at all starts every time and run smooth.

So I have a Sonoff switch in line with the powered speakers that switch it off in the evening and on in the morning. RPi 3B runs with a big smile.


I’ve got the same problem, with latest version 2.599 (first one I stalled). Smooth setup in 2 rooms, one with Zero and one with 3B+, change some GUI things, 3 hrs NAS scannen and then go to sleep, the Pi as well.
Next morning not starting.

So do the job again, shutoff again (always with the button to shutoff the system…), fails again.

Stange is, that my first attempt to install did’nt had that problem in the beginning, but now it’s just 1 reboot… When power goes down for whatever reason, same problem…

Starting both my devices up again, with screen attached to see what is actually happening…

both finding the network (the one with cable network now does have a flickering green light, previosly not), and both functioning well…

But what is happening???

I have to add some important info on this topic at least for my own failing setup.

When I connected a monitor to the PI, I noticed that a (critical) voltage drop to 4.22 V was met and that’s why the system probably halted. I thougt I was using 1 of my three Samsung 5V 2A chargers, but although they looked the same, there were three different types, supplying 1A, 1.7A and 2A respectively.

Only the 2A unit caused no failures. The 1.7A did well on my Zero with Volumio but failed sometimes on the Pi.

With the 2A unit used solely, no failing startups anymore.

Now I ordered some new 3A stuff, but I do apologize to the Volumio team and all the readers for reporting a supposed instability…

Was the original issue ever resolved?
The same thing is happening to me constantly. If there is a power outage, or somebody pulls the cable i.e. if it first hasn’t been logged out through, it will not be able to boot up in 4 out 5 times (or so, but very often). I even had a case where the SD card is not recognizable anymore by any laptop/PC I have.
I need to re-image the card to boot again.
There are few posts about this, but they are played down as a SD formatting or power supply issue. I have a beefy PS and formatted SD card in W7, W10 and Linux no difference. This is real issue I can’t believe there is no more post about this.

What peripherals do you have attached to your system?