I would like to enjoy my experience with Volumio, but I have been having nothing but problems with the Software. I have used this for 6 mnths now with a Raspberry Pi 3 and build 2.232 with a Allo Piano 2.1 and Kali Reclocker, seemed to work ok, other than system crashing all the time, and dropping signal, and having to reboot a lot, plug in ethernet cable, unplug ethernet cable wifi works, doesn’t work, works again, doesn’t work… Very Very Frustrating to say the least, but at least I got sound out of it.

Last night, I took that build apart, put it back together would not work at all now. Now I’m pissed.

Downloaded a New Image of Volumio 2.389 go through whole process follow all instructions to the letter of the law… boot up Pi (I actually heard a boot up sound) configured my player with the Piano 2.1 DAC using my smartphone and volumio.local on my PC everything seems ok,… I go to play some music and all I hear is WHITE NOISE…take everythiing back apart, put everything back together… ALL I HEAR IS WHITE NOISE…

What the hell is going on here? I have had nothing but problems with a Brand New Raspberry Pi 3 and Brand New ALLO.COM Piano 2.1 DAC and Kali Reclocker , Brand New MicroSD card, Brand New USB Drive with Music a Fresh Install of a Newer Version of VOLUMIO and what This is what I get for my efforts following all your instructions and engineered to work with this set up so that I can hear WHITE NOISE???

Not Happy at all.

1 Like

First, don’t open so many post for the same issue
Second, watch your tongue, you’ve been offensive in many of those.

Coming to your problem, in the latest build of volumio we switched to a new kernel, which seems to have issues with 24 bits audio (it affects mp3 and webradios) and it produces white noise. To fix this go to playback settings -> enable resampling to 32 bits and save.

This is of course a temporary solution, as we are working to fix this problem.

Last, for the wifi: the pi 3 internal wifi has very poor reception, your issue seems to be related to this. I suggest that you buy an external wifi dongle and you will solve also this problem.

Thank you for your reply. Sorry about my use of harsh language, I have been spending hours reading through forums, re configuring things with the set up and you are telling me it is just as simple as a new kernel and switch it over to a different bit rate. Oh My Goodness.

The Wifi is hit and miss. Even when I plug in the Ethernet Cable, the system crashes and I have had trouble connecting to the network hard wired and wireless. Would seem to be my internet connection, depending on the time of day, would work better then others.

Now that Raspberry Pi 3 B+ is out, they are saying that the Wifi has been improved, I have not been able to test that set up yet, but will be doing so shortly, and will have some comparative information.

Thanks again. Sorry for being so frustrated with Volumio and Raspberry Pi and Allo Piano 2.1 and Kali Reclocker, when it is working it does work.

*Note: I just went to go see about changing the Bit Rate, and I thought I would change the I2S back on and off and Allo Boss Shows up as the Default DAC the system prompts me to “Restart” and now the Piano 2.1 is working with the Allo Boss DAC… I am so confused, but happy that I have got the sound back.

I saw in another post that you are using the equalizer plugin, this might introduce some instability as well.

So, to solve completely your isssue I would do:

  • If you need wifi, get a wireless dongle
  • Try to disable the equal plugin and see if that helps
  • Turn on resampling until we fix the issue with the kernel

let me know

I experienced the same, most radio channels and music from the NAS only gives white noise… any solution yet ?



Since the last kernel change Kali will only work with 16 and 32 bit file

The easiest solution is to up sample in Volumio at 32 bit


I’ve just bought Piano 2.1 with Kali and spent hours figuring out why there is white noise. I’m surprised that this bug is not corrected one year later.
You should advertise something in the store at least to warn that the software is broken.

Is there something planned to fix it ?

1 Like

@cablecutter how did you manage that? (24 bit playback, kali reclocker without white noise) with software other than volumio.
I tried all kinds of software but I really run into the same problem I have to upsample or downsample, so I was curious how you solved that.

Unfortunately there seem to be a bug in Allo’s kernel driver with the most recent kernels.
While waiting for Allo to fix the driver with newer kernel, the solution is to enable resampling to 16 bits from playback options


I have a RPi3 with a Hifiberry DAC+ Pro. I have tried the fix of forcing the resampling to 32 bits, but it makes no difference. I still get white noise…although sometimes it splutters into life and I get some sound.