Where is the sound card configuration on version 0.928?


I have got Audioengine 2+ speakers with integrated DAC. Its connected to my raspberry pi B+ by USB. On version 1.55 I was able to setup the sound card. In version 0.928 I don’t find any entry in the gui settings for choosing the connected card.

How can I set up my USB DAC?


It’s on playback options

Hi Michelangelo,

I have found the entry, but can’t find the adpater. The adapter is conneced to the raspberry pi. Here is the result of aplay -l:

**** List of PLAYBACK Hardware Devices **** card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA] Subdevices: 8/8 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 Subdevice #4: subdevice #4 Subdevice #5: subdevice #5 Subdevice #6: subdevice #6 Subdevice #7: subdevice #7 card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0 card 5: A2 [Audioengine 2+], device 0: USB Audio [USB Audio] Subdevices: 1/1 Subdevice #0: subdevice #0

In the playback options, the ‘Output Device’ listbox containts three entries:

  • Audio Jack
  • HMDI OUt
  • A2

That’s all.

My first thought was the card might be configured automatic, but this was not going to be happen in my case.
So I tried out the options:

  • I’ve tried ‘Audio Jack’ because HDMI seems to me wrong.
  • If I disable option ‘I2S DAC’ the card is not diplayed.
  • If I enable ‘I2S DAC’ the lisbox ‘DAC Model’ is active, but my card is not in the list. It doesn’t matter if I choose ‘Audio Jack’ or ‘A2’ before.

What’s wrong?

So I found it: I need to choose ‘A2’ as output device and disable ‘I2S Device’.

From my point of view the configuration of sound adapters on previous version was a bit more intuitive.

Another issue is the german translation for ‘playback options’. It’s ‘Wiedergabe’ only. It’s like ‘playback’ without ‘options’. I’d suggest “Wiedergabe-Optionen” or “Wiedergabe-Einstellungen”. Another thing is ‘A2’ for USB soundcards. If you are not an expert you need to play a round. As I described above, 1.55 was from my point of view in that cases more intuitive.

That translation was probably done deliberately. German isn’t exactly short when describing things so its been kept short to prevent it going onto a new line or causing issues in the UI. Unfortunately its a trade off between what makes the most sense and what works best in the UI.

I would say its quite obvious that if you are using a USB dac then you would need I2S disabled. The playback options screen has been designed to make it easier for the 95% of users to get up and running as easy as possible which i think it does as the rest of the feedback so far as been positive.

If you have any suggestions to improve it then please let us know.