What is Volumio?

Hi all,
I am trying to get my head around Volumio. I am migrating from another Rpi/dac solution because the Spotify part broke (I could not get Volumio working with my iqaudio dac when I first tried several years ago). My question is will Spotify integrate with Volumio? At the moment I can open Volumio from the (paid for) app on my mobile and access my hi-res music, flac, wav stored on an sd card plugged into my Rpi 2 B+ usb port. I can also open Spotify and connect up to the Volumio access point and listen to all my playlists. The thing is, neither knows about the other. I can start them both up and they fight over Alsa. What I would like is to have both available from the same app. They can be independent. eg. either Spotify or Mpd but from the same front end app. Will this be possible with Myvolumio? I have tried registering but have noticed that I am not alone, this doesn’t always happen. Strange from something that charges and I expect will want more money if I go up a tier or two with Myvolumio/Tidal.
I can connect to my amp using Spotify connect and can access my Rpi using the Volumio/Other app but will Volumio/Myvolumio allow me to have access to both from the same app? Thanks in advance.

I’m not too clear about what your actual question is here. Spotify with Volumio is either incorporated in the UI (Spotify plugin) or used indirectly through a Spotify Connect plugin. The former means search results in the UI will include Spotify (as well as any other sources you have, such as a NAS), whereas in the second it is all done in your Spotify app and played via Volumio.

Thanks for your reply. I had installed both the Spotify and Spotify connect plugins. I uninstalled and re-installed the Spotify plugin and re-entered my Spotify info and I now have the Spotify plugin shown and can listen to my Spotify music. It was your comment on searching that had me check this. I can search my artists and browse a-z but none of my Spotify playlists have been imported so opening the plugin and opening my playlist folder yeilded no playlists. I can now control Volumio and Spotify from the plugin. Thanks for your help with this.

For getting your playlists into the Spotify plugin, there is a thread over at the Development Talks subforum. Have a read and see if your up for it! :wink:

ashthespy "For getting your playlists into the Spotify plugin, there is a thread over at the Development Talks subforum. Have a read and see if your up for it! :wink:
Thanks ashthespy for the heads up.
Don’t wish to moan (not to you ashthespy :slight_smile: )but this is exactly why linux can never win. (Not a Winders fanboy, Amiga actually but had Winders forced on me for compatability) Everytime I have tried Linux, be it Slackware, Debian, Suse, Mint it always comes back to a shell prompt!! Apart from cutting and pasting the index.js file the next step is straight to the shell. I haven’t set up Volumio for SSH, why would I?? Oh yes, I see now! The bit that foxes me is :-
ssh volumio@volumio.local
cd /data/plugins/music_service/spop/
cp index.js index.js.old
scp user@:/path/to/new/index.js
This bottom line ??? what is the path/to/new/index.js ??
I can plug in a hdmi cable and access the files without SSH but where to put the file? Does it not go where the original file was? If so why not say so? If not, why not?
This maybe obvious to Linux folk, not to me.
Since installing Volumio it has been nothing but perseverence that has kept me trying to use it. I tried to recreate some of my playlists but came across problems, other than it being a pita when you have to add tracks separately, when I added the same song to a playlist. It can’t be deleted. I had to delete the whole playlist and start again! I am getting an Allo Boss Dac, hopefully it will arrive tomorrow and I shall look into other players.

Well that is a few hours I’ll never get back!
I copied the .js file and amended it as shown with the new token. Couldn’t SSH so I fired up Ubuntu 18.xxx on Virtualbox and copied the file over to ‘overlays’ on the volumio sd card. This was then copied to the spop directory. Rebooted …nothing. Had to reinitialise Spotify with user name and password but still nothing! Ho hum!

Hey Mark - I kinda get what you mean, but then again I spend most of my day staring a a terminal :slight_smile:

In the case that you haven’t still cracked it - this might help!
If you are on win10 (like me) - you no longer have to junp through hoops to get ssh/scp working,

Once ssh is enabled, you can do something like:
0. Make a backup of the old index.js

1 ssh volumio@volumio.local cd /data/plugins/music_service/spop/ cp index.js index.js.old

  1. Open up the folder on your win box with the new index.js
  2. Launch up the terminal (right click open cmd prompt here)
  3. Copy over your newly modified index.jsover to the Volumio box
ssh volumio@volumio.local
scp index.js volumio@volumio.local:/data/plugins/music_service/spop/

Hi ashthespy,
Thanks for your help with this but I still cannot get my head around it. I type in what I believe to be the correct commands but alas nothing works. I have set up ssh for Windows 10 but It has lost the facility to right click open command prompt here. I have been using an admin powershell and going into the directory where I have put index.js, my D:/ drive. If I go into D:/ and then ssh into volumio@volumio.local and scp from there it says index.js no such file! I have tried to use pscp from my windows pc but then it cannot find the spop directory. I did manage it once today, dunno how, but I lost my Spotify icon so I restarted. I have read that I only had to sign back into spotify and it would reappear; Ho hum! I have tried full paths/no paths and still nothing. I have tried user@Pcname:/d/index.js and the full path to spop, from Windows and Rpi; either the path is wrong or it cannot find the file or it times out saying something like it cannot find the D:/ drive. I will persevere. Thanks again.

Thanks to ashthespy and of course skikirkwood for posting the code. To say it was a ‘pita’ is an understatement, considering it was a colon that let me down! volumio@volumio.local : /data/…etc. I ended up using pscp from Windows to get it to work. It wouldn’t have been so bad but I have been working in the dark 'cos I have to have lights out for my fish tank (my perculas are spawning again!) and the backlight has failed on my G19 keyboard. It’s not easy trying to type with a torch in ones mouth.
Thanks again to those who commented and a special thanks to ashthespy for not making me feel a complete loser and pointing me in the right direction.

Glad you’ve got it working correctly :smiley:. As regards the ‘colon’, computers are very unforgiving if you don’t get the syntax correct, and they never tell you why exactly :wink:

No issues, and glad you finally get it up and running!
For future reference - if you prefer a pointy-clickly thing to do the same thing you did, check out WinSCP. Coming to think of it, I should have mentioned it earlier - oh well!