I use a RPI3 running 2.502, ethernet connected. My music playback from my NAS or my usb connected drive all work. However my web radios were working but now they all fail when I try to play them with curl failed to decode error. I am not sure this is associated with the update to 2.502 as I do not use the radios very day so did not see a direct connection. If I copy a radio url into my browser it works fine.

I have created a log file - it shows my action of opening the url but then nothing else. While my volumio web gui shows the error message. Am I doing something wrong?

I have a very large volumio.log file that also does not contain any reference to a decode error.

Any help appreciated.

Just an update - my volumio.log does contain a reference a web radio station I tried to reach - I copy the section here:
Every file type I tried to upload was refused so I have to paste the section.

ControllerMpd::sendMpdCommand load “https://vprclassical.streamguys1.com/vpr-classical128.mpa
2018-12-06T13:06:13.447Z - info: sending command…
2018-12-06T13:06:13.448Z - info: sending command…
2018-12-06T13:06:13.450Z - info:
2018-12-06T13:06:13.450Z - info: ------------------------------ 6ms
2018-12-06T13:06:13.451Z - info: parsing response…
2018-12-06T13:06:13.451Z - info: ControllerMpd::parseTrackInfo
2018-12-06T13:06:13.452Z - info: ControllerMpd::pushError
2018-12-06T13:06:13.453Z - info: message=Cannot read property ‘split’ of undefined, stack=TypeError: Cannot read property ‘split’ of undefined
at Promise._successFn (/volumio/app/plugins/music_service/mpd/index.js:291:54)
at nextTickCallback (/volumio/node_modules/kew/kew.js:47:28)
at _combinedTickCallback (internal/process/next_tick.js:131:7)
at process._tickCallback (internal/process/next_tick.js:180:9)
2018-12-06T13:06:13.454Z - info: ------------------------------ 16ms
2018-12-06T13:06:14.036Z - info: ControllerMpd::sendMpdCommand add “https://vprclassical.streamguys1.com/vpr-classical128.mpa
2018-12-06T13:06:14.037Z - info: sending command…
2018-12-06T13:06:14.040Z - info:
---------------------------- MPD announces system playlist update
2018-12-06T13:06:14.041Z - info: Ignoring MPD Status Update
2018-12-06T13:06:14.043Z - info: parsing response…
2018-12-06T13:06:14.044Z - info: CoreStateMachine::setConsumeUpdateService mpd
2018-12-06T13:06:14.045Z - info: ControllerMpd::sendMpdCommand play
2018-12-06T13:06:14.047Z - info: sending command…
2018-12-06T13:06:14.049Z - info: ------------------------------ 10ms
2018-12-06T13:06:14.051Z - info: parsing response…
2018-12-06T13:06:14.377Z - info:
---------------------------- MPD announces state update: player
2018-12-06T13:06:14.379Z - info: ControllerMpd::getState
2018-12-06T13:06:14.380Z - info: ControllerMpd::sendMpdCommand status
2018-12-06T13:06:14.382Z - info: sending command…
2018-12-06T13:06:14.384Z - info: parsing response…
2018-12-06T13:06:14.388Z - info: ControllerMpd::sendMpdCommand clearerror
2018-12-06T13:06:14.389Z - info: sending command…
2018-12-06T13:06:14.391Z - info: ControllerMpd::parseState
2018-12-06T13:06:14.392Z - info: ControllerMpd::sendMpdCommand playlistinfo
2018-12-06T13:06:14.393Z - info: sending command…
2018-12-06T13:06:14.395Z - info: parsing response…
2018-12-06T13:06:14.397Z - info: parsing response…
2018-12-06T13:06:14.398Z - info: ControllerMpd::parseTrackInfo
2018-12-06T13:06:14.400Z - info: ControllerMpd::pushState
2018-12-06T13:06:14.402Z - info: CoreCommandRouter::servicePushState
2018-12-06T13:06:14.403Z - info: CoreStateMachine::syncState
2018-12-06T13:06:14.403Z - info: CoreStateMachine::pushState
2018-12-06T13:06:14.404Z - info: CoreStateMachine::getState
2018-12-06T13:06:14.404Z - info: CoreCommandRouter::volumioPushState
2018-12-06T13:06:14.404Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2018-12-06T13:06:14.426Z - info: CorePlayQueue::getTrack 0
2018-12-06T13:06:14.426Z - info: STATE SERVICE {“status”:“stop”,“position”:0,“seek”:null,“duration”:null,“samplerate”:null,“bitdepth”:null,“channels”:null,“random”:false,“updatedb”:false,“repeat”:false,“isStreaming”:false,“title”:“vpr-classical128.mpa”,“artist”:null,“album”:null,“uri”:“https://vprclassical.streamguys1.com/vpr-classical128.mpa",“trackType”:"mpa”}
2018-12-06T13:06:14.427Z - info: CURRENT POSITION 0
2018-12-06T13:06:14.427Z - info: CoreStateMachine::syncState stateService stop
2018-12-06T13:06:14.428Z - info: CoreStateMachine::syncState currentStatus stop
2018-12-06T13:06:14.428Z - info: CoreStateMachine::pushState
2018-12-06T13:06:14.429Z - info: CoreStateMachine::getState
2018-12-06T13:06:14.429Z - info: CoreCommandRouter::volumioPushState
2018-12-06T13:06:14.429Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2018-12-06T13:06:14.450Z - info: No code
2018-12-06T13:06:14.451Z - info: CoreStateMachine::pushState
2018-12-06T13:06:14.451Z - info: CoreStateMachine::getState
2018-12-06T13:06:14.452Z - info: CoreCommandRouter::volumioPushState
2018-12-06T13:06:14.452Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2018-12-06T13:06:14.490Z - info: ------------------------------ 114ms
2018-12-06T13:06:18.437Z - info: CoreCommandRouter::executeOnPlugin: mpd , handleBrowseUri
2018-12-06T13:06:18.437Z - info: CURURI: music-library
2018-12-06T13:06:19.738Z - info: CoreCommandRouter::executeOnPlugin: mpd , handleBrowseUri
2018-12-06T13:06:19.738Z - info: CURURI: music-library/USB
2018-12-06T13:06:21.030Z - info: CoreCommandRouter::executeOnPlugin: mpd , handleBrowseUri
2018-12-06T13:06:21.030Z - info: CURURI: music-library/USB/Music
2018-12-06T13:06:22.109Z - info: CoreCommandRouter::executeOnPlugin: mpd , handleBrowseUri
2018-12-06T13:06:22.110Z - info: CURURI: music-library/USB/Music/Music

I have just tried your stream URL vprclassical.streamguys1.com/vp … cal128.mpa and I got a 404 error that the file wasn’t found. Has your station changed it’s stream URLs?


Thanks for checking the log file. Yes there is an error in the VPR url - it should end mp3 not mpa - why this change occurred I am not sure - well seen!

However even after correcting the url I get the same failed to decode error. I have tried other VPR urls that play okay in my browser and they all give the same error still - see VPR aac url.

I wondered if the url was being mis-translated but the last part of my log file shows it correctly - see below. I have tried copying the url from the error log file and that plays in my browser.

What else could be going wrong?

Thanks for looking.
2018-12-08T08:12:22.569Z - info: CoreCommandRouter::volumioGetState
2018-12-08T08:12:22.570Z - info: CoreStateMachine::getState
2018-12-08T08:12:24.052Z - info: CoreCommandRouter::volumioGetState
2018-12-08T08:12:24.053Z - info: CoreStateMachine::getState
2018-12-08T08:12:28.742Z - info: CoreCommandRouter::volumioGetBrowseSources
2018-12-08T08:12:28.745Z - info: CoreCommandRouter::volumioGetState
2018-12-08T08:12:28.746Z - info: CoreStateMachine::getState
2018-12-08T08:12:28.773Z - info: CoreCommandRouter::executeOnPlugin: appearance , getUiSettings
2018-12-08T08:12:28.780Z - info: CoreCommandRouter::executeOnPlugin: wizard , getShowWizard
2018-12-08T08:12:28.780Z - info: CoreCommandRouter::executeOnPlugin: system , getShowWizard
2018-12-08T08:12:28.809Z - info: CoreCommandRouter::executeOnPlugin: multiroom , getMultiroom
2018-12-08T08:12:28.811Z - info: Listing playlists
2018-12-08T08:12:29.226Z - info: CoreCommandRouter::volumioGetState
2018-12-08T08:12:29.226Z - info: CoreStateMachine::getState
2018-12-08T08:13:40.599Z - info: CoreCommandRouter::executeOnPlugin: webradio , addMyWebRadio
2018-12-08T08:13:40.599Z - info: {“name”:“VPR”,“uri”:“https://vprclassical.streamguys1.com/vprclassical128.mp3”}
2018-12-08T08:14:51.890Z - info: CoreCommandRouter::executeOnPlugin: webradio , handleBrowseUri
2018-12-08T08:15:12.872Z - info: CoreCommandRouter::executeOnPlugin: webradio , addMyWebRadio
2018-12-08T08:15:12.872Z - info: {“name”:“VPR AAC”,“uri”:“https://vprclassical.streamguys1.com/vprclassical64.aac”}
2018-12-08T08:15:15.601Z - info: CoreCommandRouter::executeOnPlugin: webradio , handleBrowseUri
2018-12-08T08:15:19.183Z - info: CoreCommandRouter::volumioAddQueueItems
2018-12-08T08:15:19.184Z - info: CoreStateMachine::addQueueItems
2018-12-08T08:15:19.184Z - info: CorePlayQueue::addQueueItems
2018-12-08T08:15:19.184Z - info: Adding Item to queue: vprclassical.streamguys1.com/vprclassical64.aac
2018-12-08T08:15:19.185Z - info: CorePlayQueue::saveQueue
2018-12-08T08:15:19.185Z - info: CoreCommandRouter::volumioPushQueue
2018-12-08T08:15:19.189Z - info: CoreStateMachine::updateTrackBlock
2018-12-08T08:15:19.189Z - info: CorePlayQueue::getTrackBlock
2018-12-08T08:15:19.190Z - info: CoreCommandRouter::volumioPlay
2018-12-08T08:15:19.190Z - info: CoreStateMachine::play index 5
2018-12-08T08:15:19.190Z - info: CoreStateMachine::setConsumeUpdateService undefined
2018-12-08T08:15:19.190Z - info: CoreStateMachine::stop
2018-12-08T08:15:19.191Z - info: CoreStateMachine::setConsumeUpdateService undefined
2018-12-08T08:15:19.191Z - info: CoreStateMachine::play index undefined
2018-12-08T08:15:19.191Z - info: CoreStateMachine::setConsumeUpdateService undefined
2018-12-08T08:15:19.191Z - info: CorePlayQueue::getTrack 5
2018-12-08T08:15:19.191Z - info: CoreStateMachine::startPlaybackTimer
2018-12-08T08:15:19.192Z - info: CorePlayQueue::getTrack 5
2018-12-08T08:15:19.192Z - info: [1544256919192] ControllerWebradio::clearAddPlayTrack
2018-12-08T08:15:19.192Z - info: ControllerMpd::sendMpdCommand stop
2018-12-08T08:15:19.194Z - info: sending command…
2018-12-08T08:15:19.196Z - info: parsing response…
2018-12-08T08:15:19.196Z - info: ControllerMpd::sendMpdCommand clear
2018-12-08T08:15:19.196Z - info: sending command…
2018-12-08T08:15:19.200Z - info:
---------------------------- MPD announces system playlist update
2018-12-08T08:15:19.200Z - info: Ignoring MPD Status Update
2018-12-08T08:15:19.201Z - info: parsing response…
2018-12-08T08:15:19.201Z - info: ControllerMpd::sendMpdCommand load “https://vprclassical.streamguys1.com/vprclassical64.aac
2018-12-08T08:15:19.202Z - info: sending command…
2018-12-08T08:15:19.210Z - info:
2018-12-08T08:15:19.211Z - info: ------------------------------ 10ms
2018-12-08T08:15:19.530Z - info: ControllerMpd::sendMpdCommand add “https://vprclassical.streamguys1.com/vprclassical64.aac
2018-12-08T08:15:19.530Z - info: sending command…
2018-12-08T08:15:19.531Z - info:
---------------------------- MPD announces system playlist update
2018-12-08T08:15:19.532Z - info: Ignoring MPD Status Update
2018-12-08T08:15:19.532Z - info: parsing response…
2018-12-08T08:15:19.532Z - info: CoreStateMachine::setConsumeUpdateService mpd
2018-12-08T08:15:19.533Z - info: ControllerMpd::sendMpdCommand play
2018-12-08T08:15:19.533Z - info: sending command…
2018-12-08T08:15:19.535Z - info: ------------------------------ 4ms
2018-12-08T08:15:19.535Z - info: parsing response…
2018-12-08T08:15:19.861Z - info:
---------------------------- MPD announces state update: player
2018-12-08T08:15:19.862Z - info: ControllerMpd::getState
2018-12-08T08:15:19.862Z - info: ControllerMpd::sendMpdCommand status
2018-12-08T08:15:19.862Z - info: sending command…
2018-12-08T08:15:19.863Z - info: parsing response…
2018-12-08T08:15:19.866Z - info: ControllerMpd::sendMpdCommand clearerror
2018-12-08T08:15:19.866Z - info: sending command…
2018-12-08T08:15:19.867Z - info: ControllerMpd::parseState
2018-12-08T08:15:19.867Z - info: ControllerMpd::sendMpdCommand playlistinfo
2018-12-08T08:15:19.868Z - info: sending command…
2018-12-08T08:15:19.869Z - info: parsing response…
2018-12-08T08:15:19.869Z - info: parsing response…
2018-12-08T08:15:19.870Z - info: ControllerMpd::parseTrackInfo
2018-12-08T08:15:19.870Z - info: ControllerMpd::pushState
2018-12-08T08:15:19.870Z - info: CoreCommandRouter::servicePushState
2018-12-08T08:15:19.870Z - info: CoreStateMachine::syncState
2018-12-08T08:15:19.871Z - info: CoreStateMachine::pushState
2018-12-08T08:15:19.871Z - info: CoreStateMachine::getState
2018-12-08T08:15:19.871Z - info: CoreCommandRouter::volumioPushState
2018-12-08T08:15:19.871Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2018-12-08T08:15:19.895Z - info: CorePlayQueue::getTrack 5
2018-12-08T08:15:19.895Z - info: STATE SERVICE {“status”:“stop”,“position”:0,“seek”:null,“duration”:null,“samplerate”:null,“bitdepth”:null,“channels”:null,“random”:false,“updatedb”:false,“repeat”:false,“isStreaming”:false,“title”:“vprclassical64.aac”,“artist”:null,“album”:null,“uri”:“https://vprclassical.streamguys1.com/vprclassical64.aac",“trackType”:"aac”}
2018-12-08T08:15:19.895Z - info: CURRENT POSITION 5
2018-12-08T08:15:19.895Z - info: CoreStateMachine::syncState stateService stop
2018-12-08T08:15:19.896Z - info: CoreStateMachine::syncState currentStatus stop
2018-12-08T08:15:19.896Z - info: CoreStateMachine::pushState
2018-12-08T08:15:19.896Z - info: CoreStateMachine::getState
2018-12-08T08:15:19.896Z - info: CoreCommandRouter::volumioPushState
2018-12-08T08:15:19.896Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2018-12-08T08:15:19.920Z - info: No code
2018-12-08T08:15:19.921Z - info: CoreStateMachine::pushState
2018-12-08T08:15:19.921Z - info: CoreStateMachine::getState
2018-12-08T08:15:19.921Z - info: CoreCommandRouter::volumioPushState
2018-12-08T08:15:19.921Z - info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
2018-12-08T08:15:19.956Z - info: ------------------------------ 95ms

According to this link vprclassical.streamguys1.com/vprclassical64.aac)


I just cannot get the url to work. I could be making an error but I find it difficult to believe I can do this repeatedly with different station urls. I am pasting or actually typing in the correct url (I have tried both ways).

Could it be something to do with my Volumio set up? I will delete it, re-install and let you know. Thanks for the help.

No success deleting and re-installing. However I cannot get back to a fresh install where I get the menu to name the device etc. Although I thought I had deleted all traces of Volumio somewhere my previous set up configuration exists. So maybe not a good test? How do you get back to a completely new install?

Not totally sure what you mean here, but if it is a clean reflash it should get you to the first run config wizard. You can also run it from ‘system settings’ I think, but I have never tried that.


I was not a re-flash - so that was why I did not see the config wizard. However accidentally I have fixed the decode issue. It’s a curious effect but I changed the network eth0 configuration. I had changed it to static as that is how my router sets the ip address in the first place. So I thought I should do the same in Volumio. However if a reset it to DHCP in Volumio it stills uses the correct ip address but does not give the recode error!

Thanks for discussing this with me.