Webradio "failed to decode" error v2.389

New installation on a RPI3. Tried to add my favorite webradio. Got above error.
URL is: abc.net.au/res/streaming/aud … sic_fm.pls
Plays OK in VLC
None of these listed links would play:

Any ideas?

Hmm, now I’m further confused.

I have to changed the abc.net.au host name to it’s IP address and it worked. ONCE…

Ok, DNS server issue, I thought. Changed DNS server on the router (rebooted) and tried again. No success. Changed to [Enable Custom Server] in the network tab. No success.

Changed back to IP addressing that worked before. No success ?!?.

Now, the really weird thing is that although neither of my two added stations [IP or hostname] starts to play. But when I go via [QUEUE] and click that one time success it persistently starts the stream.

What am I missing?

Well I can confirm that the stream doesn’t play through Volumio, but does on a PC with VLC. Has it worked with Volumio at all in the past?


I wonder if the playlist file might be invalid because it includes two version lines



Title1=Classic FM NSW

Title2=Classic FM NSW

The links in the file play fine.


Try removing one of the links, and if it works fine then raise a issue on github.com/volumio/Volumio2/issues

Looking again, the problem appears to be that the PLS file says NumberOfEvents, instead of NumberOfEntries. Correcting that, the original file works fine. Here is a test link



Thanks for helping out, guys!
Yes, it seems that the [NumberOfEvents] entry throws off Volumio.
Plugging in one of the URLs included in the PLS file as the webradio URL directly plays the stream just fine. Sorted.

I had the exact same experience - see topic internet-radio-not-working-after-update-t9488.html#p46865.