WD Disk Drive Problems

Hi all,

I’ve got my pi set up with Volumio. I am powering my pi through a D-Link Powered USB Hub [dlink.com/us/en/home-solutions/connect/usb/dub-h7-7-port-usb-2-0-hub], and am using a TP Link [tp-link.com/ca/products/details/?model=TL-WN823N] wifi adapter, and I have a USB DAC I’m using for audio output. I can’t find any info online about the DAC, but it has worked so far without any issues. Using this setup, I plugged in my USB thumbstick with some music and the whole setup worked without issue (once the network config was setup using a wired connection).

However, to get my whole music library going, I tried plugging in a Western Digital 1 TB hard drive (does not have it’s own power supply) and then powered everything up; I cannot figure out why this isn’t working. The pi still starts up, connects to the network, I can access the pi through my computer (and can access all the files on the WD HD) but I cannot access the pi for the volumio UI through my web browser (the browser just tells me the connection failed). If I turn everything off and try the USB thumbstick again it all works again.

Anyone know what’s going on here?