Waveshare 5 inch touchdisplay, driver install dosen t work

Hello together,
i hope someone can help me.

i try to install my Waveshare 5 inch Tocuhscreen , the display does work fine…

but i cant install the touch driver.

i am logged in as root (root@volumio), and type
and the console answer is
bash: ./LCD5-show: permission denied :frowning:


i tried with sudo ./LCD5-show
and answer is
command not found :frowning:


and bevor, i did chmod +x LCD5-show
and tried with chmod 777; chmod 755; chmod a+rw and nothing helps

and yes, i m in the rigth folder…

it would be perfekt, if can use my Waveshare touch

some ideas? :smiley:


I suggest that you do a fresh installation of Volumio, and then install the display plugin.

so i tried a new system install and…

it doesn t help.

alwas the same error message

bash: ./LCD5-show : Permission denied

i can see volumio an this display, but the touch driver can t installed :frowning:

I don’t have a Waveshare display and it’s just a shot in the dark:

Login via SSH as user volumio instead of root. Then try to install by doing sudo ./LCD5-show

hi, i tried these… see my first post.

i tried with sudo ./LCD5-show
and answer is
command not found :frowning:

i tried all these commands with and without root/sudo

Maybe I misunderstood but from your first post I assumed you have been logged in as user root all the time (even when you tried “sudo ./LCD5-show”). Therefore I suggested to log in not as root but volumio and then execute “sudo ./LCD5-show”.

Ich tried it all…

Loggen in as bin root or as root there is no difference between .
I get all the time that Same massege …
And it is very crazy by typing sudo ./LCD5-show that the consol say Commander Not found :frowning: and by typing the same without sudo the Error is permisson denied

And i will repeat, no matter as logged in as root or as User, Always the same Error!!

And its the right Driver, i used it on other raspian systems before
that makes no sense

When you create a simple script like#!/bin/bash echo "Hello" are you able to execute that with sudo?

BTW (unrelated to the problem with executing LCD5-show):

LCD5-show calls uname -n in line 13 and then checks if the result was “raspberrypi” in line 16. On a volumio system “uname -n” will return “volumio” so the script will not update the touch configuration unless you change line 16. The version check might be inappropriate for the volumio kernel, too, but I didn’t check that. Also don’t know if this would be important for you, so just a hint.

Can you tell us how you have installed the driver please? The more details the better. I do note that there are a few posting in the forum about problems in getting “touch” to work with this device. Does anyone in the Community have the Waveshare 5" display working with touch control?

hi all, probably problem has already been solved but unfortunately no solution was posted. So I will describe my case. (it worked on rpi , maybe it is proper way on volumio also)

After configuring hdmi (config.txt on boot partition) I downloaded driver package (from github) and copied extracted files onto usb flash drive. Unfortunately every try to execute driver installation script resulted in the same error (“Brak dostępu”=“Permission denied”):

root@raspberrypi:/media/pi/SC# chmod +x LCD5-show
root@raspberrypi:/media/pi/SC# ./LCD5-show
bash: ./LCD5-show: Brak dostępu

As you can see it was executed from mounted USB drive. After copying files to rpi file system and executing it locally, driver installation script works ok:

root@raspberrypi:/media/pi/SC $ cp -R * /home/pi/driver_touch/
root@raspberrypi:/home/pi/driver_touch# chmod +x LCD5-show
root@raspberrypi:/home/pi/driver_touch# ./LCD5-show
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
( here were proper installation messages)

After (automatic) reboot, touch screen is ready.