Waveshare 3.5inch LCD RPI (B) rev2.0 on RPI3B+ for Volumio

Of course but why on this display whit same resolution there s difference?

Hm, I don’t have a 3.5 inch display with a resolution of 480x320 to compare but in the pictures everything looks normal to me. Maybe try out the classical UI theme.

Do you have a picture that shows the difference you are referring to?

i’m sorry … no! but if i want enlarge the font text into css where i can go?

I have no clue. I don’t tinker with the .css files, but you probably can get help in the thread Contemporary optimizations for small or large landscape displays where you already have posted.

Thenk you for help!

1 Like

This is the resolution of i set 480x320px

Yes, doesn’t look nice. With your other 3.5 inch display it was looking better (when resolution was also set to 480x320)?

i think of yes… but other display has not HDMI and i installed this script.

What is the content of that script? Do you have a link?


set -o errexit

if [[ $EUID -ne 0 ]]; then
echo “This script must be run as root (use sudo)” 1>&2
exit 1

set -e


cd ~

sudo apt update
sudo apt -y install git
sudo apt -y install xserver-xorg-input-evdev

sudo rm -rf LCD-show
git clone GitHub - goodtft/LCD-show: 2.4" 2.8"3.2" 3.5" 5.0" 7.0" TFT LCD driver for the Raspberry PI 3B+/A/A+/B/B+/PI2/ PI3/ZERO/ZERO W

sudo cp LCD-show/usr/tft35a-overlay.dtb /boot/overlays/
sudo cp LCD-show/usr/tft35a-overlay.dtb /boot/overlays/tft35a.dtbo

sudo mkdir -p /usr/share/X11/xorg.conf.d/
sudo cp -rf LCD-show/usr/99-fbturbo.conf /usr/share/X11/xorg.conf.d/99-fbturbo.conf

sudo mkdir -p /etc/X11/xorg.conf.d
##sudo cp -rf LCD-show/usr/99-calibration.conf-35-90 /etc/X11/xorg.conf.d/99-calibration.conf

cat <<‘EOF’ > /etc/X11/xorg.conf.d/99-calibration.conf
Section “InputClass”
Identifier “calibration”
MatchProduct “ADS7846 Touchscreen”
Option “Calibration” “227 3936 3880 268”
Option “SwapAxes” “1”
Driver “evdev”

grep -q “include userconfig.txt” /boot/config.txt ||
echo “include userconfig.txt” >> /boot/config.txt
grep -q “hdmi_force_hotplug=1” /boot/userconfig.txt ||
echo “hdmi_force_hotplug=1” >> /boot/userconfig.txt
grep -q “dtparam=i2c_arm=on” /boot/userconfig.txt ||
echo “dtparam=i2c_arm=on” >> /boot/userconfig.txt
grep -q “dtparam=spi=on” /boot/userconfig.txt ||
echo “dtparam=spi=on” >> /boot/userconfig.txt
grep -q “hdmi_force_hotplug=1” /boot/userconfig.txt ||
echo “hdmi_force_hotplug=1” >> /boot/userconfig.txt
sed -i ‘/dtoverlay=tft/,$d’ /boot/userconfig.txt
echo “dtoverlay=tft35a:rotate=270” >> /boot/userconfig.txt


whit this script the touch it’s ok!

Can’t spot anything where the resolution gets set explicitly in the script. So I would expect the other display to be run with a resolution of 480x320, too.

But touch is not a problem with the MPI3508 anymore I think. (?) :thinking:

BTW: Did you try the classical UI theme?

no the touch is not a problem … even before it worked better. Frse is better display hardware! i tried the standard graphics but i still suck! Instead between the scale of 200 in the plugin and with the CSS dofica I get a good thing. Even if the menu for the choice of files is impossible because it is too small for a selection with the touch!

Does the picture in post #57 show a magnified UI (using the Touch Display plugin’s scaling option)?

Hi gvolt, please help me!
I running the latest 2,917 volumio version and later i installed the Touch Display plugin but i cannot use the touch. Now i istall this script install_3.5_screen-270.sh or no?
this is my third test … but after to restart my diplay come black!

Is this a fresh installation or an updated system?

fresh installation!