Wave share and volumio

have the wave share 5 inch screen with touch via gpio,
I managed to install the touch screen plugin but the touch doesn’t work, I can see the GUI on the screen.

Any help would be great!

Sent from my HT6 using Tapatalk

1 Like

I have the same display, put this lines in /boot/config.txt:

hdmi_cvt 800 480 60 6 0 0 0

The touch screen work, but can not calibrate,

Same experience here - using Wave Share 5 inch display - I can see the screen (great!) but touch doesn’t work.
I tried suggested modification in /boot/config.txt, but no success :frowning: (I believe the last line in the code is to enable the touch, right?)

Any suggestions what should I try to make touch working?

In case you want this for an Odroid you’re lucky, the upcoming Image version will have it.
Not sure about the RPi, check the Waveshare wiki here: http://www.waveshare.com/wiki/5inch_HDMI_LCD
If you get it to work, then please report back so we can duscuss how to include it.

– Gé –

Actually I’m using RPi3 for Volumio and I tried both Odroid VU-5 and Waveshare 5" displays (both HDMI + USB, 5’’) and it seems the behavior is similar - both are ok as display (I can see the Volumio screen) but neither of them works as touch - I tried finger, pen, … nothing.

I thought that Touch-display plugin in Volumio works with those 2 touchscreens on RPi, but for some reason I’m not successful with it.
Can the issue be with 5’’ version of those displays? (maybe the plugin is designed for 7’’ versions only - volumio.org/raspberry-pi-displa … ic-player/ )

No use, you need to get a driver (semtech) for RPi, I had to add that for Odroids too…

This calibration work for me.


In volumio and raspbian also.

Has anyone managed to get this 3.5 touchscreen from Kuman to work with Volumio? I have the display working fine on Jessian using the supplied image file and I’ve got Volumio running headless and also to the HDMI monitor with the touchscreen plugin. Unfortunately every time I try to install the Kuman screen drivers (as instructed by the guidance) the system hangs on boot and I have to reflash the card and start again.
I assume its just a case of combining the display drivers to mirror the HDMI output to the LCD which should be possible given the supplied image file works? Would really appreciate any help to get this work.


Yes I finally got it to work with the March 2017 release of Volumio and some try and error. Still have to solve the calibration.
The CD offers preconfigured config and cmdline files. These cannot be used with the current Image for pi3.
I believe I got it running with tft35a on either KUMAN or Waveshare Drivers.
Take a look at the lcd35show you have to run to install the Display on raspbian, see what it does. Running it will result in kernel Panic, because Volumio Mounts an Image file and the CD Image uses partitions.
Then I tried the “101 Direct Volumio GUI” here on the Forum - did most of the steps there.
Ended up running into several rewritings of the Volumio Image, installing the Touch Plugin and the X System manually.
After 2 days Messing with my current Image I got it to work, with 2 Browsers in autostart and the touch functionality turned by 90 degrees, 3 “installed” Drivers and far more steps taken than I can recreate in one attempt.
So I cleaned up as far as I could, narrowing it down to 2 “small” Problems.
By cleaning up the dtparms and modules and the autostart and Xconfig mess, I now got a Volumio that is fully functional (incuding the HotSpot-feature).

  • I cannot choose the direction of the touch - So I had to turn Screen (":rotate=270") to fit under the touch, leaving me Portrait-Mode USB-up/SD-Card Down
  • I cannot calibrate the touch-accracy. So I can easily start/stop, but the pointer does not go all to the top and bottom and to the left and right.
    Both Problems seem solvable, but that is how far I am today.
    I will try and make a complete guide after I fixed everything and boiling it down to the clean solution.
    If anybody wants that Image I will backup now, feel free to tell me and I will upload it somewhere.


I’ve tried the 101- post as well (multiple times, actually); ending in either kernel panic after rpi-update (both 2b & pi 3, 3.5in spotpear LCD touchscreen). Also, the last step of installing the driver fails in kernel panic. I’ve thought of having a clean image w/ touchscreen support (works, verified’, but no Volumio), but I am not sure on howto install Volumio on that, while keeping all of the nice web UI goodies (I have tinkered in the past with an old laptop running MPD, not as cool as Volumio).

Basically what I am interested in is your method, but condensed to a workable amount of hints/code/instructions :slight_smile:

Cheers, thanks in advance,


How can I configure my Waveshare 3.5 display for use the Volumio?
I did try install driver using official post (waveshare.com/wiki/3.5inch_RPi_LCD_%28A%29) and I can work in Raspbian Jessie but not in Volumio distro.
How you make to work? I can’t see GUI (and did try install the touchscreen plugin also).


please!!! please!!! Me too!!!

It’s quite simple :slight_smile:

Enable the device using waveshare-dtoverlays
Sample for the 3.5" display based on ili9486 and xpt2046 touch

cd ~
git clone https://github.com/swkim01/waveshare-dtoverlays
sudo cp waveshare-dtoverlays/waveshare35a-overlay.dtb /boot/overlays/waveshare35a.dtbo
echo dtoverlay=waveshare35a >> /boot/config.txt
sudo reboot

Install the touch_display plugin and enable it from the webUI as usual now.
By default, this is now available on the HDMI output - so lets change this to use our new screen.

sudo systemctl stop volumio-kiosk.service
sudo sed -i "s+/dev/fb0+/dev/fb1+" /usr/share/X11/xorg.conf.d/99-fbturbo.conf
cat /usr/share/X11/xorg.conf.d/99-fbturbo.conf
sudo systemctl start volumio-kiosk.service

Should now have a working display - but the touch screen probably needs some calibration.

anyone knows how to recalibrate the 3,5" screen? the touchscreen is out of specs with volumio layout

depends on your setup: but this worked for me:

volumio@volumio:~$ cat /usr/share/X11/xorg.conf.d/99-callibration.conf
Section "InputClass"
        Identifier      "calibration"
        MatchProduct    "ADS7846 Touchscreen"
#        Option "TransformationMatrix" "-1 0 1 0 -1 1 0 0 1"
         Option "TransformationMatrix" "-1 0 1 0 1 0 0 0 1"
        Option  "SwapAxes"      "0"

The Transformation matrix is a simple rotation matrix. Look at wiki.ubuntu.com/X/InputCoordinateTransformation for more examples


Is there any option to use touch functionality on Volumio for below screen?
Waveshare: 7inch HDMI LCD (H), 1024x600, IPS, supports various systems, capacitive touch + Odroid C2.

thanks for answer :slight_smile:

Hey Guys,

i have a Question.

I have a Raspberry Pi 2 with Volumio 2.457 and a Waveshare 3.5 Display, Display works fine, but how can i calibrate?
If i press right above then is the cursor left above and if i press left above then is the cursor bottom left.

Best Regards

i have found the right settings for me:


Section "InputClass" Identifier "calibration" MatchProduct "ADS7846 Touchscreen" Option "TransformationMatrix" "0 -1 1 1 0 0 0 0 1" Option "SwapAxes" "0" EndSection
with this settings is it correct.

this Site was the Key to success : https://wiki.ubuntu.com/X/InputCoordinateTransformation

Hello Spyking,

I’m tring to make my Raspberry Pi 3 and 3.5" display work with latest volumio but I can’t succeed.
My screen works fin with full version of Debian or Raspbian.
I’m a beginner in linux.

I tried to use your totorial to get the drivers install, but I’m stuck in 3rd step :
“sudo cp waveshare-dtoverlays/waveshare35a-overlay.dtb /boot/overlays/waveshare35a.dtbo” and I get the following message " No such file or directory"

Please help me how I can resolve my problem?

Hi there,
That particular repo has been updated, and the files been renamed.
try the following instead

sudo cp waveshare-dtoverlays/waveshare35a.dtbo /boot/overlays/waveshare35a.dtbo