Volumio3 broke realtek wifi with last update

please enable beta updates from the /dev page, then perform a OTA update, you will get that version

That worked fine!

Grazie mille

I’m having WIFI issues all of sudden, my WiFi dongle keeps shutting off after 10 mins after every reboot.

Here is a link to my logs


Looks like 3.211 is working for me :+1:

1 Like

As of last update its Broken again…

From the changelog for V3.233.

“NOTE: Many external wifi dongles will stop working , if you encounter this issue please report the wifi dongle model to:
techsupport at volumio dot org”

Thanjs, mailed

Can somebody explain why our WiFi dongles are not working lately ?

Long story short:

We were forced to upgrade the kernel version for Raspberry PI, in order to support the latest model of Raspberry PI 4 v 1.5.
Unfortunately, for those newer kernels, there are no pre-built wi-fi drivers for dongles not already supported by PI. Those were built by a third-party which just stopped providing them.

We tried to support latest PI 1.5 by doing some tricks to retain wi-fi drivers, but it did not ultimately work.

So, we needed to make the choice: upgrade the kernel to support latest PI 4, or drop some wi-fi driver support. Considering that in the future we would have needed to upgrade the kernel anyway, we went for the first choice.

Of course, we could build and maintain those drivers ourselves, but it requires a substantial amount of work which we cannot handle at the moment, and we prefer to prepare a list of supported dongles that you can get if in need.

1 Like

Is there a way to roll back to prevuis version?

Good news! Can you already say which chipsets work? So I can try to find a matching dongle…

1 Like

We are waiting for feedbacks from the community…
@DED do you have any news on that? Do we know which dongles work so far?

I went back to 3.175, WiFi is working again

Small input from my side: on my way to the supermarket I passed a Conrad store and decided to check for available WIFI-Dongles and bought 2 cheap (sub 10€) dongles:

At home I found, that both have the RTL8188EUS chipset (thought one had a RALINK chipset in the store) which I can confirm to work :-).

As I only need one dongle: if someone (within Europe) wants the LogiLink send me a PM. It goes a little hard into the USB Port but works without problems.

1 Like

I have that TP LINK and I’m having problems

Strange. Mine is v3, maybe they changed the chipset?

any status update? I miss my music :frowning:

what about just using the same repos for wifi that libreelec is using? they all work fine with latest kernels,
take a look here LibreELEC.tv/packages/linux-drivers at master · LibreELEC/LibreELEC.tv · GitHub

rtl8112au - GitHub - aircrack-ng/rtl8812au: RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection
rtl8192eu - GitHub - Mange/rtl8192eu-linux-driver: Drivers for the rtl8192eu chipset for wireless adapters (D-Link DWA-131 rev E1 included!)
rtl8192du - GitHub - lwfinger/rtl8192du: Source code for RTL8192DU device
rtl8192cu - GitHub - pvaret/rtl8192cu-fixes: Realtek 8192 chipset driver, ported to kernel 3.11.

Is that TP-LINK v3 working for you with 3.233 ?

Yes. Works