Volumio2 - unable to add audio files from synology mount

Hi all,

I’m running Volumio 1.55, which works a charm. It can play all files on my Synology NAS running DSM6 (latest update installed) trough SMB/CFIS. I have tried running Volumio 2 on a rPi2 but got stuck on mounting my music library stored on a NAS.

As I have 3 rPi Zeroos catching dust, I thought lets try and get Volumio2 running on a rPi0 including a fully working mount of my music library.

Sadly, this is not working. Volumio2 is able to scan the mounted drive from the NAS up until 400 albums (it varies 398/400/390/403) are scanned. The process hangs and after a reload and/or reboot Volumio2 says, no songs are scanned yet, and I should rescan.

How can I resolve this? I have tried mount flags; “ro,noatime,sec=ntlmv2” and also “ro,sec=ntlmv2”. But without any luck.

Is there anybody out their with a good tip? Thanks in advance!


Ruud van den Dries

Are you using CIFS for any particular reason? I have a RPi Zero connecting to a Synology NAS by NFS without problems.

did you solve your adding , im stuck in same problem. and normaly im not that dumb to add network shares. perhaps it’s more a syntax problem

Hi All !

Same problem on Odroid C2. See my post from Friday …

Do you really thing Imwas going to search formyour post from Friday :wink:

I use a Synology D415, connected a music library with >2000 albums via cifs (also tested with nfs) via eth0 connection and never had an issue.
Would someone having problems please give more info on how you connect, using wlan?


UPDATE: Same issue while using NFS over WLAN. Issue: “Not able to scan more than 400 albums. Music Library is emptied on refresh.”

I connect using WLAN from a Pi Zero. Due to a holiday break I was unable to reply.

I connect using CIFS because I do. And it has always worked for me. I will look at connecting via NFS now. Will report asap on how that helps or not.

Mmm, sounds like a the same problem i had when switching over to Volumio 2.
Could it be that you have embedded artwork?
I had in one album a somewhat crippled image, when i replaced that image, it scanned my whole library.
It has nothing to do with CIFS or NFS
Look here for the post about this:

I think I have removed All embedded artwork, with a tool that should do this automaticly. After trying to ‘import’ all music again into volumio2 the same issue arises. How did you go about removing the embedded artwork? I how can I check what file is at fault?

If you take a look at the mentioned forumpost you see the journal command that lead to the solution.

Verzonden vanaf mijn iPhone met Tapatalk

I’m having the same problem on an Odroid C2. Library is on an Openmediavault server mounted by NFS. Volumio scans about half my library (3000 odd albums) and then aborts resulting in 0 albums in the library.

Although it may be possible to identify the offending track with bad artwork via the logs its not really a solution to the problem. There may potentially be hundreds of files that trigger a crash. The question is how to stop Volumio crashing and deleting the database …

Hi mveldman, I did found the first and second file that result in Volumio deleting the whole database.

Thanks for that! Tough I’m not sure what’s wrong with the files as there is no artwork to be seen. Deleting the file giving the error results in volumio scanning further until the next error giving file…

I do agree with this remark;

It is very odd that Volumio 1.55 can scan my whole database, where an newer Volumio version, namely Volumio 2.0xx, can not. That doesn’t sound logical.

Having said that, I do no how to determine faulty files, do I’m not aware what is wrong with them. I will true to determine this in some way.



As far as i know it has something to do with a bug in the newer version of mpd

Verzonden vanaf mijn iPhone met Tapatalk

Well I, used the ‘journal’ tric mveldman mentioned andere now my while library is scanned into volumio. Thanks!