Volumio2 : issues, TODO and feedbacks

Hi Everyone, this thread is meant to collect all issues you find on Volumio2. So we keep the main thread polished and we can track the issue status.

Please be as detailed as possible with your reports :wink:

The pen was formated on ftns and today i formated with fat and it works fine so if you could correct this issue it will be great.

Ok so you had issues with NTFS?


I trying the latest release and I am having issues with UPNP when trying to push music form my server.

Then I also can not add my synology NAS.
I double checked with my settings in Volumio 1.55 and i tried to replicate it but in the settings it always shows “false” under mounted.
I tried various times but I could never get it working.

any suggestions?

I originally posted to a different thread, didn’t see this one. Sorry.

From the feature list I see UPnP is listed as complete. and I am using 1.55 with a DLNA Server that pushes music to Volumio acting as a Renderer.
I am unable to see 2.0 for some reason, maybe it is just not being made discoverable. AirPlay works just fine and is discoverable.

Thanks for the awesome project and the rewrite is looking very really good. Nice and responsive.

Got the latest version up and running (alpha 6)
Still have an issue with the scanning of the library, on my nas, now connected via NFS.
After 6100 songs the scanning stops, the player stops and my library is empty.
I suspect it has something to do with some characters in my songlist, but it is weird, as in volumio 1.55 this is no issue at all.

It could definetely be… Maybe is worth trying to mount with utf8 charset…

I am not sure what you mean.
Can i somewhere configure how to mount my nas, other than the standard options in the web ui?
Is the mounting process in volumio 2 different as in volumio 1.55?
In mpd.conf everything is configured to charset UTF 8, on volumio 2 as well as on volumio 1.55.

System Player Name - Cosmetic Issue
1.55 Allowed lower and upper case letters in the name.
2.0 (build 825) converts all to lower case.
It just looks better on the other clients when it is discovered and I can use some capital letters

UPNP AV support - Unable to Stream to it as a renderer
Looking deeper into this, it looks like only open home support is enabled in the upmpdcli.conf
This is confirmed by looking at the UPnP service advertisments on the LAN
UPnP AV is disabled.
Github shows this item complete. or is that just the subsystem, and the GUI to enable it is not yet complete?


Just to say that with the last commit in webUI (from today) the webUI goes really faster to list the content of my music library : about 1,5 sec against 9sec!!!
You are on the good way ! :smiley:

It would be nice to keep the ssh keys generated when there is an update.
No need then to do a ssh-keygen -R volumio.local on the client machine.

Stéphane Acounis

Yep, we’re tweaking the boy, and it seems we’re doing a good work there…

Due to the updater’s nature: every manual modifications made to file system will persist across updates, so your SSH keys are safe…

Looking back in earlier posts, I see that it is necessary to edit mpd.conf in order to use my hifiberry DAC. Exactly what should the config lines be please?

P.S. Can we have checksums for images please?

Been playing with the latest version this evening, just have some general feedback. None of it is really deal breaking, just my feedback from a usability perspective.

Under My Music
Change ‘Songs’ to ‘Tracks’ - Some of my music is ‘Songs’ but I never refer to my music as songs.
Change ‘Playtime’ to ‘Total Playtime’ - Just a better description.

Under Network Drives
Mounted it is currently ‘true’ or ‘false’ change to a tick or cross icon to match elsewhere in the UI for consistency.
Size should be XXGB not XXG.
Advanced Options should be a button, its easily missed as just a link.
‘IP Address of your Network Drive’ should probably be ‘IP Address of your NAS/Server’
cifs & nfs should probably be something that is easier to understand to newcomers.

Under Playback Options
Can I suggest a ? icon (fa-question-circle) next to each option with a bootstrap style popover that gives a bit of an explanation of each option. Same probably goes for all of the settings.
Should all of the options be toggles rather than dropdowns for consistency throughout the UI?
When clicking toggles, the off state is white and looks odd.

Under Browse
Back button doesn’t seem to work once you are under a category.
Be nice to see each category with its own icon like under radio stations. Favourites (fa-heart), Playlists (fa-list), Music Library (fa-folder-open), Webradio (fa-microphone) maybe?
The Home icon i would expect to take me to the playback page, but it doesn’t

Under Queue
When you have nothing queued its just a blank page, probably needs some place holder text when nothing is queued.

Hope they make sense. Like I said, nothing deal breaking… just nice to haves.

I would like to see the upnp issues solved. Since alpha 3 i lost connection on bubleupnp and i have to restart volumio after 2 or 3 songs. This is very anoying .

Lot’s of improvement.

TREMENDOUS scan speed… maybe x10 times fasters.

On mount creation make the advanced button mmuch more visible, or better show credential fields directly, with an (Optional) statement.

I searched the reason why my mount failed, then remember the password I set on the share folder for security reason…

Nice work, please keep on doing such a great job.

Edit :
As per update 830.
Using 2A power supply
16Go sandisk
No overclocking.
Bug : I can’t see the mount I saved before the working one, neither the one that is beeing scanned now… Credential not present when editing…
Bug 2 : reboot seems to hang 50% of the time, I’m enforce to reset (Off/On power) to restart.
Bug 3 : factory reset don’t seems to work. (mount and DB aren’t deleted)

Hello, thank you very much for your attention. Last version beta work without any issues.

Is the volume control still disabled or something wrong on my end (version 20160220)?

Volumio does not see ANY music.
It does play radio
I moved all music on my connected HDD to root folder but only shows ‘trashes’ folder ?
Worked by ‘updating MPD’ using 1.55.
Any advice appreciated.