Volumio x86 Realtek RTL8821AE wifi

Volumio Information

Volumio Version:x86
Hardware: Asus vm42
DAC: Khadas

I run volumio on a pi and its great. Thanks
I bought an Asus VM42 specifically to run volumio x86/x64. On the whole, it’s great. However the wifi doesn’t work (wired ethernet is fine, worked out the box).
On the network set up page i tried to switch on wifi but when I saved it a red notification came up - look at systemctl status wireless.service and the journel log.
Switching to a command prompt and looking at these the wifi was failing to load. lspci told me that the wifi was Realtek RTL8821AE.
Tried sudo apt-get install firmware-realtek and then sudo modprobe -rv rtl8821ae sudo modprobe -v rtl8821ae but although the firmware was installed it failed to load.
Is the Realtek RTL8821AE just not supported, or am I doing something wrong? I have a debian buster installed on a seperate disk and the wifi is fine on that.

Which version of Volumio did you install. When it is the officially supported one, then you ran into a known issue with drivers & firmware. In that case, read the Development Talk section, specifically the Development Talks/ Volumio X86/ Buster topic.

Have tried all. 2.779 at the moment. Will try 2.781 from your post in the development thread and post results there.
Kind regards