Volumio x86 + PeppyMeter

Thanks @Wheaten, and sorry. I realized that for me setting up Peppy on my x86 nuc will be a mission impossible. I don’t want to waste anyone’s time given my ignorance about Linux. It means I will have to settle or change my end goal.


I’m new to volumio and been banging my head to get peppymeter working on a x86/x64 based volumio.

Did anybody get it to work on a pc/laptop or is it only meant to be run on pi?

Please let me know if anybody knows. I spent way too much time on it and need to move on. I struggle to find reasons why there is so much support for volumio on pi and not so much for x86. A laptop has everything build in, wi-fi, bluetooth, screen, even a decent dac. Why bother with a pi when any older laptop would work.


1 Like

Hi, everything you need is here


Good day to all, I use Volumio on a mini PC, there is no peppymeter plug-in for WinX86, I installed it manually, it works, but I can’t make friends with my 1024x600 monitor. by default, pippi has 4 options and none fits, black stripes on the bottom and top and peppy is either compressed vertically or does not fit at all. I tried
it in config.txt add:

meter.size = large
screen.width = 1024
screen.height = 600

in configfileparser.py

SMALL = “small”
MEDIUM = “medium”
LARGE = “large”
WIDE = “wide”

The plugin stops running.
The x86 version of volumio does not have a config file, I do not know how to fix the situation. Help me with some advice, please.

Please restart from scratch and don’t modify settings manually.

Did you take a look here, for templates for your screen size?

Thanks for responding quickly, yes I used one of the Gelo 5 templates,

You followed my instructions?

Hi, I couldn’t answer quickly. Work and business. I installed the plugin following your instructions, so I did not reinstall it. I was able to solve the problem. Probably not quite right, but it works now. in cofig.txt I prescribed a
meter.size = large
screen. width = 800
screen.height = 600
If you leave the width unchanged, but only change the height, then PeppyMeter starts working on the entire screen. I had to change the size of the skin in PS c 800/480 to 800/600 without preserving the proportions, but at the same time everything began to look as it should on the screen.

The video is here

1 Like

Post in English please, if you want community members to help you. Not everyone speaks Italian.
Please stop cross posting the same topic.

[Google translate]
Anyone who can help me with peppymeter? I followed the whole procedure “I think correctly” the plugin is installed and also active with a green light, but no Vu meter is activated. I can’t understand what I did wrong, I’ve already done the installation twice! Thanks in advance to anyone who wants to help me!

Just installed a fresh image of V3.611.
Followed my instructions and it is working.
As this was more a proof of concept, I won’t provide support.

1 Like

Great work as always Wheaten! It works like a charm! As you said, a plugin would be a great option for PCs!

1 Like

Thanks so much for your wonderful instructions. All the commands worked without error.
Music plays, but the machine never goes into screensaver mode, so no peppy meter.
Anyway I can force it into screensaver mode?

you can try:

export HOME=/home/volumio/PeppyMeter
export DISPLAY=:0
cd /home/volumio/PeppyMeter
python3 volumio_peppymeter.py

tried this and I got this response:
pygame 1.9.4.post1
Hello from the pygame community. Contribute - pygame wiki
Traceback (most recent call last):
File “/usr/lib/python3.7/configparser.py”, line 788, in get
value = d[option]
File “/usr/lib/python3.7/collections/init.py”, line 914, in getitem
return self.missing(key) # support subclasses that define m issing
File “/usr/lib/python3.7/collections/init.py”, line 906, in missing
raise KeyError(key)
KeyError: ‘meter.size’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “volumio_peppymeter.py”, line 97, in
parser = Volumio_ConfigFileParser(pm.util.meter_config[BASE_PATH])
File “/home/volumio/PeppyMeter/volumio_configfileparser.py”, line 76, in ini t
meter_size = c.get(CURRENT, METER_SIZE)
File “/usr/lib/python3.7/configparser.py”, line 791, in get
raise NoOptionError(option, section)
configparser.NoOptionError: No option ‘meter.size’ in section: ‘current’

Seem your running a unsupported screen size. just stick with the default small, Medium and wide.

where do i set the default size ? This was a fresh install. just used your instuctions.

Guess you didn’t read through this topic?

There is no entry in config.txt called meter.size.
I could just add one I suppose, also there is no small, medium, large entries in configfileparser.py.
Anyways, I will read thru all that thread and keep at it. txs

Please do not reinstall peppy meter at time.
Peppy player have made some changes on the source. This needs some changes also on the Volumio Plugin. We are working on it.
Best regards

OK Please let me know when I can go back to this super fun Plugin.
Yeah Volumio and the whole community!