Volumio x86 + PeppyMeter

It is not the lates, there is a beta 2.0

It runs if I start it by hand i.e. I do:
sh /data/plugins/user_interface/peppy_screensaver/peppymeter/run_peppymeter.sh

Even having it disabled in gui.

Also funny that I can start it directly after installation (only enable the plugin)

What I expect is that is something with the alsa configuration in /etc/asound.conf that Peppymeter do after installation, that do not functions right after the restart.
Bur I can not change it, as it reinstall after I start Peppemeter.
My bee I can lock it, after doing change in it?

Well, I put the SD card with Volumio2 in an other faster machine with a Core 2 duo processor. Then it does not crash. The old Asus PC 900 atom processor was too slow, he!
So I took up a old screen from the basemet later, an added it instead to the Asus PC 900. Now it even runs on this old computer!

I also did a script inspired by

dromichet

post above. Thanks for that!

Modified it a bit, looks like this:

#!/bin/bash

sleep 3s
export HOME=/home/volumio/scripts
export DISPLAY=:0
export XAUTHORITY=/home/volumio/.Xauthority

while true; do

    if volumio status | grep -q ': "play",'; then

         # Playing

         cd  /data/plugins/user_interface/peppy_screensaver/peppymeter
         python3 ./eppymeter.py

     else

     # Stopped

           if ! pgrep -x "feh" >/dev/null; then 
                  pidof python3 && pkill python3
		
           fi
    fi
sleep 3s

done

I adde the line:
export XAUTHORITY=/home/volumio/.Xauthority

Script runs without it , but at lest the script runs on users permissions, so a bit more secure.

.

Hope this help some one else!

Got an other problem also, with screen resoulution. What I understand the main Peppymeter reads the xrand file for its custom alternative. My old computer had very confusing graphical configuration, after commands:

export default DISPLAY=:0
 xrendr

it looks like this:

Screen 0: minimum 8 x 8, current 1024 x 768, maximum 32767 x 32767
LVDS1 connected primary 1024x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x600      59.52*+
   800x600       60.32    56.25  
   640x480       59.94  
   512x300       60.00  
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480       59.94 +
   640x480       59.94 +
   1024x768      59.94  
   800x600       59.94  
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 380mm x 300mm
   1280x1024     60.02 +  75.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.08*   70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    60.00  
   720x400       70.08  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Peppymeter only pic up first part after LVDS1.
So I had to choose the 1024x600
, to make in some way good, but it is only part of screen, though my screen is:
1024x768.

In my:
/opt/volumiokiosk.sh

I had to add the VGA parameter for xrandr:

 xrandr -display :0.0 --output VGA1 --mode "1024x768"

So my thought is, either edit some Peppymeter Py file so it reads card right (add same parameter as in /opt/volumiokiosk.sh) , ore can i add my own screen resouluotion in some config file, witch files to edit?!
Glad for any help?

Hallo!

I thought I should test out new version Peppy screensaver 2.1.0, as it is new (and not beta any more). Looks promessing, I got segmenty fault on the beta, no more. I got 1.5 running before.

For the record, I am on a PC, Core 2 duo processor.

I done some upgrade on al Python modules, downloded and installed by pip3. I even upgraded pygame to latest that way. Then I tested al this command, as recommended, no errors: I did this as user, i.e. command python3, in console (ssh):

import pygame
from socketIO_client import SocketIO
import cairosvg
from PIL import Image

It’s starts and show up, but the meters is not moving. Guess it is only a alsa configuration problem.

I got in

/etc/asound.conf

defaults.pcm.card 5
defaults.ctl.card 5

Then I got /in /home/volumio) the following in

~/.asoundrc

pcm.!default {
	type plug
	slave.pcm "peppyalsa"
}
ctl.!default {
   	type hw
   	card 5
   	device 0
}

# input from Spotify / airplay
pcm.peppyalsa {	
	type plug
	slave.channels 4
  
	slave.pcm {
		type multi
	
		slaves.a.pcm "mpd_alsa"
		slaves.a.channels 2
		slaves.b.pcm "mpd_peppyalsa"
		slaves.b.channels 2
	
		bindings.0 { slave a; channel 0; }
		bindings.1 { slave a; channel 1; }
		bindings.2 { slave b; channel 0; }
		bindings.3 { slave b; channel 1; }
	}
    
	ttable.0.0 1
	ttable.1.1 1
	ttable.0.2 1
	ttable.1.3 1
}

# input from MPD for sound card (direct DSD only working with type hw)
pcm.mpd_alsa {
   	type hw
   	card 5
   	device 0
}

# input from MPD for peppyalsa	
pcm.mpd_peppyalsa{
	type meter
	slave.pcm "dummy"
	scopes.0 peppyalsa
}
	
pcm_scope.peppyalsa {
	type peppyalsa
	decay_ms 400
	meter "/tmp/myfifo"
	meter_max 100
	meter_show 1
}
	
pcm_scope_type.peppyalsa {
   	lib /usr/local/lib/libpeppyalsa.so
}

pcm.dsp0 peppyalsa

pcm.mpd_alsa_deakt {
   	type softvol
   	slave.pcm "snd_card"
   	control {
        name "SoftMaster"
        card 5
        device 0
   	}
   	max_dB 0.0
   	min_dB -50.0
   	resolution 100
}

# sound card output
pcm.snd_card {
   	type hw
   	card 5
   	device 0
}

# null output
pcm.dummy {
   	type hw
	card Dummy
	device 0
}

# Control device for program compatibility.
ctl.snd_card {
   	type hw
   	card 5
   	device 0
}

I have tested the card by speaker-test command.

Default:

speaker-test -t wav -c 2

speaker-test -D default -t wav -c 2

Peppyalsa:

speaker-test -D peppyalsa -t wav -c 2

Mpd alsa:

speaker-test -D mpd_alsa -t wav -c 2

snd_card:

speaker-test -D snd_card -t wav -c 2

Dummy:

speaker-test -D dummy -t wav -c 2

All have sound out, except the dummy, suppose it should not have sound either?!

I got the separate configuration in /etc/asound.conf to get alsamixer to pic up my USB sound card as main and so I could use alsamixer command directly (before I had to do alsamixer -c5). But after installing Peppymeter, alsamixer command does not function, had to do alsamixer -c5 again. I do not have default card now when I do alsamixer -c5, evan as speaker-test on default card functions?!

Well, I do not now if it’s related to alsamixer problem, but I write it out here, for full information.

I havet tested the main Pepptmeter command in console:

cd /data/plugins/user_interface/peppy_screensaver
sh run_peppymeter.sh

The only error I get out is:

libpng warning: iCCP: known incorrect sRGB profile

Surpose it is not related to meters not moving?

I think I missed some configuration for Peppymeter in alsa config file. I am a bit newbee on Volumio, but I worked a lot on Debian distros (also run one machine with Debian 12, and Kodi there).

Glad for any help!

what hardware do you use?
HI

  1. try with a new SD card,
    2)set volume audio output as jach
  2. use filezilla to load Peppy 2.1.0. at /home/volume
  3. log in with putty
  4. volume plugin install

It costs nothing to try

I will not try with a new SD card there is nothing wrong with my main installation, Volumio plays music from both nfs network, spotify and radio. I know how to install plugins by volumio command. I us ssh to transfear files, not filezilla. I don’t use putty, I am only on Linux distros, no need for putty.

I also waiting for a new SDD card, to install Volumio on later. It will arrive soon by post.

Redacted by @nerd

yet I had problems with an incompatible SD card.
Installing the plugin is very simple. There aren’t many options left to evaluate. Why does it work for everyone and why shouldn’t it work for you?

there is nothing wrong with my SD and my Volumio installation, I even can move it around to 3 different machines, it still plays music.

Redacted by @nerd

Often the worst enemy is one’s own ego

@Klasw

Please threat our community members with the respect they deserve, when they try to assist you in their free time.
These kind of responses will not help you in any way.

In short,

  • Current Peppy_meter > 1.4 doesn’t work well on a x86. I’ve tried but it needed to much tinkering, that it’s no longer feasible for me to support.
  • The suggestion to burn a clean install is more than appropriate, as you did a lot of tinkering, which makes supporting it even more troublesome.
3 Likes

The following problem occurs when I run peppymeter: If I select VU-meter Random and interval Random Mode, peppy will stop running after a while and the system needs to be restarted. However, if I select Interval mode, this situation rarely occurs. Does anyone know this? Why?Thank you~

Hi @fire,
that sounds a bit like a lack of memory.
Hi much memory have your pi?
You can try to reduce the cache size from 20 to 10 different styles or try to disable the needle cache generally

it is 2GB ,that is a X86 computer not a pi ,i have try to disable the needle cache, but still the same。

I solved the problem with peppymeter not moving, at least for mpd player (se post above).

For some reason the /etc/mpd_include.conf do not get read properly (yes I activated it), so I moved it to /etc/mpd,conf, as an extra audio out:

audio_output {
 enabled     "yes"
    type        "alsa"
    name        "mpd_peppyalsa"
    device      "mpd_peppyalsa"
    dop         "no"
}

But when I play spotify, the meters do not move. any help with that will bee appreciated.

maybe this will lead the way:

Well, if yoy read my post, I was never on 1.4, i was at first on 1.5 and now on Peppy screensaver 2.1.0. It works well, only need to get Spotify to function also.

Please reply in a normal way, I don’t do well well on remarks like “Well, If you read”, there is no reason for this kind of remarks.

The topic i highlighted (regardless the version) is regarding Spotify and modifying the template.in order to make it work, As you indicate you have issues with Spotify. If it works I don’t know but give it a try.

YOU WROTE THIS TO ME:

SO I REPSONEDED:
Well, if you read my post, I was never on 1.4, i was at first on 1.5 and now on Peppy screensaver 2.1.0. It works well, only need to get Spotify to function with peppymeter, also.
It works, I can play music and there is a peppymeter. you say it does not work well. What is so not normal with my comment?

Just want to have some help with Alsa configuration, I fixed every problem with my installation that way, ore with changing other configuration. There is nothing wrong with my SD card, with Debian ore Volumio installation. I worked with Debian since 2004, I know how to test it, how to test SD cards, it is ok.

I will not install beta, I just want to know where the configuration is done for Spotify Connect plugin, witch file to edit, there have to be a file defining main sound card, just as for airplay an mpd player. Then I know how to do a dummy plugin in /etc/asound.conf for Peppymeter too use.

I have tried to find documentation my self online, but it is very poor. Glad for any help here.