Volumio x86 and miniDSP HD - no sound

I’ve been trying to set up the x86 version on my spare computer.
Would love to get Volumio as my main music player, as it seems to tick most of the boxes I need for my setup.

I’m running an Open Baffle setup with a 15" driver and a full range, XO controlled by a miniDSP HD unit.

I installed Volumio just fine, and it sees the miniDSP HD as a USB output.

But… choosing the USB output, I get no sound coming out of the unit. The miniDSP control panel shows no sound coming in either.

Can’t find information about the miniDSP besides it’s analogue counterpart, which degrades the sound too much for my liking. I would like to use the USB input if possible.

I was able to get the USB output with Daphile, but there were some small pops and clicks during playback that led me to try Volumio instead, having read good reviews about it.



could you also try the dev version with the latest stable kernel version to see if it works better?
You will find the download link in the opening post of section Volumio Development/ Development Talks/ “Next X86”.
If that version does not work either, we have to do further analysis.
Also check whether “Volumio normalisation” in the Playback Options menu brings any improvement.

Thanks for the reply.

I downloaded the latest dev version and flashed the thumb drive with Etcher, but I can’t boot from it, it just crashes my PC after the two initial lines.

I’ll try to flash the drive via the Terminal on my Mac instead, to see if it helps.

Update: Nope, can’t boot the newest dev version.

I went back to the original, non-dev img file, flashed to the usb drive and booted normally.

Selected USB miniDSP HD, and if I put the volume at 100, I can hear the music playing, but way too low level. Barely above whisper.

I tried multiple combinations with normalisation on/off, and other parameters within the program, and at one point, I lost that whisper quiet music, and no amount of restarting or changing back to original settings made it come back.

Since I am not a command line guru, I don’t know how I am going to make this work.

I went back to Daphile, and got sound right away, full volume. So, it’s not the rig, but something in Volumio that is bugging on my system.

Too bad. I like Volumio, it’s presentation … just missing sound! :slight_smile:

ok, then I need more details about your hardware.
Could you start doing a log?
For that, go to the “http://volumio.local/dev” page, enter a desciption in the designated field and send the log.
It will return a url, which I need you to analyse it.
At the same time, enable SSH on the same page.
I’ll talk you through anything else on the command line later.


thank you for the follow up.

Here’s the link to the log:

I’ve clicked on enable ssh, but there’s no feedback to say if it’s really enable or not.

I don’t know the DAC you’re using, but it might well be that it has different hardware mixer. So go to playback options, select hardware mixer, click save. Then try to select different mixer name, and click save. Go to playback page and set volume to 100.
By repeating the procedure you should be able to find the proper mixer name of your audio device.

Keep me posted


My DAC is the miniDSP, as mentioned in the first post.

I tried Software and Hardware mixer. I tried both mixer names"clocks".

At the moment, there is no sound at all, even at 100.

I will try a different DAC (I have an extra couple of NuPrime DACs) and set of speakers, as I need the miniDSP for this set, doing the XO actively.

the log does not show any abnormal entries, usb dac is recognized (as expected), ssh was enabled.
MPD seems to think everything is ok as there are no errors shown.
There is a known issue with initial mute on certain devices, which causes a mismatch with what volumio thinks the state is.
To check that, we need to SSH into your machine and check this with ‘alsamixer’, any experience with SSH from a Mac or PC terminal? Know how to start it?
If not, I will try to guide you.

Ok, thanks.

I know the Terminal on my Mac, and I can copy and paste lines!
That’s the extent of my knowledge on the subject… :frowning:

I took a semester of Basic programming language in my youth… yes, it was a long time ago!
Later, I tried Fortran… that lasted a week before I ran out the door! :slight_smile:

ok, you already suit the profile :smiley:
I’ll get back to you soon, which timezone are you in?

I don’t know what profile is that… Hope it’s not too bad! :wink:

+8 UTC…

but will be unavailable for the next 1.5 hours.
I teach a class coming up in 10 min.

But, I don’t want to bother so much and take over your time. I’m sure you have more interesting things to do! :slight_smile:

I will look up ssh to another computer on Google, and if you could just tell me what to do about the mixer thing, I’ll give it a shot.

I used the same computer, and the same build of Volumio, and this time, I got sound as it should be right away, using the NuPrime uDSD small DAC.

So, it seems the problem comes from the connection to the miniDSP unit.

Seems to, but why is Daphile working? Do you by any chance know which kernel version it has?
Pity the dev version didn’t boot, that must have been a flash issue as the boot procedure has not changed between the released one and the newest.
There is still a chance, when you get it to boot, that the miniDSP would work with it.

Sorry, no idea how to find the kernel version in Daphile.

Reading on the net, it’s been mentioned it is not the latest…

On the FB page, they mention 4-14-4, on another forum they say RT15… No idea.

For the dev build, I flashed with Etcher, and that didn’t work. Then I flashed within the Terminal directly, and that didn’t work either.

I am downloading the dev version again, maybe there was a problem with the file.

I’ve been reading online. I think I can ssh to my computer. I’ll try today.
What should I do to check the alsamixer?

I downloaded the latest dev build again, flashed again, and still crashes after the two lines mentioning RAM disk.

reflashing with the website version now

Superbly weird right now.

I used the website version on the newly flashed (again!) usb drive,

First time I booted, it crashed, hanging on the big VOLUMIO splash screen.
Re-started, and this time booted well.

Chose the miniDSP USB output and … sound!

I have no idea why, but it works (at the moment!)… one of those, “I have no clue but it seems to be working now” moment.

So, I’ll be trying to add a few plugins later.

Thanks for letting me hang around and trying again and again…

Another day, another mystery.

I didn’t add any plugins yet… but…

Yesterday, It was all playing fine. I shut down the unit and went to bed.

Woke up this morning, fired up the unit, and Volumio refuses to play any sound. It’s booting ok, it shows the file is playing, no error message, but no sound coming out of the miniDSP HD.

Volumio is proving to be way too finicky and unstable.

I will have to go back to Daphile, which has been rock solid from day 1. Sorry.

I will give the miniDSP SHD series a shot later when they start shipping… hopefully, the Volumio port in that box will be more stable.