Volumio wont boot on 2nd RPI2

Hello folks and sorry if I actually missed the solution to my problem…

I got Volumio up and running on my RPI2…everythings fine…no complains…works out of the box…
But I got a 2nd RPI2…froma friend of mine… and I cant seem to get it running the same way it does on mine.

I can use the same SD-card I use on mine and put it in his RPI…but Volumio will hardly boot… most startups throw me “error bad block” messages… and I need to cut the power and restart the RPI for about at least 5-8 times before I get Volumio to start.
Another problem I got is, that if I reboot too often, and Volumio still wont start… obv. the SD-card gets corrupted…and I cant do anything else but reflash, and play this game again and again… still I cant figure out why the same image wont run stable on 1 RPI but on the other hand works without a problem on the other one?
Thought there might be some hardware revision… or some slight differences due to different suppliers… but couldnt get to the core… updating the libraries wouldnt help either… so I hope someone might be able to help me on this regard?

Thank you very much!

hello friends,
GREAT piece of software!!

Unfortunately the current image won’t boot up on the new raspberry 2.
Will this be easy to fix?


agree, the boot-Problems on Raspi starts to nerve…

my solution(s):

  1. never Switch-off the Player, instead use: “sudo halt” (remote via putty)
    (I’m in doubt about the functions “shutdown/reboot” via WEB-UI)

if the CF crashed: put the CF in an other Linux-PC
sudo fdisk -l (try to find the CF, for example /dev/sdc3)
sudo fsck.ext4 -v /dev/sdc3
(in some cases the FAT32-(Boot)-Partition ist also corrupted)

hope it hels


I have also tried to install volumio 1.55 on two raspberry Pi 2s today. The image will not boot on either machine but remains stuck with disk access light on an no network activity. As the two machines I have used are from different batches/manufacturers it is clear that the problem is in the current volumio distribution (I also tried several different SD cards).

I would recommend OSMC as an alternative to volumio as it works flawlessly and has support for all the DACs that can be used with the Pi.