Volumio with hifiberry dac and 3.5" touch screen

I hope I have posted in the right area.
As a newbie, I bought an RPi4, a DAC and a 3.5" touch screen thinking I could put them together to create a flac player. I have got to the point of the screen displaying using volumio’ plug in. The touch ability has not activated?
I accessed PUtty to add code. However, have no idea on how this is done. Can anyone shed some light on this process?
Thanks in advance

1 Like

Hi kp123,
the Touch Display plugin does not activate the touch function of a screen. Either this works out of the box (not for your screen obviously :wink:) or some adjustments / modifications have to be done manually from the CLI. What this is depends on the touchscreen so we need to know the brand and exact model name of your screen and how the screen is connected to your Pi.

Please also describe in detail what modifications you possibly already did.

Thanks for replying.
The screen is a MPI3508(from Aliexpress). It is connected to the RPi via 26pin connector. When I added the volumio miscellanea plug-in for the touch screen, the screen works and acts as a monitor, albeit, at the size of the display , it becomes unusable.
I have attempted to use Putty adding lines from a Google article titled "Tutorial 3.5 inch Display for Volumio.
I put each line in and pressed “Enter”. The exercise did not go as the description in the article suggested. I formatted the Sd card, loaded Volumio and tried again. It didn’t work.
I added ws-35b-v2 script to the Volumio boot files and tried again hoping that the instructions might read what was on the sd card. That didn’t work either.
I think there must be many that have this very basic, audiophile, RPi4 music player with DAC and touchscreen idea as a project. Volumio is great because it has taken care of the DAC.
The 3.5 player comes with image file but I dont know how and where these instructions are placed within the Volumio program.

I guess this is a complete OS image so you can’t use / install that in Volumio.

Are you now on a fresh Volumio system? If so try adding the following lines to /boot/userconfig.txt:

hdmi_cvt 480 320 60 6 0 0 0
hdmi_timings=600 0 20 28 48 400 0 13 3 32 0 0 0 30 0 25000000 5

I took these entries from the MPI3508-show script by goodtft (btw: DON’T run this on Volumio) but I do not know if all of them are really needed and if they apply to your particular display as I don’t have info about the manufacturer / brand of your display.

After editing /boot/userconfig.txt a reboot will be required. If the touchscreen should work after that but not be aligned to the visual display we will have to take additional steps.

Thank you for replying. I am totally “lost” with “adding the following lines to /boot/userconfig.txt:”
I guess I use putty for this but how do I get to it? When I do enter it do I end the sentence with reboot or do I enter reboot after the $ sign?
Thanks again.

1 Like

Connect to Volumio via SSH as described here. Putty can be used for that.

Open /boot/userconfig.txt with the nano editor:
sudo nano /boot/userconfig.txt

At the end of the file type in or copy and paste the lines I posted above.

Then close nano saving your modifications with Ctrl+x, y and the return/enter key.

You enter reboot after the $ sign (might need using sudo). Or you reboot Volumio from its UI. :wink:

Ok, thank you. I will do this now.

I took a screen shot.

When I entered reboot after the$ the process aborted so I pulled the power out an rebooted. The RPi4 did not reboot. I will prepare another installation. Thanks for showing me how to save the file. I will try following the 3.5 installation again.

This the google doc.

I will attempt this again(?)

The last line in your /boot/userconfig.txt appears to be incomplete. It should read

What does this mean? What process aborted? Did you close nano before?

I don’t think so, it uses the tft35a overlay. I doubt that this is suitable for your display.

The file saved. Thanks you. When it went to the screen where entries could be made, I typed the word reboot, but a white popup appeared telling me the process had been aborted. The putty screen was inactive, so I turned off the RPi by removing the C-connector to power. Then I powered it up again.
I have just booted up the Rpi and I have a display with miniscule login line on the screen.

Ah, yes of course: When Volumio reboots the SSH connection is ended. After booting up has finished you would need to connect via SSH again if you want / need to do further modifications from the CLI.

Could you check if the Touch Display plugin is active?
If this should not be the case try to restart the plugin and look for error messages from the UI. Also please execute
systemctl status -l volumio-kiosk.service
and post the result.

This is the screen I have ,if this helps

This is the screen that inspired the thought that I might achieve this result.

These are the details from installing the touchscreen plugin. The touch screen does not work.
After adding the line above I got

. I did not know how else to send the files.
Thanks again for your help.

I’ll be travelling for the next about 6 to 7 hours. After that I’ll have alook. If possible copy the output and post the text or PM me.

Could you try uninstalling and reinstalling (not only disabling and enabling) the Touch Display plugin please.

The Touch display was uninstalled and reinstalled with no change.
I tried to copy the text from putty but it caused it to generate a whole lot of code. Made a mess.
I dont know what PM is.
Again thank you for your time and effort.

PMed you.

Please post the results of
cat /boot/config.txt
cat /boot/userconfig.txt

P.S. Did you start with a fresh Volumio image before you modified /boot/userconfig.txt as suggested in post #4?