Volumio "webserver" not starting up

Volumio Information

Volumio Version: 2.882-2021-04-24
Hardware: R-Pi 3B+
DAC: iqaudio Pi-DAC+

I have installed and run volumio very successfully in the recent past. However, this time, after repurposing my Pi for another task, I have now reinstalled volumio from scratch. My music collection is on a USB HDD. But, despite several re-formats and re-imaging, I cannot get the volumio server to run over the Wlan. The SD card formats OK, the Pi runs up and resizes the filesystem OK, the wireless hotspot works and enables one to do the initial configuration, etc. However after that configuration and a restart, I then cannot connect to the volumio server via the Wlan and a browser. My router’s device configuration list has allocated an IP address and says the Pi is connected and online, running ping on my laptop returns 4 packets from the IP with no packet loss but says “the destination host is unreachable”. I can log into the Pi’s volumio OS via a keyboard and access the filesystem without a problem. Ifconfig lists wlan0 and its IP address OK and seems to be counting up the packets sent and received OK. But try as I may, whether I use the device name “volumio” as the URL or enter the IP address, my laptop browser times out. It seems that the volumio’s “webserver” simply does not start up. Any clues as to why. Many thanks in advance for assistance, Steve

Please provide a log file, so we might catch what is happening.

Thanks. But sadly times out as do both http://volumio.local/dev and http://volumio/dev. The browser simply does not connect to the volumio server. Also both SFTP (filezilla) and SSH (Putty) time out.

@steveapple can you burn your image with balena etcher this could help you with this problem.

Thanks DVO. After formatting with SD Association’s SD Formatter, I have burnt the image to the SD card using both the RaspberryPi imager and Belana Etcher several times. Same result. All the initial stuff happens and the hotspot starts. Configure the volumio and then restart. Then one cannot connect via the wifi although the router claims that the device is online.

can you connect it via wire ? it sounds that wifi is off.

Well… after tearing my hair out for hours and hours, formatting and re-flashing over and again onto a particular SD card, I decided that, as a really long shot, maybe it’s an issue with the SD card. After all, the PI connected to the WiFi perfectly with its native OS loaded on another SD card - so definitely no hardware problem. Thus in desperation, I flashed Volumio onto another SD card and, guess what? It worked first time!! The question remaining is why? The SD card I was using is 128GB (one I had lying around that was once upon a time in my phone), the one I have now flashed is just 16GB in size. I do not understand why the SD card (size or not) should have made a difference, but somehow it has. Nonetheless, problem solved. Thank you to all who offered possible solutions.

do you still have hair over? :wink: happy you found the problem…uhm bad sd i use a 128 g in my pi…

Thanks dvo. Still got some hair. Agree with you, could be a bad SD.