Volumio VERSION: 2.001 always restarts in Hot-Spot mode

If there is no ethernetcabel connected volumio restarts allways in Hotspot mode and ignores the Wlan settings.
Changing to Hot-Spot mode and pressing the save button in Wlan settings will suddenley change to the given Wlan settings.
At shutdown or restart Volumio will restart again in Hotspot mode.

Could you please try to connect via SSH and type (after configuring wlan)


and then reboot

does it work this way?

No, only if hot-spot is deactivated.

It seems it´s a prob with the priority of the network connections and active states.

WiredLan always is functional if connected and reachable.

If HotSpot is activ it has an IP like this: 192.168.211.X
So it´s not reachable from the rooter (192.168.178.x) but from smartphone

After saving Wlan settings Volumio suddenley changes to Wlan IP without restart.
So it´s reachable from the rooter until a restart with activated Hotspot, then it has the HotSpot IP again.

Switching off the Hotspot will not stop the Hotspot but changes it to the set WirelessLan IP without restart.

After restart the rooter will show the HotSpots name with the WirelessLan IP from the settings
and the WirelessLan Antenna from the Raspi will get the next free IP because the fixed one is used
from the HotSpot.

So it looks like that

  • WiredLan IP is No. 1
  • HotSpot IP is allways No. 2 while active
  • WirelessLan is allways No. 3

When HotSpot is not active:

  • WiredLan IP is No. 1
  • HotSpot is No. 2 and gets WirelessLan IP and is active
  • WirelessLan IP is used from HotSpot and will get a new IP from the rooter

Regards Jo

… or settings are not saved correctly for restart situation, because:

after restart it also looses type of DAC.
It´s setted correct in the menu, but doesn´t works
Pressing save in the menu helps suddenley.

It´s not possible to change Startvolume it´s allway set to 100%.

Also there seems to be a difference between rebooting by disconecting power,
using restart in the settings and using shut-down in the settings.

Did you flashed directly 2.001 or did you update from an earlier version?
Did you try the sync method that I told you before?

Yes, I tried the SSH and Sync without success.

I tried both, Update and fresh installation, also different WLAN transmitters.

Good luck to Your wonderfull work and allways remember …

Spirits that I’ve cited,
My commands ignore …

Johann W. v. Goethe