Volumio USB drive not a USB drive?

Hello Volumio peeps!

I have Volumio installed on a RPI4 using the AudioPhonics streamer. Everything works great, except the USB drive is throwing me for a loop.

I have an external RAID1 USB drive plugged into the PI, I can see it when I ssh in. I formatted it as EXT4 and it shows up as /dev/sda1.

I then connected to the pi from a Mac from Finder using Connect to remote server… smb://192.168.x.x./usb. I copied some files over to it successfully from Finder. The files show up on Volumio under Music Library → USB. I can see the files I copied and play them on Volumio. Great success!

My concern is when I unplug the USB drive, the files still show up in Volumio and I can still play them. I unplugged the USB drive, rebooted everything and the files are still there and playable.

Hence, I assume the files are not actually going on to the USB drive, but the microSD card. How can I correct this?

I’ll answer this since I figured it out myself and there is no clear documentation anywhere.

Assuming you have given the drive a mount point. I called mine /ssd

  1. Edit the samba.conf file:

sudo nano /etc/samba/smb.conf

under USB, change the file mount to whatever the mount of your USB drive is. In my case it was /ssd. Mine looks like this under [USB]:

comment = Volumio Internal Music Folder
path = /ssd
read only = no
guest ok = yes
writeable = yes
public = yes
browseable = yes
create mask = 0644
directory mask = 0755
force create mask = 0644

I’m fine with allowing anyone on the network (me) to read/write to it.

  1. Auto mount the usb drive at boot. I followed this guide:
  1. I could then connect to the USB drive from a Mac and read it, but I couldn’t write to it. Fixed it with:

sudo chmod 777 /ssd

Now it works, the USB drive is the RAID1 drive I have attached to the RPI.

This is much easier than setting up a separate dedicated NAS since I can connect to it and drop new music on it.

Slam, bam thank-you-mam.