Volumio Update Folder problem

Hello everyone.
My current setup is RPI 3 +Allo Kali + Allo Piano 2.1. I’m on Volumio v2.773. As a source, I generally use either my Hard Drive that is connected to the USB port on RPI or a shared folder on my external HDD which is connected to my PC. I have no problem seeing the content of both locations however when I add new files or folders to these locations and click on “update folder” on Volumio, which I click on the specific folder that I want to update, it keeps forever to detect the changes and often times it won’t. It doesn’t matter whether it’s just one song or a couple of folders. As on the attached picture, the updating sign right next to the music library keeps turning and turning. I need to restart RPI to get rid off it and click on update again. How can I resolve it? Sometimes I add just 5 songs and I don’t get the folder updated.
Thank you.
RPI 3+ Allo Kali Reclocker + Allo Piano 1.2
volumio 1.JPG

I’ve seen similar behaviour, over a few versions.
Sometimes it seems that the only way for the updates is patience.
Mostly I think the current version is updating quickly with new media added, especially if it’s adding a new album to a band that is already present, that seems to go very quickly.
But sometimes adding a new band and album takes what feels like forever.
Sometimes I think it helps to go to, Settings, Sources, My Music, Update.

Thank you for your reply. Yes I go to sources and do that but it still keeps going. Might be something with the current update because before this new update small changes get updated right away…


The best way I found to avoid this is in 3 steps:

  1. prevent volumio from automatically updating the DB. This is done in /etc/mpd.conf (parameter auto_update should be set to No) and also in a config.json file under /volumio/app/plugins/music_service/mpd. Parameter auto_update must be set to “false”. Run “killall node” when this is done, or reboot.

  2. when you make changes in your library, first update manually the MPD DB. This is done by connecting through ssh to volumio and run “mpc --wait update”. If you know precisely what has changed, you can give a path like “mpc --wait update NAS/”, you will save time if your library is large.

  3. When you get the prompt again, this means that the MPD DB is now updated. Just relaunch volumio with “killall node”. Volumio will take again the time nedded to boot, but not longer.

You should not get any turning wheel, and be ready to listen to your new albums…

If you’re happy with this, you can make a bash script that does the job, and call it in /etc/rc.local.

And you’re done… :smiley:

Hmm it looks like I need to work my rusted Linux skills out :slight_smile: Thank you!


Not so tricky indeed.

It’s only if you want it to work by itself that you need to write a script. And this script is fairly simple, I can give you mine if you want, you just have to adapt it.

Otherwise, manually, you just have to log into volumio and type one command when you know you need to update the DB:

“mpc --wait update && killall node”