Volumio stops playing Tidal 6s before the end of the song


Volumio Information

Volumio Version: 3.055 (beta)
Hardware: x86

Debug Log


Steps to Reproduce

  1. start playing an album on MyVolumio / Tidal
  2. 6s before the end of the first song playback will stop
  3. playback is completely stopped, the next song in the album will not start playback

Additional Information

I’m using MyVolumio “Superstar” and a Tidal “Premium” (not “HiFi”) account.
The Volumio version (3.055) is the latest beta in the Volumio Buster Beta program. I’m sure that it worked well with continuous playback of several songs in the playlist (album, whatever) some days before. So I presume that there might be a general issue with MyVolumio and Tidal…
Playback of Tidal songs and albums works correctly when I’m using the Tidal WEB interface.

My MyVolumio has upgraded four days ago from “Virtuoso” to “Superstar”. I don’t know if there can be a correlation to that…?

Here are some similar experiences:

btw: updating mpd to a new version is obsolete because volumio 3.055 has already mpd version “Music Player Daemon 0.22.3 (0.22.3)”.

If I can help with additional information, please let me know.

It is very similar to what I get with Qobuz… And sometimes, with local files. Seems mpd is in cause, or alsa pipeline.

Today everything is working fine again with Tidal.
Seems to be a server-based problem that apparently has been solved…


I have a similar problem with Qobuz running within Volumio 2 or 3 Beta on a Tinker Board with a Virtuoso subscription. Either playback stops or skips to the next track in middle of a track. Playback usually can be restarted. My suspect is Volumio sometimes is not able to recover from server issues.

I can´t remember to face this problem using BubbleUPnP streaming Qobuz via Volumio.

Now I see this problem again. 6s before the end of the song playback mutes, the playback clock runs until the end of the song and then no more playback is possible.

When I then make a change at the “Playback Options” and change to another “Output Device” plaback is working again.

I fear it’s no server sided problem but an issue with MPD or ALSA …?

2021-04-13: (Volumiobuster-3.055-2021-03-12-x86_amd64)
Tidal is stopping again - 6s before the end of the track playback mutes, then no further playback is possible…


Raspberry Pi
Volumio 2.907

I have this exact issue too

I’m having this same issue with Qobuz. I’m using Allo digione player. Almost every listening session ends up with this problem and its really annoying. Rebooting helps sometimes, but not always.