Volumio + spotify - source not visible

Hi all,

I’m hoping that some folks may help me with this.
I got a brandnew RPI3 model B and a freshly installed image from this afternoon.

All works well (radio, nas mount etc…) but the only thing I’m battling with is Spotify. After some research I found a topic from skikirkwood with some guidance about the plugin installation which worked ok.
Yuy for me.

I was expecting to view a Spotify icon under the “Browse” list just like web radio/playlist and other. It doesn’t appear and as such I cant search for spotify music or my playlists.

The logs of volumio indicate the connection is succesfull so not sure where I should be looking?

  • The my appearance where you can select the Sources Visbility doesn’t show Spotify either.

Any thoughts someone?

2019-10-01T14:48:17.814Z - info: Spotify credentials grant success - running version from March 24, 2019 2019-10-01T14:48:27.077Z - info: [{"prettyName":"Spotify","name":"spop","category":"music_service","version":"1.3.5","icon":"fa-spotify","enabled":true,"active":true}] 2019-10-01T14:48:29.362Z - info: CoreCommandRouter::getUIConfigOnPlugin

2019-10-01 16_53_11-Window.jpg

To check if the plugin works correctly, search an Artist or song or whatever and it should return Spotify results.
Also, a reboot might help.

Hey Paulm,

Thanks for the reply.
Already did a couple of reboots but unfortunate no such luck
Searching doesn’t give any results back.

Note: I saw in another topic that teh issue is facebook related

So now it’s working, case closed :smiley:

Perfect that you solved it.
If it does not return any Spotify results via the search, that indeed indicates that there is something wrong with the authentication.

We’re working on that