Volumio Service Start/Stop loop (0.935 x86)


Firstly, I’ve used Volumio for some time on various RaspberryPis and it’s worked really well for me and my friends, so thank you very much!

I’m trying to recycle some old hardware I repaired - an Intel Atom (x86) minicomputer with ethernet, wifi, SATA, etc for use with Volumio x86:


It seems to boot correctly and the Chrome browser (in kiosk mode) opens and attempts to connect to the local webserver but fails.

When I switch to the first terminal I noticed the Volumio service and the Airplay service appear to be in a continual loop of starting and stopping.

I can SSH to the box and access logs, but I’m unsure where to look first. Can you suggest where I should start my investigations?

Best regards,


P.S. Here’s a video showing the messages whilst booting:

dl.dropboxusercontent.com/u/140 … 2%2050.mov


could you please open an issue on http://github.com/volumio/Volumio2 using the issue tab?
This is to make sure it gets seen to. I have not been able to reproduce this, but will try more this weekend.
In the meantime, could post the contents of /var/log/volumio.log?
Could you please also do sudo journalctl -f > /home/volumio/log and post the contents of the file?

Edit: Could you try v 0.963 (downloadable version from 25.07.2016) and check if you still have the issue?
Note that x86 is still work in progress. Not everything might be working yet, so your feedback is very welcome!
From your video I guess there is a network issue, not sure exactly. When you ssh in, could you check if the machine got an ip?
(ipconfig -a)

Whooaa - that fixed it!

The new volumio-0.963-2016-07-25-x86.img booted straight in to the WebUI - I wasn’t expecting that to work so well - great job!

The WiFi and Ethernet appear to work fine.

The SP/DIF output from the onboard Realtek High Definition Audio isn’t working yet, but this isn’t a problem for me since plugging my Cambridge Audio DACMagic 100 via USB appears to work just fine!

All your efforts to move to the new platform appear to be paying dividends!

Thanks again


How to download volumio-0.963-2016-07-25-x86.img?
The 0.976 x86 version from main page does not boot on my PC.


There doesn’t seem to be a list anywhere, so you can recreate the URL if you know the filename.

Here you go:

updates.volumio.org/x86/volumio/ … 86.img.zip

you mean the 0.963 version worked and 0.976 does not?
Nothing happens or do you get an error or does it stop somewhere?

With a million different PC’s out there it is difficult to guess what might be going wrong.
Can you tell me a bit more, what is it? PC, notebook, chipset, cpu, amount of memory?
Booting from a hdd or an usb stick?


Thanks for response. I got it solved already. It has something to do with UEFI BIOS and Windows Secure boot settings. It must be turned off, otherwise volumio 2 does not boot from USB drive. Worth mentioning in installation manual on download page.
So volumio (0.976) is up and running now.
The only thing I miss for now is possibility to adjust volumio screen size to fit into TV (I am using HDMI between PC and TV. Volumio screen is “bigger” than my TV and some button are not visible). For example I had such adjustment every time I install fresh windows. Otherwise some buttons are not visible on TV screen and you have to guess where they are … So I guess for those using TV instead of regular monitor would be nice to have additional option in Volumio 2 menu setting called: “Display Ratio Adjustment” to fit Volumio 2 into your TV set. Same as it is possible in windows settings.

No, this is not something for volumio. Your TV should have a menu option to increase or reduce overscan.
There is nothing we can do to solve this for all possible devices, we’re in audio, not video :mrgreen:
Hope this helps anyway…

Please help us and start your own thread for different issues, with the number of questions we currently get, it is nearly impossible to keep track of which problem hides behind which thread title.