Hi Everybody,
I know it has been a long wait, and there was a great lack of communication… We just literally put our heads in the sand by devoting every little time we had into Volumio 2. And now it’s ready to be released. This is RC2, meaning it will be the last version prior to definitive release. So we expect just to fix some bugs and then release it for stable use.

What you will find:

  • Theme manager with awesome backgrounds. For those wanting to keep it simple, just select a background coloror.
  • Fully functional plugin system. Only plugin available as of now is Spotify, but there are some already in the works which will be available soon. Starting from next week this functionality will be fully documented allowing everyone to write his own plugins.
  • Nas discovery: no more fiddling with paths or names. NAS mounting should now be a breeze.
  • New search mechanism: look for artists, albums or webradios with just a search
  • New Webradios API, thanks to Shoutcast there will be thousands of webradios included
  • Multilanguage: full support of english and italian, with partials support for french language. More info on how to send your own translations soon.
  • Reworked play queue: select random, consume, clear, save to playlist directly from there.
  • Common queue for spotify and music library
  • Ability to sort items in queue
  • Way faster navigation, especially on mobile
  • Choose if shut down or stop music on sleep
  • Selectable one click volume options
  • Compatible with any pi version
  • Over 300+ commits from RC1

Really look forward to hear what you think. It has been a long wait, but I hope it was worht it. Enjoy!


A new hotfix version has been released:
updates.volumio.org/pi/volumio/0 … pi.img.zip

Anyone on RC2 Can update to latest hotfix version using the OTA Updater. Just go to system -> check for updates


If you want to contribute by adding your language to Volumio, here’s how to: contribute-translating-volumio-your-language-t4289.html


  • Unfortunately the updater cannot be used (to update from RC1) since we changed the kernel. However we expect to stick with this kernel for long time, so from there the updater can be used.
  • Odroid, x86 and other platforms coming soon!

From your feedbacks, here are the things to fix \ add:
(we’ll add them and release an update soon, no need to reflash…)

Added French, German, Dutch and japanese language translations
Fixed I2S DACs not sticking as options
Fixed NAS addition when no drive is found
Fixed condition that prevented to mount NAS shares with spaces
Fixed NAS options
Exclude Volumio share from NAS broswer
Fixed WebRadio Playback
Fixed Playing album
Fixed removing my webradio
Fixed Editing mywebradios
Create local music folder and share it via NAS
Add Soekris DAC and RaspiDACv3
Added auto unmute for iq audio AMP


  • Add importing of M3U playlists


Yay! Will update my V2 rc1 as soon as I get home. By the way is it as a update or will I need to install it over again?

Sent from my iPhone using Tapatalk

Yes! Yes!

I wonder if it’s upgradable (from RC1) too.
Because I’m that kind of guys who put 50 GB of music in the MicroSD card.

Same here - can we update?

And nas discovery?

Is that all automatic?

Will this work for Pi3 as all previous would not register the library correctly in fact it showed as empty will give it a try anyway will post my result

Just wanted to say thanks for the insanely big amount of effort you are putting into this guys. Thank you very much.

Looking forward to try it.

Yes !!! But as it has been said, it still a RC… with still some bug or work to do. Some are already known :
So please don’t use "Français " as language or you’re going to lose side menu. If it’s already to late, you have to do the following to avoid reflashing :
ssh to your device
nano /data/configuration/miscellanea/appearance/config.json
and change { "language": { "value": "Fran ais", "type": "string" }, "language_code": { "value": "fr", "type": "string" },

{ "language": { "value": "English", "type": "string" }, "language_code": { "value": "en", "type": "string" },
cd /volumio
killall node

You will surely discover other bug… so let us know !
Enjoy it !

No, unfortunately the updater cannot be used since we changed the kernel and the kernel updater is not implemented yet…

First of all: amazing piece of work done by all to get RC2 out. Congratulations.
I am running into a couple of problems however. While RC1 was working ‘straight from the box’, RC2 is not.

Here are my findings:

  1. On my Pi3 the Hifiberry DAC configuration in the Playback Options does not stick. It keeps turning back to output device ‘Audio Jack’ however often i put in ‘HiFiBerry DAC’. And the result is: no sound. In RC1 this works fine.
  2. NAS Discovery does not work. It keeps on scanning forever and whatever you put in manually does not stick either. As a result the NAS can not be attached to Volumio. In RC1 this was not a problem: it could easily be attached manually.

So folks, again, I can see all the work that has gone into it, but there are still some major issues.
Thanks for all your efforts.

Thanks for your feedback wim.
As for the hifiberry bug, expect a fix next week (with an update). For NAS, could you share some more details to let us understand what goes wrong? What NAS do you have?

Right now, as the minority kind of users who insist bringing this fantasy outside, I can’t find the access to the local music directory to import my collection.

The system directory seems to be hidden when I mount the SD card under Linux.

The good old “\volumio” under Windows prompts a login window, where the volumio/volumio combination won’t work. Kind of stuck here.

Awesome news about RC2!

I have gotten it working and mounted my NFS NAS drive.

However, my HifiBerry Digi does not seem to be sticking as the output source, and there is no audio output.

Thank you, Aaron

Congrats for this superb release!

All going well, just can’t find where playlists are stored.
Settings say /var/lib/mpd/playlists, I created a test one but nothing there…

Just found (Github) that they now reside in /data/playlist

I have a NAS4Free based NAS, which is visible throughout my network and was easily hooked up in Volumio1 and Volumio 2 RC1. in RC2, as soon as you open ‘Add New Drive’, it start scanning and keeps scanning, without finding a NAS and while you can enter the configuartion items in this menu, it does not accept them when pushing ‘Save’.
I managed to make a workaround by editing fstab and adding the directory manually to /mnt/NAS. This will show the NAS in ‘Music Library’ and I can actually play it and hear the music. So HiFiBerry DAC+ also works now, even if the Output Device in Playback Options shows the wrong entry. So this is apparently not a networking issue.

Another issue that came up is that although all radio stations (either Dirble, Shoutcast or my own Shoutcast Favourites) show up and playing them puts the link into the Playback menu, not one of the radio stations produces sound. And the HiFiBerry is off the list of suspects now, see above.

I use Odroid c1+ and the only way to use RC1 was only possible with an Odroid suited image.

Any Odroid users out there who tried using this image?

Sent from my iPhone using Tapatalk

Hi Mair,

hold on for an hour or so, I’m building the Odroid images “as we speak”.
After a quick verification I will upload them to http://oph.mdrjr.net/gkkpch/

We hope to get “official” Odroid images out soon, everything is ready, the only thing missing was time :slight_smile:

Thanks [emoji1303]

Sent from my iPhone using Tapatalk

Could you please type via SSH:

echo volumio | smbtree -d 3

and paste here the results? (if you feel there are too private datas, send via pm)

Built, verified and uploading now. This should be finished in approx. half an hour.
Wait until the md5 files appear, then you know the image files are complete and you can safely start downloading.

on my RPI 3 don´t even boot…
there is something wrong.

i don´t have nothing connected. only the network cable and hifiberry dac pro