Volumio + Raspberry PI Offline: possible?

Hi, I’m a person who decided to use Volumio for its Hi - Fi via a Raspberry Pi 2.

The system has been properly installed and works very well, I changed the song from smartphones and from the PC via the webUI, I would have only one request:
you can use Volumio Offline? I wish I could select songs by the same Raspberry (connected to a keyboard + mouse and a monitor), without having to connect to the Internet without having to use an external device.

Unfortunately Volumio not a window manager and I do not know how to solve. Thank you.

You want a GUI actually running on the Raspberry Pi to control volumio?

You can start with using mpc commands from the command line. You could also install a gui and browser but that’s a pain getting it to work on volumio 1.5(5) dependancy hell and all that.
Or you could opt to use keyboard / mouse input on a low level, still rather hard but an old mouse could control the most common navigation (play/pause/volume /next/previous) this will require some programming. Or add a remote.

But out of the box you can only use the commandline to control mpc. And of course an other device


You can not create “macros” low level, that the touch of a button (for example, Ctrl + W) changes song, with another key us pause and so on, all from the terminal?

I do not care much graphics, it suits me even the command line.

You could create a script and when you start it you can listen to input signals from the keyboard. But that’s real diy-ing and requires programming. I can’t really help you with that.

Ok thanks a lot, have you some tutorial can i see for this? Thanks.

In my side, I put a USB WIFI dongle ; and the Raspberry with Volumio works as Access Point.
So My Phone connect itself to the Raspberry and command it ; I don’t use other network.

once inserted the dongle usb wifi what should I do ? I have to give some control ?

Something like that:

apt-get update
apt-get install hostapd dnsmasq

vi /etc/dnsmasq.conf

vi /etc/hostapd/hostapd.conf

vi /etc/network/interfaces
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet static

vi /etc/default/hostapd
Remplacez la ligne #DAEMON_CONF= » » par DAEMON_CONF="/etc/hostapd/hostapd.conf"

service dnsmasq start
service hostapd start

and reboot

Thanks a lot.
I try but do not work, the vi command open a file but what is this?
if i try to use nano i can not to save…

try sudo nano instead.

I am already root.


How can I disable the control passage startup that controls the raspberry is connected to the internet , and if not prevents booting ?

— EDIT —

I solved in this way :

su *insert your root password* nano /etc/network/interfaces

delete this line

auto eth0 iface eth0 inet dhcp

save and reboot.

that actually shouldn’t prevent you from booting, it would probably only take some more time to boot.
Disabling like you did shouldn’t be a problem as long as you have a wireless connection, but i would prefer to set it to a static IP outside your normal range and remember/write it down. So in the future when you want to use the wired connection you won’t run into trouble. Or when you change the name or password of your wireless network

The Raspy work very good with my Hi-Fi! :smiley:
I’ve only one problem:
since I just have to use the command line, I recycled an old VGA monitor.
I used this HDMI - VGA cable: i01.i.aliimg.com/wsphoto/v0/5666 … jector.jpg
But if i boot my raspberry i don’t see anything.
If instead i boot the raspberry connected at a TV with HDMI and after disconnect the raspberry and connect him at this cable all work fine.

At this time all work everything works until it detachment from the device current to restart (instead, if i use “Sudo reboot” work fine).

Why this? It’s a boot/config problem?
Thanks a lot (sorry for my english).

Have tried an other distribution, like raspbian? What did it do then?

I think that the screen isn’t recognised by the HDMI output. These kind of adapters tend to forget those kind of things…

You could try to force hdmi video out from the config.txt. Since I don’t know it you’ll need to Google the exact command.