Volumio Publish Plugin not updating GitHub as expected

I’m writing a plugin on Version 2.868 and I’m developing the plugin locally in /home/volumio/volumio-plugins/plugins/miscellanea/mpd_oled

When I run volumio plugin package I get mpd_oled.zip appearing in my plugin folder as expected.
When I run volumio plugin publish from the plugin’s folder, my plugin does not appear in my Github branch in plugins/miscellanea/mpd_oled as expected. I do see an old version of my plugin in the example_plugin folder on Github. volumio-plugins/package.json at master · supercrab/volumio-plugins · GitHub

What have I done wrong?


You can’t do that… You have to send a PR in MASTER branch, with only your source code, no node_modules
Yes, the doc needs to be updated :wink:

Thanks @balbuze Sorry, I’m meant to say publish not package. I’ll make it a bit clearer: I’m trying to publish the plugin to my github repository, i.e. I’m trying to update the changes to my branch. I’m not trying to do a pull request for merging just yet - I want other people to test my plugin but it’s not possible, currently i find

  • my code changes for my plugin do not appear on in my branch in gitub
  • there is no zip file uploaded to my branch
  • the documentation mentions plugins.json should now contain a link to the zip folder, but where does this plugins.json get created?

Any ideas?

I’ve managed to work out how to publish to git hub using the command line. For some reason the plugin utility would not publish changes to my plugins folder on my repo.

git status
git add .
git commit -m "Changenotes"
git push