Volumio Primo Boot

So Volumio Primo does not boot from USB - is it correct or am I missing something?

No, it does not boot from USB.

And there is absolutely no way to revert it to version 2 then?

No. What is the problem that makes you want to go back to v2?

This was posted in another thread Does anyone have a link to Tinker Board Volumio 2 images? - #7 by sngreen

Continuous play when controlled from the other apps mostly. It’s just nagging me that I have lost something with this upgrade. Wish I did not, but I did not know better. Perhaps there will be an update to v.3 in future that will fix whatever’s remaining, but who knows.

Yes, we ask because we want to fix it.

Can you explain a bit more in depth what you mean with “Continuous play when controlled from the other apps mostly”. Knowing that we can investigate and fix.


I use HiFi-Cast as a controlling app for all my streaming, streaming from inhouse AssetUPnP server. It no longer streams continuously and unless checked “Force track advance” (which is not compatible with continuous play) it will also stop after each track. I tried other apps, with the same results, unfortunately. So, let’s say you play “The Dark Side of the Moon”, and instead of smoothly going from one track to the next there are now rather long pauses in between.

Ok, so you lost “Gapless Playback” from UPNP client apps.

Are you sure it was working in version 2?

Those answers will help us fix this

I also have non-upgraded volumio primo box on version 2.873 and it works fine. I also have other streamers in house, and they all work fine.

So yes, I am sure it is version 3 that broke it.

Thanks, we’ve added it to our bug list. Can’t provide an ETA on when it will be fixed, but we will do

I can confirm the above behaviour (also a Volumio Primo user). With 2.xxx continuous play (and gapless) over UPnP worked without a hitch, but with 3.xxx advance track has to be done manually - also elapsed time does not work (I’ve tested with mConnect, BubbleUPnP and also Foobar on a Windows PC).

I’m not a heavy user of UPnP so for me it is a minor issue.

Oh my! Just upgraded to 3.233 and gapless is as smooth as ever thought it should be.
Thank you

1 Like

Spoke too soon. I think it still needs some work. The slider does not advance while the music is splaying and it stops after the first several tracks. As I have two volumio primo boxes and the other is still on v.2, I know this is not the same behavior on the other.

I am glad to see there is some progress nevertheless.