Volumio on the Raspberry Pi Zero 2

Hi All

I’ve got my hands on a new Raspberry Pi Zero 2 W, which I was hoping would provide a little bit of extra processing power over my current beloved Pi Zero W with Pirate Audio DAC running Volumio with @AxLED’s excellent pirate audio plugin. The Zero 2 has a quad core CPU, compared to the single core of the Zero W. It boots Raspbian Lite, and I can log in and use like I would any Pi. Unfortunately, if I take the SD card from my working Volumio (2.917), and put it into the bare Zero 2 W, it doesn’t appear to boot. The web interface doesn’t come up, there’s no Volumio hotspot, and there is no flashing on the disk activity LED. The same happens with freshly burned (with Balena Etcher) 2.917 and 2.907 images that I’ve tried on other SD cards. So, the system appears to not boot at all, but I don’t know how where to look now for a possible solution to this problem, or for further diagnosis.

Any hints / stories from someone who has got Volumio to work on the Zero 2 W?


1 Like

Apologies for the dupe of Raspberry Pi Zero 2 - Not Booting - #2 by arckuk, I did a search and found no reports of Pi Zero 2 with Volumio, and in the hour or so I spent confirming the result, @kaybee61 posted their problems.

did try a 3.xx version ? maybe that works…

Yes - version 3 is booting on RPi Zero 2.
I have used https://updates.volumio.org/pi/volumiobuster/3.129/Volumiobuster-3.129-2021-10-29-pi.zip
Thanks @dvo

1 Like

your welcome :slight_smile:

Does the Wi-Fi work?

yes, wifi works.

Just to confirm, this is the on board Wi-Fi, not a dongle right?
Great! Looks like they back ported the patches to 5.4.yy as well! :slight_smile:

Raspberry Pi Image is not working on my new Pi Zero W2. Powerled stays off.
SDcard is ok, Raspberry Pi OS Lite works great.
Are there more Pi Zero W2 users with this problem?
Grtz from NL, Wim

yes,it is the onboard wifi, just the naked Zero 2.

1 Like

Just got the new Raspberry Pi Zero 2.
Has anyone got Volumio running on this?
Ive loaded volumio-2.917-2021-10-06-pi.img but it won’t boot.
The image will boot on an original Pi Zero, but when the SD card is put back in the Zero 2, nothing works.
I’ve tried 2 different SD cards, but no joy.
The latest Raspbian lite does boot on the Pi Zero 2.
Does anyone have any suggestions please?

1 Like

I’ve just posted on the same subject, I searched for similar posts, but couldn’t find anything when I first checked, and have spent the past hour or so confirming my problems, so sorry for the dupe. Anyway it looks like it’s a problem we share! I also got Raspbian Lite to boot. Hoping someone will come up with more insight into the reason why Volumio won’t!

1 Like

PI Zero 2 needs a few changes, it is work-in-progress. With Volumio 3 RC1 it should work.

1 Like

Thanks @tigger-gg and @dvo , a beta version 3 download works fine on the Pi Zero 2 (I used the latest 3.129 build).There is a definite improvement in responsiveness compared to the previous Pi Zero. Unfortunately, I can’t get the pirateaudio plugin to work with beta 3 (st7789 module seems not to work at all), does anyone have an idea what the would be needed to get Voumio 2 booting on a Zero 2?

A time machine :wink: It probably needs a kernel update for the patches for the Pi Zero2…

1 Like

3.129 worked for me too, but Id also like to have Volumio 2 working as I want compatibility with my other volumio boxes around the house

What exactly do you mean by compatibility? You can still control 2.xx instances from 3.xx and vice versa…

I’m using the snapcast plugin. Not quite sure of the compatibility in V3

Don’t forget Volumio 2 is going EOL soon.

Thats a shame, because V3 appears to be 64bit only, which will impact on my older Pi’s