Volumio on RPi Zero


Recently I’ve got a new RPi Zero.
According to the raspberrypi.org, it’s the same as “old” RPi with cpu working on full speed (1GHz).
I’ve wanted to use it as a “bedroom player”.
I’ve installed the 1.55 image on a card (later also tried Volumio 2).

Unfortunatelly, it didn’t work. Only the led is blinking a couple of times and nothing happens.

Any idea how to make it work? Will it be “officially” added to Volumio in near future?

MoOde Audio is working without the issues on RPi Zero.


I’ll buy Zero as soon it come in shops.
I will use it as radio/music player in my kitchen so it must be cheap as possible and high sound quality is not a primary goal.
So, I’m also interested in Volumio on Zero without installation problems.
What sound card you use on Zero, mrqs?

Got it working (audio out through HDMI ) under BerryBoot release for PiZERO (avail in gihub issues talks), after generating a squashFS image from std Volumio 1.55 img.
I got 2 separate “classical” error messages reported by several people here, but could not find any explanation/fix so far.

transientlog: Premission denied Error openning '/dev/input/event*': No such file or directory Startpar: service(s) returned failure: trancientlog ...cat: /run/player_wrk.pid:
As concerning as this may look, it did not prevent Volumio from working nicely.

I did try to install as standalone (no BerryBoot) with plain 1.55 image, changing the FAT partition firmware files with latest.
It sort of started but was not functional as USB-Ethernet adapter was not detected (though it worked fine on BerryBoot).
I did not spend too much time on it as my priority is to get it under BerryBoot.

BTW, would be nice if Volumio was released as Berryboot images too…

Had some success with the steps I found here: runeaudio.com/forum/the-new- … tml#p10969

Volumio comes up, but quickly falls over if I try and play music. Maybe because I’m using a HDMI -> VGA + 3.5mm converter for sound…

I thought about doing this, but I couldn’t get the economics to work. It seems that I would need some kind of an ethernet/wifi adapter and an analog audio adapter as well, which would push the total cost into the Pi1 B+ range. I’m currently working on getting Volumio to run on a CHIP computer ($9), which comes with wifi built in and an audio out jack. Granted, the audio quality won’t be spectacular, but I hope it will be good enough for normal background listening.

Pi zero is 5$. USB wifi is 3$, usb sound card is 2-4$, usb hub is 3$. Total 15$. I cant find anywhere Model B+ for that money.

I actually managed to get hold of a RPi Zero, and loved the teeny tiny form factor coupled with one of the plainDACs https://volumio.org/forum/plaindac-plaindsp-universal-i2s-dac-from-under-t3431.html. Multi-room audio here we go …oops, volumio doesn’t boot.

Now, as mentioned earlier on this thread, Moode works well, and a solution can be cobbled together for Runeaudio and possibly volumio, with access to an old RPi 1. Before everyone starts getting too carried away with the RPi 3s, can anyone offer a solution which doesn’t need access to a RPi 1? From the flashes of the LED, it appears that the RPi Zero doesn’t recognise the SDRAM and needs an updated bootcode.bin/start.elf firmware.

So i also got the PiZero and can confirm the latest Beta (Beta4) does not boot successfully. Not sure what the error message is because i do not have a monitor attached to my setup. I was hoping to use Volumio with my headless pi zero in combination with a otg RJ45 USB1.1 JP1081B ethernet adapter combined with an IQaudIO PI-Dac zero. The pi zero boots perfectly under Raspbian including ethernet/DAC functionality though.

Volumio 1.55 works fine on a RPi Zero after first booting up the card on an old RPi 1 and updating the firmware (rpi-update), but I haven’t tried the Volumio 2 beta by this route.

Anyone want to suggest an easy method of updating the firmware or at least the bootloader without involving a RPi 1?

Ian Sutherland

Ok bought myself a Pi B+ to try to get a working Pizero in combination with Volumio 1.55. No matter what i tried with Volumio 2.0 beta’s, i always got the 8times flashing green light on booting (headless Pizero).

What i did was the following to get Volumio 1.55 to work on the PiZero:

  1. Download default Volumio 1.55 img
  2. Flash it to 16GB SDHC card
  3. Boot it using Pi B+
  4. run apt-get -y update && apt-get -y upgrade && apt-get dist-upgrade && apt-get -y autoremove && apt-get -y autoclean (took almost 6 hours)
  5. run apt-get install binutils
  6. run rpi-update

After step 6 a new kernel is installed and the Pi Zero boots succesfully using the updates Volumio 1.55 image. I can not yet test if there’s any sound, i need to solder the GPIO pins to install the IQaudIO PiZero DAC. What i do see is that using the webinterface i am able so select all the webradio channels and start playing them using the RPI DAC output. Using top i see that MPD eats small amount of CPU resources and ALSAMixer also detects the soundcard. I tried to create an IMG file from the working image, here i did not succeed because i currently do not have a Linux machine which has an SD slot.

Note: dmesg gives me at least the following errors on both the Pi B+ and the Pi Zero:

[ 1.921923] vc-sm: Videocore shared memory driver [ 1.928527] [vc_sm_connected_init]: start [ 1.934999] vc_vchi_sm_init: failed to open VCHI service (-1) [ 1.940731] [vc_sm_connected_init]: failed to initialize shared memory service [ 1.951397] [vc_sm_connected_init]: end - returning -1

After some investigation it turns out harmless :question: :

Yes, that is expected. Most vchiq services on GPU are disabled when using cut down firmware (which you get with gpu_mem=16), so vc_sm is not supported. Perhaps the kernel log message should be silenced, but it is harmless.

Some additional info taken from the Pi Zero cmdline:

root@volumio:~# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA] Subdevices: 7/8 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 Subdevice #4: subdevice #4 Subdevice #5: subdevice #5 Subdevice #6: subdevice #6 Subdevice #7: subdevice #7 card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: sndrpirpidac [snd_rpi_rpi_dac], device 0: RPi-DAC HiFi pcm1794a-hifi-0 [] Subdevices: 1/1 Subdevice #0: subdevice #0

root@volumio:~# lsmod Module Size Used by nfsd 263655 2 sr9700 6002 0 dm9601 6941 0 snd_soc_rpi_dac 2737 0 snd_soc_bcm2708_i2s 7654 2 regmap_mmio 3556 1 snd_soc_bcm2708_i2s bcm2835_gpiomem 3703 0 snd_soc_pcm1794a 2101 1 bcm2835_rng 2207 0 snd_soc_core 167389 3 snd_soc_rpi_dac,snd_soc_pcm1794a,snd_soc_bcm2708_i2s snd_compress 8865 1 snd_soc_core snd_pcm_dmaengine 5794 1 snd_soc_core uio_pdrv_genirq 3526 0 uio 10078 1 uio_pdrv_genirq snd_bcm2835 22502 2 snd_pcm 92861 4 snd_bcm2835,snd_soc_core,snd_pcm_dmaengine snd_timer 22156 1 snd_pcm snd 67534 8 snd_bcm2835,snd_soc_core,snd_timer,snd_pcm,snd_compress fuse 86348 1 ipv6 358835 44

root@volumio:~# lsusb Bus 001 Device 002: ID 0fe6:9700 Kontron (Industrial Computer Source / ICS Advent) DM9601 Fast Ethernet Adapter Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

root@volumio:~# uname -a Linux volumio 4.1.20+ #865 Mon Mar 21 18:40:13 GMT 2016 armv6l GNU/Linux

root@volumio:~# df -h Filesystem Size Used Avail Use% Mounted on /dev/root 1.5G 1.2G 201M 86% / devtmpfs 238M 0 238M 0% /dev tmpfs 242M 0 242M 0% /dev/shm tmpfs 242M 5.1M 237M 3% /run tmpfs 5.0M 4.0K 5.0M 1% /run/lock tmpfs 242M 0 242M 0% /sys/fs/cgroup Ramdisk 256M 0 256M 0% /run/shm /dev/mmcblk0p1 75M 29M 46M 39% /boot tmpfs 49M 0 49M 0% /run/user/1001

root@volumio:~# free -h total used free shared buffers cached Mem: 482M 199M 283M 10M 13M 114M -/+ buffers/cache: 71M 411M Swap: 0B 0B 0B

root@volumio:~# tail /etc/debian_version 8.0

[code]root@volumio:~# cat /proc/cpuinfo
processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 2.85
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2708
Revision : 900092
Serial : 000000004bce55df[/code]

I soldered the headers tonight on the PiZero and managed to connect the PiZero DAC from AudioIQ to the PiZero. Upon testing there was no audio from the DAC running Volumio 1.55 so i was forced to RTFM :nerd: The following was mentioned:

[code]To remove the standard Raspberry PI audio card, comment out the broadcom sound driver (sndbcm2835)
from being loaded in /etc/modules
pi@raspberrypi ~ $ sudo nano /etc/modules

/etc/modules: kernel modules to load at boot time.

This file contains the names of kernel modules that should be loaded

at boot time, one per line. Lines beginning with “#” are ignored.


So i did and there was light or even better, Music :smiley:! At first the master volume control was not working within the webinterface of Volumio but it worked using AlsaMixer. Selecting the correct “I2S DAC” option using the webinterface of Volumio under the option “System” -> “I2S driver” being “AudioIQ DAC” instead of “AudioIQ DAC Plus” solved that glitch right away. Currently me=happy :laughing:

root@volumio:/var/log# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: IQaudIODAC [IQaudIODAC], device 0: IQaudIO DAC HiFi pcm512x-hifi-0 [] Subdevices: 0/1 Subdevice #0: subdevice #0

If you replace the boot files on the sdcard with these newer boot files -> github.com/raspberrypi/firmware … aster/boot than the pi zero will boot volumio.

Since the Raspberry Pi ZERO turned out to be a great platform for small audio solutions, i really hope that there will be a official VOLUMIO Distribution for the system.

Are there any plans for this in 2017 ??

I tried to burn the Volumio2 and -like described above- edit the boot section.
But this led to a very non stable boot up, Volumio get stuck randomly at startup and is not usable.

RPi0 works fine with the current version of Volumio, without any modifications.

Please edit the topic title to [SOLVED] if you are happy with the resolution.

on my original RPizero (non W) with PhatDAC soldered on, volumio 2 just hangs (for 12hours at least). Can anyone else confirm this combination work with Volumio 2?

I will answer my post, it DOES work with phatDac and RPi0, sounds very good.