Volumio on Rock64 install guide

Hi, I’m new to this forum and also to Linux etc. I would like to have a step by step guide on how to install Volumio on a Rock64 V3 sbc please.
Any help is much appreciated.



Is no longer supported, there is only an older version.

Instruction are on Volumio’s site:

Hi Wheaten,
thanks for your reply. I’ve tried that one but I cant get it to work. I tried using the Pine64 installer to flash the sd card with the image from that link but it doesnt seem to anything when I start it up. The red and white leds on the board stay on constantly, not sure if this means anything and I cant see the board connected to the network. I have installed Dietpi on the same card previously and its booted up no problem. Reformatted the card for the Volumio install and have tried both the Balena Etcher flash and as I said the Pine64 installer using the browse function. The Balena Etcher flashes the card but after verifying it says that the flash failed. Dont know where to go from here. Maybe something I’m doing wrong or missing some other step?

Unable to help. the Rock64 was a community porting. There is no support for it.

  1. Don’t use a pine64 image for a rock64 board, that can and will never work (different SoC, different hardware alltogether).
  2. Don’t use Balena Etcher, try another tool, e.g. Rufus.
  3. Not even sure whether a v3 board will run with the old Rock64 images, untested.
  4. There is no more support for Rock64, sorry.

Hi gkkpch,
thanks for your feedback. Your suggestion not to use Balena Etcher is good as I found it never flashed the SD card properly. I’ve been using the Pine64 installer program to flash the volumio image from a location on my desktop and it works for Dietpi but not Volumio. I’ll give Rufus a go and see if that works. When I received the Rock 64 board I did notice that a chip was missing and I checked with CS and they said it was the SPI chip and was no longer required on the V3, I was wondering if this is the reason why the image wont boot - the red and white leds stay on constantly. If this is the case, is there anything I can do to overcome it - eg modify config files or something (I’m not very familiar with Linux) or set jumpers or terminal into during the power on?


According to the Armbian forum, V3 needs the device tree updated because of highspeed SD support, the boot issues has no relation with missing SPI.
As I said, Rock64 is not supported anymore, so you are out of luck.
Unless you would boot from an emmc device, the same thread on Armbian does mention, that booting from emmc is OK.

Hi gkkpch,
Thanks for researching this as I have no idea where to start. I tried flashing using Rufus and it still wont boot - no activity on the red and white leds.
I noticed that when viewed in Win File Explorer after flashing I can see a number of folders and files on the SD card, whereas when I flashed with the other utilities, Windows wouldnt even recognise the card. Is this normal?
I used the default settings in Rufus to flash the card - is this ok?
I did purchase an emmc module from Pine at the time I ordered the Rock64. In view of your comment above re the device tree - is it worth trying using the emmc?

Kind Regards