Volumio on Odroid XU3

Hi all,

first of all i just want to thank the devs for all the awesome work done with Volumio 2 , its an amazing piece of software.

im only having one issue, i know the build was created for the Odroid XU4, which works great, im managed to get it to play through the HDMI but i have no volume control when i do this.

i have the same issue when i run Volumio 2 off the Odroid XU3 board, also no volume control, id also like the ability to output sound through the 3.5 jack on the Odroid XU3

iv tried running the command sudo amixer cset numid=3 1

but i get the below output

amixer: cannot find the given element from control default

also i can only get the sound to play through the HDMI if i setup pulse audio and edit the mpd.conf file as well as the default.pa file to stop the module from switching off

I did the odroid ports (C0/C1/C1+/C2) and the experimental X2/XU4 images.
The reason why XU4 (and your XU3) got left behind was lack of demand.
There is no way I can support this, other than very obvious issues for which a fairly simple rebuild/ re-compile can be done.
In your case I’m afraid you have to do with what you have, really sorry.
Will monitor the XU4 anyway, seems mainline support is as good as done.
Might try one at a later stage and look at your 3.5 jack issue, but no promise…

– Gé –