Volumio on a Freedom Box

Has anyone tried to install current volumio on a A20-OLinuXino-LIME2:


This is the board you get if you order the Freedombox `Pioneer Edition’ home server:


and it is a very nice little device indeed. I understand that the two OS’s cannot coexist on the same board, but would like to experiment with running volumio on this hardware.


There is no “current” Volumio version for any Olimex board.

Thank you. Yes, I knew that there was at present no version of volumio built to run on that board. I’ve read the Porting Guide in the volumio documentation (thank you for that) and was considering the project. Since armbian is the standard OS for the olimex board I was hoping it wouldn’t be too difficult, but thought it would make sense to ask if someone had already tried. It seems like nobody has.

You can actually use the Armbian built packages to produce the platform files, just unpack the .deb files and copy the image, the modules, dtb and uboot files. The rest is in the build scripts.
So with reading the porting guide you should be able to quickly build your own version.
Note: it won’t have myVolumio.

Thank you for these pointers! It sounds sort of doable as a pandemic project. It hadn’t occurred to me that it wouldn’t have MyVolumio, but of course that makes sense once you think about it for a second. In any case, I appreciate your advice.

just shout when you need help