Volumio Not Recognised in Logitech Media Server

Hi all.

Just installed Volumio and Squeezelite on my Pi3+ today.

However, after I’ve activated squeezelite plugin on Volumio, I still don’t see my Pi in LMS(installed on my Synology NAS).

In contrast, I have a Logitech Transporter and it has always been recognised by LMS no problem.

I tried installing Squeezelite-X on my PC and it is working fine as well.

So the only thing doesn’t get recognised in LMS is my Pi3+ running Volumio, with squeezelite installed.

I’ve tried restarting LMS, Restarting the NAS, doing a factory reset on my router…No luck.

Has anyone encountered the same issue before?

I thought it might be the port issue so I tried to switch LMS’s port around…9000,9001,9002…tried quite a few. Couldn’t see still. Anyone know what port Squeezelite on Volumio uses? And is it possible to manipulate the port?

I ran into this same issue, exactly as you describe it.

For me, I was using a RasPi 3b+ with latest volumio installed directly on the disk.
My desired output was through the 1/8" audio jack, using the native squeezelite plugin.

After brute forcing the settings, I was finally able to get it working by changing the following:

Settings>Plugins>Installed Plugins>Squeezelite Player>Settings>Configure Audio Output Settings>Output Device:
Changed the option to:
[(default) bcm2835 ALSA] Default Audio Device
^ Note: this is the second option from the top on my RasPi.

Once I saved, and possibly restarted the Pi, it showed up in my LMS docker container.
For reference, these are the ports I am using. Since I also played with changing the ports, I am not positive these are the defaults. But they certainly work for me:

I have searched everywhere for this, even posting in the Gitter chat, without success.
So if this helps you or someone else out, outstanding. It was worth registering for.

I had high hopes after trying your suggestions and it worked the first time, but after changing the name from Volumio to a more descriptive name (have multiple instances and need to be able to differentiate) LMS is no longer finding them. I tried many restarts of the containers (unraid), the pi(s), and still no players show up. I’m hoping I can get this working and replace my Roon setup (mostly for cost, Roon is quite a lovely service but pricey).