Volumio not displaying all albums

Hi All,

I’m fairly new here, I’ve recently started using my RPi3b again for my music collection. However, I’ve been trying to troubleshoot why some folders are not showing up. mpd.log shows that the folders have been updated, but they do not show up in the Albums view. But they do show up in the Music Library view if you drill down into it. For instance, I can go to “Music Library → NAS → HDTracks → The B52 s → Cosmic Thing [192kHz - 24 bit]” and I see the files and can play it fine, but the album view doesn’t see it. This is true for a few albums.

any ideas?

A problem we had in previous versions was zero sized files or files with zero length

I used MP3Tag to sort by time and delete all zero time files, then rescanned my library

It’s also worth using MP3Tag to check you actually have tags for the software to see

Hope this helps this time

Interesting… would this be true for any zero sized files or zero length files in the folders, not just audio files?


Can’t remember to be honest, I only have audio files and the cover pic in my directories, but I think it was just the audio files

so it seem to be an issue with some AIFF files. While re-creating the database, I tailed the mpd.log file, and the ones that mod could not process it just scrolled by, as opposed to the aiff files it could process, you could easily tell it was doing something. Is there a way to turn on verbose logging?

so I did a bit more testing.
at first I thought it was the tag version, so I converted the from v.2.4 to 2.3, rescanned, no results
reverted back to 2.4, converted the aiff file to flac and that worked.
I thought I would be happy with that, but it bothered me that the aiff didn’t work.
so I “converted” the aiff to aiff, and that worked.
digging a bit more, it was the aiff files I got from HDTracks that volumio couldn’t read. Files from Qobuz were fine, as well as CDs that ripped to aiff.

so I guess that’s something :-/

1 Like

Don’t you just love it when you find a “standard” isn’t standard :slight_smile:

Glad you sorted it in the end though