Volumio no longer seeing USB drive following update to latest version


Hope you can help. A couple of days ago I updated Volumio on my RPi 4 to the latest version. Of course that may be entirely coincidental, but prior to that I was perfectly able to access a collection of FLACs on a USB drive attached to the Pi. The 2TB drive is partitioned and formatted as ext4 via Ubuntu. Since the update however Volumio will not let me browse to it in Music Library (the screen is blank). I can manually mount the drive to the Pi and see that the files are all there through the terminal. I’ve re-flashed Volumio and the situation didn’t change. There are no reported errors on the drive.

I’ve searched the forum, but can find no solutions.

I’m puzzled. Any ideas what’s going on here?


please, send your logs : Sending logs for troubleshooting - Volumio Documentation

Done: http://logs.volumio.org/volumio/ybhKIiA.html

I see an error on your HD

May 13 16:09:01 flamingpi volumio[823]: mount: /media/Rita: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.
May 13 16:09:01 flamingpi volumio[823]: error: Failed to mount Rita: Error: Command failed: /usr/bin/sudo /bin/mount "/dev/sda1" "/mnt/USB/Rita" -o noatime,iocharset=utf8
May 13 16:09:01 flamingpi volumio[823]: mount: /media/Rita: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.

It could be the reason…

Could be… Thanks for looking at this.

I was thinking there was probably some error with the drive, but I get no errors reported when I check it in Ubuntu. Earlier I did reformat it and copy over the files again, but that (clearly) has made no difference. What fs type should I be using - previously it has been fine with ext3/ext4. I’m not a Linux wiz so I’m struggling here…

fdisk on the Pi reports:

Disk /dev/sda: 1.8 TiB, 2000365289472 bytes, 3906963456 sectors
Disk model: Elements 25A2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: FEB920E7-B791-4D73-94BD-2187BF7B4559

Device Start End Sectors Size Type
/dev/sda1 2048 3906961407 3906959360 1.8T Linux filesystem

As I say - I can mount the drive manually onto the Pi and all seems fine - it’s just that Volumio doesn’t seem to want to play ball.

Does this give any clues as to what I might do to fix things? Thanks again for your help.

Or maybe it this - there is a bug in 3.251

Ah - sounds promising. I’m offered 3.283 which is says is a test version, “do not install” - should I press on regardless :slight_smile:


Don’t! It may result in a non fonctionnal system.

OK - thanks. I’ll wait for next stable release and see if that fixes things - sounds like it might.

Thanks again to you both for taking the time to look at this.


So,I have the latest Volumio release installed and this is still a problem :frowning:

I tried the drive on a Moode installation and that worked OK. Ubuntu does not report any errors with the drive (it’s relatively new), formatted as ext4. All been OK on earlier releases.

I’ve sent a log file through:


Any help would be appreciated - I’ve run out of ideas.