Volumio new v2 ssh login

Tried login via ssh

But doesn’t work for me either.
What is the new ssh login/pwd?

volumio.github.io/docs/User_Man … Guide.html

for SSH, password volumio2 doesn’t work (2.175 version) (on raspberry pi 3)


but if you can’t access SSH do this:
Go to system -> delete user data

I just tried that (delete user data)


what is the new host identification ? (and password)

It’s just that Volumio regenerated its ssh key after “delete user data” (which means delete anything user modified within the system, not just Volumio settings; it’s mostly a reformat).
Your SSH client warns you about that change; nothing to worry about.

Thanks macmpi for you response

but in fact, Volumio respond :

Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /Users/yannickmahe/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /Users/yannickmahe/.ssh/known_hosts:1
ECDSA host key for volumio.local has changed and you have requested strict checking.
Host key verification failed.”

I don’t understand all that,

“Host key verification failed”

Your Mac remembers machines info it ssh with as known_hosts.
If one of these known hosts change its identification (like Volumio after creating new ssh keys), macOS warns you and prevent logging in (paranoid setup).

Workaround is somehow explained within the error message: delete older Volumio entry into /Users/yannickmahe/.ssh/known_hosts, or remove that file altogether.

There are other more subtle solutions you may find if you Google that matter.
Not Volumio related anyway, this is a macOS setup matter.

Thanks (again) to you.

I would never have guessed it all

And this made me take a step forward.

But I am again in the original position :
can’t find the “good” login/psw couple…

volumio:volumio for user:pass ssh login; no change.

But ssh is not a necessity to use Volumio: it’s only for tinkering if need be.
Normal operations & settings are to be managed through web UI.

volumio (or volumio.local or seems OK for user

but I do not find any password that works.

that said, my Volumio2 + Raspberry combo works…

I use it via itunes + Airplay on my MBP.

But I want to try to mount a local harddrive (on MBP) as a NAS, and try to listen to some HD files (perhaps with minimserver ?).
In fact, as I’m really not a linux specialist, I’m not sure how to do it.

OK, so you do not need to get into command lines under ssh for this.
Please read the manual (see signature), and work through Volumio WebUI: many things should be self explanatory.

I understood that (I think)

“Please read the manual (see signature), and work through Volumio WebUI: many things should be self explanatory.”

I had read it already, and tried many things, but no way to mount my iTunes folder.

For the moment, to stream hi-res files, I had to install minimserver, BubbleUPnP server, and Linn Kinsky player.
and for Qobuz, same servers and Linn Kazoo player (I can stream Qobuz with Kazoo, but no local files, strange).
And to play itunes 16/44 files, airplay works like a charm.

For hi-res, I would prefer to mount my iTunes folder (on USB external harddrive on my MBP) on Volumio, but I didn’t find the way to do that.

For Qobuz, I think that it is necessary to find “the good plugin”.

Is you external USB HD formated for macOS (HFS+)?
Volumio will mount FAT partitions for sure, but I have not checked with other formats.
Once mounted content is scanned and shows-up in Browse/Music Library, and in Settings/My Music

Qobuz plugin is in the work I think: no idea how functional it is yet.

Hello macmpi

yes my external drive is formatted for macOS (OSX actually).
I really do not want to change that !

Perhaps this is the problem, but I know that is is possible to mount a macos volume under Raspbian (with a driver).
And again, I need to ssh volumio. And ssh does not work with any login:password I tried (strange).

Perhaps these 2 problems are linked…

About Volumio, some time ago, Michelangelo wrote somewhere that the plugin is already written, and he just waits for a “key” from Qobuz.

Perhaps I’ll try piCorePlayer, or OSMC/KODI, for which a plugin is available (but not for hi-res, I understood)…

On your Mac, from Terminal app (or iTerm), type: ssh volumio@volumio.local and then reply volumio as password.
Is that what you are doing?

A work-around solution would be to do file sharing from your Mac, and mount the share from Volumio My Music panel.
I’m not sure Volumio mounts AFP, but for sure NFS & SMB work. (NFS probably more efficient, but a bit more tricky to set under macOS).

Is there any reason that the appropriate drivers for HFS+ can’t be installed in Volumio? I don’t have any Mac media to test …

Dunno, never tried, though I’m definitely a Mac user; should not be big change I guess. Will check when I have some time, unless others do it first.
@yannig27 you may want to enter an issue in Volumio github, so that this specific part does not go forgotten.

Don’t know why, but SSH works since yesterday.
I have not changed anything in Volumio, nevertheless.

@macmpi About hfs+ mounting problem via my macbookpro, I’m still not sure if this is a Volumio bug.
Since SSH now works, I’ll look further.

And right now, I’m using the Raspberry with a local hfs+ drive. Works like a charm (except I’d like a search by composer tag).
I can even mount this drive via network on my macbookpro (but I can’t write on it, seems like all drivers are not implemented in Volumio).