volumio+john kenny ciunas dac

I’m here for the first time
I’m going to install volumio on a UDOO quad (when I’ll find one)
the question is: my DAC is a John Kenny ciunas dac, (based on amanero combo), are there known problems with this configurations? There’s something I need to know before create my configuration?
This dac is very good but not so famous, mr Kenny is a very nice and collaborative person, and I really hope to be able to listen to his dac on your sistem.
Thanks for your answers

Hi Leo,
I don’t really know if the Amanero Combo works with Volumio. If it is the same than the amanero, we got feedbacks that it works:

The only problem is that you probably can’t have hardware volume, but that could be a configuration problem and could be eventually solved.
Let me know!

thank you

I have this combination successfully working - it took a while, but once I got it working it’s fantastic. As the previous post mentioned, the “hardware” volume control doesn’t work with the Amanero USB transport the Ciunas uses, so you’ll have to control your volume at the pre-amp/amp/receiver that you’re using to play the audio from the Ciunas. (Or use the lower quality software mixer.)

However - it required a downgrade to the firmware to get it to work with ALSA and volumio (or any other linux-based music distro that uses ALSA).

If you’ve purchased the DAC recently it may have a newer firmware that doesn’t play well with ALSA. To get it to work with Volumio, you’ll need to run through a procedure to downgrade the firmware. If you haven’t purchased it yet - definitely let John know about this before you buy it and I am sure he can send you one with the correct firmware you need.

If you’re not getting reliable audio out of this DAC using Volumio, check with John Kenny and ask about the firmware needed to run on Linux. I just went through this with him recently (July 2014) and he should be familiar with the issue and what to do to solve it.

If it works fine “out of the box” then you don’t have the issue, enjoy!

hi bdouble
thanks for your suggestions
I bought the ciunas this january, so I think it has the new firmware
but I’m very scared to work with the firmware, I don’t want to broke something
I sent an email to John about 10 days ago, in his answer he didn’t mentioned firmware problems
may you explain me the way you solved the problem (in very simple, simple terms!)?
I’ll buy an UDOO quad at the end of august (now it’s impossible) so I have time to learn
any other suggestion about the ciunas in general?
thanks a lot

Hey there -

Unfortunately, the firmware update isn’t what I would call “super easy” on the Ciunas.

It involves opening up the DAC so you can access the circuit boards directly. John Kenny can provide instructions with pictures to guide you, but what you have to do to get the DAC prepared to accept the firmware update via USB is to temporarily touch an unconnected wire to a specific place on the circuit board for a few seconds. This electrical “short” tells the Amanero board that it should accept a firmware update using the Amanero OEM tools.

It’s not really that hard, the pictures are clear and the process is easy to follow. But, you do need a PC to run the Amanero OEM tool, and you do need to be comfortable opening up the device.

If you don’t feel comfortable with that, perhaps you could return the DAC to John and he would send it back to you with the firmware update applied? I don’t want to speak for him, but he’s been really nice to work with and helped me a lot - I imagine if you contacted him and told him the situation, he would help you too.

I can tell you that this DAC sounds really fantastic with Volumio, and it’s worth the hassle!

I think it’s too complicate for me
anyway it’s only a problem of volume isn’t it? It doesn’t degrade the sound quality, it’s true?
I can use the volume of my ampli :confused:
but… John told me the ciunas doesn’t need any driver to works on every linux based on UAC2 compliant kernel, maybe I can use volumio without alsa drivers?
Or…maybe someone can solve this problem with a little patch (Michelangelo can you hear me? :unamused: )
I really hope this little problem will be ininfluent on the sound quality of the system, I don’t really care about the volume.
thank you again bdouble

I’m really hopeless with Linux

The issue with the firmware on the Ciunas is not related to the ability to use hardware volume control. You cannot do that with the Ciunas, period. You can set the playback control to “hardware,” if you like, but the Ciunas will ignore it and the volume controls in Volumio won’t work. Best to set this to “disabled.” If you really need the volume control, you can set this to “software” but be aware that you’re taking a sound quality hit when you do that.

If you have the wrong firmware with the Ciunas, the device will not work at all with Volumio (or any other Linux system). The system will appear to be functioning, but you won’t get any audio out of the DAC. I tried a lot of stuff to get this to work, and it simply doesn’t - the only way to fix this is to use a different firmware.

So the question is really - does your DAC work at all? If so, you have nothing to worry about - enjoy the tunes! If it doesn’t work, you’ll need to use different firmware on the Ciunas.

If you’re not comfortable with doing the firmware update yourself, perhaps you might want to ask John Kenny if he could exchange your unit for one with the correct firmware?

if the ciunas doesn’t work with volumio I’ll try something else (cmp2, daphile, runeaudio) 'till a new version of volumio will solve the problem…
I’ll wait
I won’t risk to send back my ciunas, it’s too far from Ireland (I live in Monteforte Irpino, the far end of Empire), I had a lot of problem when I received it (20 days of waiting, the devices arrived not warking…), I don’t want to buy an UDOO quad for nothing
thank you again bduoble
Amanero is a good device, I hope first or later the problem will be solved in a new volumio version

The problem is not with Volumio, the problem is with an update to the Amanero firmware - an update that made it incompatible with ALSA.

It’s might be possible to get Volumio to work with something else like PulseAudio, instead of ALSA, but - this will likely require some advanced Linux skills to get running. It’s not going to be for your average end user…

I purchased my Ciunas in March - perhaps the version you have, purchased earlier, has the older firmware that works just fine with ALSA.

In any case, you can tell right away - with the older firmware, the Ciunas works great “out of the box” with a stock Volumio installation. With the newer firmware, the DAC will not output audio.

John told me he’d be speaking with the Amanero designer, to discuss the firmware issue on Linux. Perhaps there will be a new Amanero firmware that fixes the issue in the future. But, as the update process on the Ciunas involves opening the device up, I will probably just keep the version I have which works just fine.

today I proved daphile, and everything was ok
it works with alsa drivers isn’t it?
so maybe volumio could be ok with my ciunas
anyway, I can only try

what means “out of the box”?

What I mean by “out of the box” is that if you have the right firmware on the Ciunas, it will just work with Volumio. No special configuration necessary.

If you have the wrong firmware, it won’t work, at all.

Sounds like you have it working, so no need to worry!

thank you bdouble for all your suggestions
I’ll go away for some days
in september I’ll try to find an UDOO quad to put volumio on
I’ll let you know