Volumio for Raspberry Pi 1.3Beta (25/04/2014) Feedback

I noticed that Michelangelo had updated the 1.3beta version on the 25th April. I was hoping he’d updated MPD to 0.18.10, and he had!

This version seems to be working fine for me, but I do have a question about the I2S settings.

I have a ES9023 I2S DAC, and I’m sure I had the driver setting on “Generic” before, but for this version, that didn’t work. I tried the “Hifiberry” driver and this works fine. Is there any difference between the I2S drivers or is the labelling just for easy set-up?

Where can I find 1.3 for RaspPi for download?



sourceforge.net/projects/volumio … erry%20PI/


Many thanks!

Oh Great ! Thanks Michelangelo

Except MPD what are the other things updated in this version 1.3b version ?
is there a change log available somewhere ?

Thanks, Michelangelo. The wifi dongle issues seem solved. It will now turn on the Tenda dongle on boot up and connect. And there seems to be an improvement in sound quality to my ears.

Please incorporate LIRC sometime soon so birca’s1987’s IR remote can be easily added. Not sure I like having to do the update before getting lirc. I wonder if that update changes or adds some extra, unwanted baggage to Volumio?

Hello, the point of Derek is good :
Does apt-get update
Then apt-get install LIRC, Python stuff is going to install unwanted thing ?

I personally install python for driving a lcd connected to the pi. So far so good. Not tested with 1.3 beta


Is the Wolfson Sound Card support in this version?

1.3 runs very stable for about 48h now but there are still some (minor) pops/clicks when playing flac files.
i had to restart mpd 0 times so far. :smiley:

one thing i dislike: i have to turn off the new “consume mode” after every restart in the webUI. it does not remember the last selection.

Can you share your setup (dac …)

this raspyfi.com/building-my-reference-dac/

same as mine :slight_smile:
did you power the usb-i2s interface with a independent linear power supply ?

By the way, did you try to plug the DAC directly on is2 on the Pi ? (I’m considering trying that)

Unfortunately the UPNP integration doesn’t work. At least with my Synology DS213j NAS.

I can mount the NAS without problems and access it’s folders as in 1.2beta. But when I start the MPD DB update it stucks in the update process. The tab description stays on “updating”. Both UPNP servers on my network (a DVB-S set top box and the UPNP/DLNA server running under DSM on the Synology) are found. But when browsing through the library by the volumio web UI it shows only a single entry for the Synology. Even after some hours of waiting (I’ve only a small music collection uploaded to the Synology so far). I’ve no problem conneting to the Synology with foobar2000 on a windows PC.

So, I connectetd to the Raspberry by SSH and checked /mnt/upnp/ds213j manually: Everything is there. By artist, by title, by album …

Do I have to change configuration of the Synology or volumio?



Yes, +1 for recompiling with Consume=Off. In the meantime, as a dirty fix, add mpc consume off
to the /etc/rc.local file.

Raspberry PI plus HiFiBerry Dac. wired network.

When adding a NAS volume to a library, the web gui tells me that it is updating the libary. However, other than seeing a UPNP link to the NAS (with no content, I don’t see the mount or files at all (under 1.2 I could see files pretty much straight away). I can see a mount point (/mnt/NAS/George [the name I gave it] is there but I can also see /mnt/NAS/Flac which I didn’t create). The NAS is Netgear and is set to CIFS mode.

mount tells me

// on /mnt/NAS/George type cifs (rw,relatime,vers=1.0,sec=ntlm,cache=strict,uid=0,noforceuid,gid=0,noforcegid,addr=,unix,posixpaths,serverino,acl,rsize=8048,wsize=8096,actimeo=1)

That’s the same behavior I discovered and described above. At least I could connect to the NAS by temporarily disabling the UPNP/DLNA server on my Synology. Then I got the NAS displayed in the volumo library as with 1.2beta. Afterwards I reactivated the UPNP server on the NAS.
But don’t try a new update on the MPD DB in volumio…



Hum. Sounds like the 1.3 version is causing problem while mounting NAS shares …
Guys, why are you bothering with UPNP ? does a mount with NFS or Samba is not good enough ?

In my case, UPNP (DNLA ) switched on by default and I’ve never bothered turning it off. I have two DNLA devices (One Netgear the other is Western Digital). The netgear is my main NAS, the other something that I’ve never got round to sorting out properly (i.e. transferring the files to the main nas/ using it as a backup device).

I’ve now turned of DNLA on the NetGear Nas, Now I can actually see the files on the other DNLA device (which just didn’t show up before) but I still can’t see the files which should be on my mounted drive.

PS playing with RaspberryPi/Volumio/HiFiBerry Dac and getting some nice sounds.

This did the trick - I had to turn off all DNLA/PnP source on the network and update MPD database before volumio showed files through the web interface.

I checked the mount point and that showed the files just fine.

PS tried playing through UPNP source and it wasn’t at all a good experience - music just stopped and started. Lesson learned I think - turn off DNLA servers.

I installed 1.3 beta, everything seems OK, except for one thing. On 1.2, I installed python-dev and python-rpi.gpio in order to use a H/W push button. Whe I do this in 1.3 I get:

apt-get install python-dev

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-dev : Depends: python (= 2.7.3-4+deb7u1) but 2.7.5-5 is to be installed
Depends: python2.7-dev (>= 2.7.3-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

apt-get install python-rpi.gpio

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package python-rpi.gpio
E: Couldn’t find any package by regex ‘python-rpi.gpio’

python --version

Python 2.7.6

Any clues what is going wrong here?