Volumio for Odroid C1 - Feedback Thread

Let’s welcome the Odroid C1!

Post here your experience with Volumio on C1, suggestions, feedbacks …

Enjoy your music!

A question about odroid -c1 : on their website http://www.hardkernel.com/main/products/prdt_info.php?g_code=G141578608433&tab_idx=3, it is written in the audio section :

So would it mean that only usb dac are usable ? Or what is the solution ?

On their website they add:

Source: com.odroid.com/sigong/blog/blog_list.php

So it means that next version will be available with i2s output option as well…

Still painful indexing…, taking many time to scan my 32GB sdcard. For your reference, Rune audio is almost ready to play once plug.

Hope 2.00 will be better.

Hi, I don’t quite get your problem, indexing is done by mpd and not by Volumio or RuneAudio.
Why not get an odroid emmc card to store your music if you want more speed?

Hi Ge

This is my real feedback to make Volumio better. Keep calm please.

I am calm and there is nothing wrong with giving feedback. I was only trying to say, that there cannot be such a big difference between the two, because they do not do the indexing, mpd does and is the same for both.
The remark on emmc was well meant, from my experience it does make quite a difference.

I’m sure Gè’s intention were good, but in forum being misunderstood is always easy.
Anyway, to get to your point:
it’s interesting that there is so much difference, on SD Card. I would say that this relies in how the SD Card is mounted (in Volumio is in a way that prevents corrutpion, and this makes it a little slower). Also it could be due to libmpg, which was quite buggy when mpd was compiled. New versions should solve the problem. I’ll look into that.
And in Volumio2 we’ll have a db management completely redesigned. Which is super fast: ning-yu stated it takes 50 seconds for 100k tracks…

Just installed Volumio ODroid C1 release to a 16GB Sandisk MicroSD card, it boots, but for some reason doesn’t get a DHCP address from my router. The same ODroid works fine with OpenElec and Android. I’m using a hardwired ethernet connection.

Editing /etc/network/interfaces to confiure a static IP has worked fine, and I’m now able to log in to Volumio via a web browser. I’m in the UK using a standard BT Homehub 5 ADSL/VDSL router.

I then couldn’t play music from Spotify - the Spotify option would load my playlists, but then when I tried to play, nothing happened and the Spotify option disappeared. Doesn’t feel as polished as the Pi version yet.

Thanks for the feedback… Could you provide more information about the spotify issue? I mean the exact steps you take which lead to the crash…

Today Hardkernel published a picture of the HiFi DAC shield with detailed information.

Odroid c1+ is out now.

Will the firmware for c1 work with the new board?

Yep, it will work. We are however working to release a new version soon with some optimizations for the HiFi DAC

Cool! Thanks[emoji106]

Sent from my iPhone using Tapatalk

Cool. I look forward to it. :smiley:

I just got Odroid C1+ & Hardkernel HiFi DAC today and install the latest build 1.55 for it. I and got a problem: no playback.
I tried mpc in console and get an error:

root@volumio:/tmp# mpc play NAS/Gorky Park - The Best/Gorky Park - The Best.flac [paused] #1/1 0:00/79:08 (0%) volume: n/a repeat: off random: off single: off consume: off ERROR: Failed to open audio output
In the Volumio settings the Audio Output is AMLM8AUDIO and no other options. is it any way to fix it?

The released 1.55 image only supports the C1, this why the DAC does not show up yet.
The image is currently being updated to support the C1+ and should be available shortly.

any update or eta? really looking forward to this and not sure whether to be patient or fork a repo and get to work :smiley:

Image is here: volumio.org/volumio-and-the-new … fi-shield/ 2 Reboots was requered, but now it works fine!

Thanks a lot!