Volumio Debian Bullseye Alpha - Raspi images

With Bullseye releasing soon released, I wanted to test how easy it would be to jump releases with the new modular Build System I worked on for Stretch Buster.

So here are completely unsupported alpha images, with only the open source parts, aka vanilla Volumio.

-Kernel: Linux 5.10.78
-Node v16.13.0
-armv7 – no pi0 support.

2021-08-18, version 0.022
-Kernel: Linux 5.10.52-v7l+ (1:1.20210805-1)
-Node v16.6.2
-armv7 – no pi0 support.

2021-07-29, version 0.021
-Kernel: Linux 5.10.52-v7l+
-mpd: 0.22.6
-Node: v14.17.2
-GLIBC: 2.31-12
-gcc: 10.2.1
-Python: 3.9.2

Known issues
All current Volumio bugs
No MyVolumio
upnp is diabled
winbind is diabled
Volumio’s hard coded paths will probably trigger issue with Debian’s merged /usr directories
Boot welcome QR is finicky
Certain plugins will fail, and modules will need recompilation


–This is just a fun test, please do not trouble the core devs with bug reports from this image!
–All currently known Volumio (core, UI, API) bugs will still be present, I didn’t change anything there.
—There might be even stranger bugs given how fresh bullseye is.

FWIF: Bullseye/sid has been my daily driver for some time now, but I have been using only with streaming sources (Spotify Connect, Webradio, RP, etc).
So caveat emptor - your mileage might vary.

1 Like

Let’s try

hahaha, you could have mentioned that the plugins are already listed.

  • Spotify => working

  • MPD_OLED => working

  • Contemporary-optimizations-for-small-or-large-landscape-displays => Working

  • Webradio (also custom radio’s from Juke.nl) working

  • USB disk won’t mount => Not working


  • Qobuz => Not working.


  • Same irrational behavior with mounts as Buster.
    Music Libarry => Sometimes the list is populated, often not (Internal NAS USB)
  • Running this version on the same setup as Buster, USB is discovered, but it won’t mount.
  • When not used for approx. 30 minutes, no audio. needs a reboot to operate again.


  • Player controls seems more responsive
  • Fast skipping back and forward in a track without issues
  • Fast skipping back and forward between tracks without issues

Thanks for this info , if would also qobuz would work I would install it. Great that mpd oled and contemporary is working.
Do tou see any improvement than on buster? Speed etc…


this comes that al the stuff of myvolumio isn’t there yet i had that with the 3.10 too.
a mutch smoother experience ( this will be gone after implementing MyVolumio )

1 Like

That’s strange, is this from local USB playback? Or also streaming stuff?

Local USB isn’t working.
I see that the disk is recognized, however Volumio fails to mount it, (Using the same hardware as with Buster, Buster mounts it)
So Only could stream from spotify. After approx. 30 minutes disconnected the headphone, and 5 minutes later reconnected it. Volumio indicated it’s playing but complete silence. Even after running through de playback options, “volumio vrestart” still no audio.
After reboot audio came back.

Also the Music Library random shows “Internal NAS USB”. When USB is shown sometimes the content is empty. also no mounting in /media/…

i have a simulair exp. with yt on 3.0.74 plays 10 songs and some songs went silent after 1 he could not play
so this could be a volumio issue … in the latest updates there are some bad bugs.
for me i reboot or start one of the other plugins and switch back the 11th song fail multiple times

runned a new test now it plays normal… if it’s buggy is it stays but after a reboot it’s gone again

That doesn’t sound good :expressionless: Can you send me a log via PM? I will find some music to put on a USB stick and take a look over the weekend as well.

Interesting - Spotify uses spop, so if there is an issue with the song queue in Volumio, volumio vrestart should normally help. Unless it doesn’t stop and restart spop correctly. Then again, it could also just be an issue with spop :thinking:

I haven’t run into any stability issues, but running mainly Spotify Connect, Radio paradise, webradio.

$ uptime
14:20:29 up 36 days, 23:48,  0 users,  load average: 0.12, 0.11, 0.05

If you have this still running and come across this again, could you grab a log before rebooting the system?

Either way, please don’t spend too much effort on this – it was a just a fun exercise during some procrastination! The focus should be getting bug free Buster first.

1 Like

Added a new build, this uses all upstream stuff, so apt upgrade should keep your packages updated as things are fixed. But yeah, all current Volumio bugs are still going to be there :slightly_frowning_face:

If someone wants to build their own images – branch is at ashthespy/VolumioOS/tree/bullseye

Hi. Thanks for the image. Flashed and set up. Can connect to airplay but no sound coming through it.

I hope you realise this image was a highly unstable test image, and isn’t meant for everyone…

That being said, you will have to look at your logs for answers, I don’t know anything of the top of my head…

Mate, i am just sharing my experience. Not asking for you to solve the problem as i know it is not even a beta. I am not a linux expert thusbi wouldn’t even know or ask how to check the log and solve the problem.

Thanks anyway for your effort to build it.

1 Like

Perhaps my tone was a bit harsh - I just wanted to say that without logs there isn’t much use of these tests…

1 Like

Any new images to try?

Not really the core OS distribution I just keep updated using apt, and it serves my purpose just fine :slight_smile:

~$ uptime
 11:03:50 up 122 days,  1:59,  1 user,  load average: 0.00, 0.00, 0.00

Also these are some of the last “community” images that works OTB with the plugin store, as you can’t access the new myVolumio store with non Volumio server sanctioned images…

So tl;dr - no new (public) images from my side, gotta wait for the core devs to release Bullseye…

Any update on a supported ‘release’ image of bullseye for 64bit RasPI?

@ashthespy, I just stumbled across this and it would solve a huge issue I’m having trying to get Volumio and Home Assistant Satellite working on the same RPi. However it looks like your repo of the build scripts is gone, or hidden. Any chance you would be able/willing to share the build scripts again for getting a Bullseye or Bookworm image working? It would be hugely appreciated.

None from my side…

I deleted that tree, sorry - I unfortunately cannot publish my bookworm images as well, as they are running on custom forks to work without myVolumio…

Given the lack of the new UI + plugin store without myVolumio, it doesn’t make much sense to publish new “community” images…

No worries. After some trial and error I’ve been able to fork and update the main repository to get a working Bullseye build. In my use case I don’t care about the myVolumio pieces at this point, I just need a newer version of Python to start working on a Home Assistant Satellite plugin. After doing a ton of digging around to get a media player device that supports Pandora, and works well with Home Assistant integration, Volumio was the best I found. However I’m trying to incorporate the Home Assistant Agent, and buster is just too old to run those pieces.

Ideally I’ll just use my forked version until the main Volumio codebase is upgraded to Bullseye or Bookworm, hopefully soonish.

If anyone is interested in what I’ve done, all code will eventually be up at GitHub - Raetha. Though I promise near zero support for it.

1 Like