Volumio crashes when updating DB - Cubox-i


I recently received my cubox-i2 ultra (nice little machine!), and tried the fresh volumio for cubox-i.

Install, ok
First boot, ok
Mount NAS nfs share, Ok
Update DB, never went through:

  • Web UI not responsive any longer --> shows the arrows turning, and saying reconnecting
  • No possibility to ssh any longer.

second try:
After reboot, ssh to volumio and updated via command line. After couple of minutes, I got that message:

root@volumio:~# Write failed: Broken pipe

Before I lost connection, I could see that the content of the NAS was being scanned though by using:

tail /var/log/mpd/mpd.log  

After connection is lost, cubox does not answer ping and I cannot reconnect “Host is down”
Also tried to update webUI as per volumio-ui-update-install-script-t633.html
Same situation… :confused:

It is a pitty, now that I had a glimpse about volumio, I really wish to be able to use it! :slight_smile:
Any ideas where to start looking?

Thanks for your help!

Thanks for reporting! Strange… that works like a charm for me… Could you please try to reflash your SD and report back?

Hi Michelangelo

Thanks for your reply.
Should have given more information maybe in my previous post, my bad:
The issues I report have been noted on the second install of Volumio already.
I did face the same issues with the first try.
I will, anyway, retry to flash the sd card later today (currently not at home) and report back.


FYI, few other things I also noted:

  • My music collection contains a lot of ALAC files, which, from what I read may be problematic with the version of mpd included in volumio (0.17.4 IIRC). There is a ffmpeg related message when ALAC files are scanned (I ll edit the post and give details later) when creating the DB.

  • As I do not intend to use smb shares, I tried to remove cifs-uils, as recommended on another thread in this forum.
    I got the reply that cifs-uils could not be removed, because it was not installed.

Well, some updates…not so good. :frowning:

I Re flashed volumio and remounted (apparently successfully, from UI) my NAS nfs share, but I still have the same issue with mpd DB update. At some point, it gets stuck.

Looking at /var/log/mpd/mpd.log, this is what I find just when I start updating:

Feb 20 23:55 : mixer: Failed to read mixer for ‘Output’: no such mixer control:

From the UI, mixer is set to “hardware” and the output is “imxspdif”.
When updating DB, I have the following message in mpd.log before each and every single ALAC file being scanned:

ffmpeg/mov,mp4,m4a,3gp,3g2,mj2: max_analyze_duration reached

So far, I have noticed the crash does not occur at the same file.

Any idea welcome!

Further testing:

Tried to plug in a USB hard drive (FAT) with some sample files on it, but it does not mount.
The DB always remains empty.
How can I mount the HDD?

Still no luck creating mpd db from nfs NAS share.
I still have the same issues.
On one attempt (and only one, so far), the mpd process just disappeared from the top command. Gone!
then, no more answer from volumio.

Regarding the ffmpeg message from mpd.log, i reported earlier, I checked what ffmpeg was installed.
The command

which ffmpeg

did not return anything. I tried

ffmpeg --help

no return either… It seems ffmpeg is just not there, but it is listed as an input in /etc/mpd.conf
Is that normal?

I may be asking myself too many questions trying to isolate the issue…
Any help is welcome!


This is the exact same problem I have on my CuBox model DB-300-P. I believe it has to do with file permissions.

I have the same problem!
During the update everytingh is frozen. Besides in audio output I have only Spdif and Hdmi (I can’t hear anything with my USB Dac - Teac Ud-H01)


I have CuBOX-I2 ultra and CuBOX-I4 Pro,
Both of them have the same problem…
I think it’s a problem of this Volumio version?
when can guys fix it?

Hi everyone,

I am wondering if anyone has succeeded in mounting a HDD, by any means of any connection–USB or NAS–, and creating a DB on a Cubox-i. If so, could you take a moment to describe the process you went through that worked? No detail would be too trivial to include.

I think several of us would be very grateful.

If, however, there have been no such successful efforts, can I suggest that the developers of this extremely promising software revisit the release for Cubox-i to confirm that it indeed supports this essential functionality?

Best regards to all.

My setup is Cubox-i4Pro using a Synology NAS. The NAS configured network mount is SMB/CIFS. The DB updates with no issue. I do have some difficulty with creating the mount as it takes several attempts before the mount presents a green check mark. I assume this behavior is just the Synology NAS waking up from sleep mode.

Thanks tracer! I really appreciate your reply and it is good to hear someone has had success in this.

Can I ask where you see the “green check” and what precedes it?

Yes… From the Volumio WebUI (MPD) start at the “Menu” located on the upper right corner of the Main page and select “Library”. This will open the page “DB sources” at the top of the page and “NAS mounts” lower down on the page. There will be a green check mark or red x to the left of the configured network mount. If the mount is active there will be a green check mark. Does this help?

Thanks again tracer.

Part of what is frustrating me is that, through the Web GUI, there are no error messages or anything when I try to create a database. When I hit the button to do so It displays a little green box with a check in it and that indicates the process is starting. Then it just fades, disappears, and nothing apparently happens. As a consequence, I am not even sure what I would look for as a sign of progress. I was hoping your experience would offer a clue.

Some additional investigation!

For the NAS mount there does not seem to be any issue for the Cubox-i4Pro in my case.

For a USB drive directly connected to the Cubox-i4Pro I find quite a different outcome. First the Cubox-i4Pro may not have enough power to operate the drive directly from the USB port and that results in no mount. If the drive requires less power than the USB port can supply or a powered USB hub is used, then the external USB HDD will mount. To see if it is mounted try this from having ssh to the Cubox-i.

fdisk -l

My result is:
root@volumio:~# fdisk -l

Disk /dev/mmcblk0: 15.7 GB, 15719727104 bytes
22 heads, 16 sectors/track, 87223 cylinders, total 30702592 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x125dde26

 Device Boot                Start         End             Blocks   Id  System

/dev/mmcblk0p1 2048 4194303 2096128 83 Linux

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sda1 2 1953525167 976762583 b W95 FAT32

Once the mount is confirmed. I go to the Volumio WebUI Library and update the MPD Database. This takes a few minutes as my NAS music library is quite large. At the conclusion of the MPD Database update I Browse to NAS, WEBRADIO, RAMPLAY, and USB. If I click on USB it opens an empty page. It seems to be empty, but I do have music on the USB drive. I can not access it. Is this a permissions issue or what? The drive is formatted FAT32 as you see from the “frisk -l” output.

I had not previously attempted this configuration, but thanks to your encouragement I now seem to be among friends with similar problems.

Success with USB external drive formatted FAT32! I am sure there will be an easier method in the future, but this does work for now!!
Attach your external USB drive to one of the USB ports on the Cubox-i and reboot. Then ssh into the Cubox-i.

See what your USB drive is called:

sudo fdisk -l

in my case:

chmod -R 777 /mnt/USB mount /dev/sda1 /mnt/USB

check to see that it is really mounted

df -h

then add this line to /etc/fstab

sudo nano /etc/fstab

/dev/sda1 /mnt/USB vfat defaults 0 0

save file and exit control O, return, control X

There is no need to add simlinks as they are already present.
Restart the Cubox-i. From the WebUI “Library” update the MPD database. You should then be able to browse the and play content from the USB drive. My USB drive has a folder named “music” with both Flac and mp3 files in it.
I hope this helps for now.

Hi tracer,

Congrats and thanks! No, this does not exactly meet the promises made of a 10 minute easy install, but at least it works and it doesn’t seem to bad.

I have never used SSH before, so I’ll have to figure that out–something like ftp, I gather–or get some help, but this is the first solid plan of action I have found yet.

Thanks again! I really appreciate your efforts.

Okay, I’ve figured out how to use SSH., but I could use a bit of further help.

My drive is called:


So I entered:

chmod -R 777 /mnt/USB
mount /dev/sda2 /mnt/USB

This mounted the drive so that when I clicked on “Update MPD Database” in the Web GUI, where “Browse” had been I then had rotating arrows and “Updating”. This took several minutes and the when I clicked 'browse" and then “USB” I could finally see my music files.

Now the question is: How do I now get this to happen whenever I start up the CuBox? That is, how do I get Volumio to mount my drive automatically?

My drive is formatted NTFS.

I assume that I need to add a line to /etc/fstab ?

If so, where? At the start? At the end?

Would this line, extrapolating form the one you added, perhaps be:

/dev/sda2 /mnt/USB ntfs defaults 0 0

Thanks a ton!

Hi Shriekback,
I too am just another user with a very little Linux experience.

Your USB mount point is already created. It is /mnt/USB My drives are all formatted FAT32 in order to simplify the complexities of permissions and I do not change hardware for now as I believe all of this will be unnecessary in the future. NTFS can be a bit more complex. First of all, you can edit the /etc/fstab file and add your code anywhere in the file. I usually add code after all the comment lines and near the end. A comment line starts with a #.
If you add the line:

/dev/sda2 /mnt/USB ntfs defaults 0 2

to the /etc/fstab file it will likely work upon reboots as long as you do not change the hardware. The order the filesystem is checked at boot time is the 2 (2 here says do it after the boot drive).

As you add and remove USB drives from your system, Linux won’t guarantee to always create the same block file to represent the same drive. In these cases, the configuration you have specified above may not be suitable, and the files you expect may not appear under the mount point directory. To fix this, you need to use the ‘blkid’ utility.

sudo blkid 

This lists both Universally Unique IDentifiers (UUID) and LABELS which are associated with your drive. These are specific to your drive, and are guaranteed never to change as you add and remove the drive. You can use these in the /etc/fstab file to create a more robust mounting mechanism.

You can change the line we added earlier in the /etc/fstab file to the following for the same result (using your drives UUID of course):
This is an example!

UUID=734dff8e-1bb7-49b34-be98-776e38f97857    /mnt/USB    ntfs 


LABEL=IOMEGA     /mnt/USB    ntfs    defaults    0    2  

I would recommend reading the manual pages for fstab and mount as they work together to enable easier configuration of how your drives files are mounted, which users should be able to mount drives, and what the default permissions for mounted files are going to be. These are options which you can specify in the fstab file and which are passed to mount when the drive is being added.

That worked perfectly!

Thanks so much tracer. You have been enormously helpful and I sincerely appreciate all the effort you put into explaining how to do this in a way someone with very little relevant experience could follow. I hope it helps others too.

Very best regards,

Steven (Shriekback)

I read the thread carefully but for me it’s impossible to update my DB. I’ve a Nas Synology with NFS protocol but nohing! Volumio doesn’t want update my library. On Volumio GUI I see my Nas with green sign, but when I try to update my library everything crashes after 15-30 seconds.
It’s weird, because I have a Raspberry and with Volumio everything is OK (my Nas is see with NFS protocol without problem).
Another thing, Volumio with Cubox-I doesn’t see my USB audio output, but only Spdif and Hdmi (Teac UD-H01). On the contrary with Raspberry everything was Ok.
GRoaann!!! :imp: