Volumio & BubbleUPnP Server on the same RPi

Hallo there,
I’m starting this thread as I would like to run Volumio and BubbleUPnP server on the same RPi unit, but I’m not an linux engineer, so I’m searching for some convenient method. Currently, I run Volumio on RPi and BubbleUPnP on separate Android TV box, which works fine, but I’d like to make simpler setup. I suppose, performance-wise, RPi 3 shouldn’t have any problem running both. Also, I do not want to start BubbleUPnP every time manually after Volumio restart (happens sometimes due to power failure or other reasons). If necessary, I can work with command line, but do not wish to do so after every restart.

Why I want such setup? Because I’m mainly streaming from Tidal using Lumin application (Open Home compatible) on iPhone. But without BubbleUPnP server I wasn’t able to setup Tidal account in the application. Alternatively, if you, guys, know other method how to stream from Tidal to Volumio (w/o BubbleUPnP server), I’m interested to hear about it.

Thanks in advance of any hint.

Trying to achieve the same thing. Just posted in the Help forum.

Hope to see some solutions soon.

Have you found anything?

No, I haven’t found any solution. In fact, I didn’t spend lot of time with it. I tried to run Picore Player + Squeeze box app, but it’s lot more difficult to setup and not so user friendly.

I found possible solution based on Open Home Player (see http://openhome.org/pages/use/downloads/pi.html), which is a software package you can install on standard Rpi Linux. Unfortunately that means you will leave Volumio GUI. But then you can order internet radio or Tidal streams from mobile application (Linn Kazoo or Lumin) and Rpi plays it to back to sound output of the Rpi even when you close the control application. I tried that in the meantime on my Mac and it really works.

1 Like

Upmpdcli is the OpenHome implementation used by Volumio. It has plugins for Tidal, Qobuz, … But those are not installed by default (as far as I can tell). Installation is easy.

 sudo apt-get install upmpdcli-tidal

To configure it, you’ll need to edit /volumio/app/plugins/audio_interface/upnp/upmpdcli.conf.tmpl according to the instructions at the above website and then reboot.

Latest version of upmpdcli is already part of Volumio system. So the install instruction does nothing. But to change the config file - that’s another story. Seems like I need to go to bookstore of “Linux for dummies”. I have no idea how to edit it in command line. My fault.

Upmpdcli is installed but not (at least not on my system) the plugin(s) for Tidal (etc).

The default editor installed with Volumio is called “nano”. When you read instructions on these forums which say, “nano [this]” or “nano [that]”, that’s what they’re talking about.

I don’t know how to find out if Tidal plug in is installed, but after entering the suggested command, the result is “already installed”.

I tried nano under user “volumio”, unfortunately for saving the conf file another user is needed. Root?
Also, there is lots of lines in the file starting with #. The usually means the line is “commented” and not active, right? But I wasn’t sure at which lines exactly the # delete. This whole thing is too complex for such an audiophile BFU as myself.

Sorta. What you need to do is “sudo nano” instead of “nano” (you will be prompted for User volumio’s password; then you can do what you want).

As to the commented lines, I think you want to leave those commented.

What you want to do is add lines supplying the configuration options described here. (I’d suggest adding them at the bottom of the file, just so you can easily remember where your changes are.)