Volumio + Boss + Innbox v45 + DAP-1320 = no connection


I’ve been experiencing connection problems for some time now, but it seems to be getting worse last few days.

My setup:

  1. Rpi 3B + Allo Boss DAC + 16GB SanDisk class10 microSD
  2. Latest Volumio
  3. Wireless router Iskratel Innbox v45
  4. Wireless Extender D-link DAP-1320
  5. keyboard attached to RPi USB (just for troubleshooting)
  6. HDMI dislpay attached to RPi (just for troubleshooting)

First of all, I’d like to state that I have no issues on other multiple devices connecting wireless in same way.

The problem:
At first, everything was working fine. Then I started to loose connection (volumio.local not available in browser), and after some time it would come back by itself and reconnect. Music would resume. Then, after some time, after the connection has been lost it wouldn’t reconnect by itself and I had to unplug the RPi to get it to reboot and connect to browser UI. This slowly started to happen a lot, and today I couldn’t connect at all anymore. So I reflashed the newest Volumio.

After I did, it booted. I had to put in the user and pass. And I got the hotspot. I entered the volumio UI. Set up the network. After that, it restarted and all the problems started form scratch. At first it wouldn’t connect at all. Then I unplugged and replugged the RPi power and I managed to get the connection for few seconds, after which it went away. It worked the next time after rebooting, but when I tried to setup the allo boss dac in UI, it prompted to restart, and after restart it wouldn’t connect anymore. Rebooting helps, but after few seconds I loose connection.

During all this time, via HDMI, on my display I can see the Volumio terminal asking for login info. The red status led is constantly red. The green status led flashes shortly every 10 seconds precisely.

This is the log report that I managed to create in the short period when connection was working;

Any solution, or advice for my suffering?

That’s weird, because I also have the RPI3B and Boss Dac and don’t experience those things.
I’m using latest Volumio with Allo PSU (5v 3A) and a TP Link Router (WR1042ND).
I don’t use a repeater, have one, but this could be your problem. When I used it my Chromecast suffered from loosing connection.

I’d be inclined to think so too, if I didn’t have a laptop, 2 desktop workstations, mobile phone, tablet and tv connected to the same repeater without any issues. Also, for a few months this setup was working fine for me on Volumio too. Only recently have I experienced first trouble with disconnecting. I can’t pinpoint the exact moment. Maybe after a certain update?

I moved my Rpi closer to router, so I didn’t have to use the repeater and the Volumio still refuses to connect. Now the rebooting doesn’t help at all. Also, a fresh install didn’t help. Volumio hotspot doesn’t seem to be activating.
I tried installing DietPi instead, and the Wifi doesn’t work there either. The message says “no wifi hardware found”.

I can connect to my router via ethernet cable directly and get into Volumio UI which seems to be working. There I find the Wireless mode OFF, and hotspot OFF. If I turn the Wireless or Hotspot “ON”. Nothing happens except that I get “Network successfully restarted” notification twice. No Volumio hotspot is visible on any other devices. If I refresh the Volumio WEB UI, both Wireless and Hotspot go back to OFF.

Here is the dev log report after I have connected to Volumio UI via ethernet and tried to manually turn Wireless and hotspot “ON”:


Could it be that my WiFi module on Rpi3 ModelB was dying and now is actually dead? Is there a way I can tell if it is so?

I just stuck in the USB WiFi dongle, and everything works like a charm. So it is the Rpi3 WiFi/Bluetooth module that dropped dead, and actually sucked big time from the start. And now, in retrospective, probably all the unresolved issues that I had so far;


…were probably caused by the bad WiFi module in one way or another.
I wish there was some sort of support and guidance that would’ve driven me to that conclusion before I spent countless hours trying to find out.

Well…Der Lauf der Dinge.